summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-11-09 12:26:29 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-09 12:35:29 +0100
commit5768dda687dd23a0ffb2c45d432cd2f609875ad1 (patch)
tree0a9de70a70189486e6a0d068448cb4d52f38e52f
parent511cdb8182b29e397d11a05b2dec5b8c6e828051 (diff)
downloadmeta-openembedded-5768dda687dd23a0ffb2c45d432cd2f609875ad1.tar.gz
ktap: add libelf PACKAGECONFIG also to ktap-module
* building ktap-module without elfutils fails with: ktap-module/0.4-r0/git/Makefile:107: No libelf found, disables symbol resolving, please install elfutils-libelf-devel/libelf-dev Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb5
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap.inc12
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap_0.4.bb11
3 files changed, 14 insertions, 14 deletions
diff --git a/meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb b/meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb
index 62f2a99a2..64648b015 100644
--- a/meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb
+++ b/meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb
@@ -6,11 +6,8 @@ SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux"
6 6
7inherit module 7inherit module
8 8
9# Available package configs: ffi (only supported on x86_64)
10PACKAGECONFIG ?= ""
11
12# Only build the module 9# Only build the module
13MAKE_TARGETS = "${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} mod" 10MAKE_TARGETS = "mod"
14 11
15# Kernel module packages MUST begin with 'kernel-module-', otherwise 12# Kernel module packages MUST begin with 'kernel-module-', otherwise
16# multilib image generation can fail. 13# multilib image generation can fail.
diff --git a/meta-oe/recipes-kernel/ktap/ktap.inc b/meta-oe/recipes-kernel/ktap/ktap.inc
index 93a4e2ca3..72538bc84 100644
--- a/meta-oe/recipes-kernel/ktap/ktap.inc
+++ b/meta-oe/recipes-kernel/ktap/ktap.inc
@@ -10,4 +10,16 @@ SRC_URI = "git://github.com/ktap/ktap.git"
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11 11
12# Package config is abused as a general compile time configuration tool. 12# Package config is abused as a general compile time configuration tool.
13
14# Only supports x86_64 for now!. Needs to be enabled for ktap-module too.
13PACKAGECONFIG[ffi] = "" 15PACKAGECONFIG[ffi] = ""
16
17# Needed to resolve symbols in DSO and for sdt
18PACKAGECONFIG[libelf] = ",,elfutils"
19
20PACKAGECONFIG ?= "libelf"
21
22EXTRA_OEMAKE = " \
23 ${@base_contains('PACKAGECONFIG', 'libelf', '', 'NO_LIBELF=1', d)} \
24 ${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} \
25"
diff --git a/meta-oe/recipes-kernel/ktap/ktap_0.4.bb b/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
index cbdabf82d..eb2bf651d 100644
--- a/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
+++ b/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
@@ -5,17 +5,8 @@ require ktap.inc
5SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux" 5SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux"
6DEPENDS = "ktap-module" 6DEPENDS = "ktap-module"
7 7
8#Available package configs:
9# libelf - needed to resolve symbols in DSO and for sdt
10# ffi - only supports x86_64 for now!. Needs to be enabled for ktap-module too.
11PACKAGECONFIG ?= "libelf"
12
13PACKAGECONFIG[libelf] = ",,elfutils"
14
15# Only build the userspace app 8# Only build the userspace app
16EXTRA_OEMAKE = "${@base_contains('PACKAGECONFIG', 'libelf', '', 'NO_LIBELF=1', d)} \ 9EXTRA_OEMAKE += "ktap"
17 ${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} \
18 ktap"
19 10
20do_install() { 11do_install() {
21 install -d ${D}${bindir} 12 install -d ${D}${bindir}