summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGary S. Robertson <gary.robertson@linaro.org>2014-11-24 16:59:14 -0600
committerArmin Kuster <akuster808@gmail.com>2014-12-26 17:58:46 -0800
commit2b524c31f7b1750e7976284b099f24c9c196c876 (patch)
tree383b181c0b8ebe3cac2d7bb3dd2c937089b2a8c5
parent1b01b3c6288df09160f0a8d28c0ab56d4eb17be1 (diff)
downloadmeta-openembedded-2b524c31f7b1750e7976284b099f24c9c196c876.tar.gz
libhugetlbfs: Make cross-devel recognize all ix86 arches
In a non-native cross-development scenario, the Makefile only recognized i386 or x86_64 PC architectures. Extended this to also recognize i486, i586, and i686 Upstream Status: Accepted but not yet applied by libhugetlbfs project Signed-off-by: Gary S. Robertson <gary.robertson@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Makefile-Recognize-all-ix86-arches.patch32
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Makefile-Recognize-all-ix86-arches.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Makefile-Recognize-all-ix86-arches.patch
new file mode 100644
index 000000000..271827511
--- /dev/null
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Makefile-Recognize-all-ix86-arches.patch
@@ -0,0 +1,32 @@
1From a0166583ba5f7b6a6d2de434f633126fb12c9d29 Mon Sep 17 00:00:00 2001
2From: "Gary S. Robertson" <gary.robertson@linaro.org>
3Date: Wed, 24 Sep 2014 15:27:31 -0500
4Subject: [PATCH] Makefile: Recognize all ix86 arches
5
6In a non-native build scenario, the makefile
7only recognized i386 or x86_64 arches. Added support
8to recognize i486, i586, i686.
9
10Upstream Status: Accepted by libhugetlbfs project
11
12Signed-off-by: Gary S. Robertson <gary.robertson@linaro.org>
13---
14 Makefile | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/Makefile b/Makefile
18index 91502e1..0bfaee8 100644
19--- a/Makefile
20+++ b/Makefile
21@@ -71,7 +71,7 @@ ELF64 = aarch64elf
22 TMPLIB64 = lib64
23 CUSTOM_LDSCRIPTS = no
24 else
25-ifeq ($(ARCH),i386)
26+ifneq (,$(filter i386 i486 i586 i686,$(ARCH)))
27 CC32 = $(CC)
28 ELF32 = elf_i386
29 TMPLIB32 = lib
30--
311.7.9.5
32
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
index c2262eaaa..c90621703 100644
--- a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
@@ -19,6 +19,7 @@ SRC_URI = "git://git.code.sf.net/p/libhugetlbfs/code \
19 file://0001-aarch64-fix-page-size-not-properly-computed.patch \ 19 file://0001-aarch64-fix-page-size-not-properly-computed.patch \
20 file://0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch \ 20 file://0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch \
21 file://0001-Extend-arm32-support-to-include-BE-variants.patch \ 21 file://0001-Extend-arm32-support-to-include-BE-variants.patch \
22 file://0001-Makefile-Recognize-all-ix86-arches.patch \
22" 23"
23 24
24S = "${WORKDIR}/git" 25S = "${WORKDIR}/git"