summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2014-12-18 13:40:44 -0500
committerArmin Kuster <akuster808@gmail.com>2015-03-16 18:27:03 -0700
commit2867c7f8edbade8e5c177e4a2ce3dcbc5a825d44 (patch)
tree987749824ebd395a2e5ee60c1069e3611e420e77
parentf9480d4a2d1c5e47a29255e981d80b12f9b1edf3 (diff)
downloadmeta-openembedded-2867c7f8edbade8e5c177e4a2ce3dcbc5a825d44.tar.gz
sip: Update to 4.14.2.
The sip configure.py script now has some support for cross compiling. This allowed simplication of the existing OpenEmbedded sip support. The sip recipe now produces support for builds via sip-native and target runtime via sip. This has been build and runtime tested on the zedboard and ettus-e300. Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/python/python-sip_4.14.2.bb46
-rw-r--r--meta-oe/recipes-extended/sip/sip-native_4.14.2.bb35
-rw-r--r--meta-oe/recipes-extended/sip/sip_4.16.4.bb50
3 files changed, 50 insertions, 81 deletions
diff --git a/meta-oe/recipes-devtools/python/python-sip_4.14.2.bb b/meta-oe/recipes-devtools/python/python-sip_4.14.2.bb
deleted file mode 100644
index acabc9721..000000000
--- a/meta-oe/recipes-devtools/python/python-sip_4.14.2.bb
+++ /dev/null
@@ -1,46 +0,0 @@
1SUMMARY = "Runtime helper for sip-generated python wrapper libraries"
2SECTION = "devel/python"
3HOMEPAGE = "http://www.riverbankcomputing.co.uk/sip"
4AUTHOR = "Phil Thompson"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://siplib.sbf.in;endline=15;md5=3d462bd8cb43db3e4be998fe155ae9cf"
7DEPENDS = "python"
8RDEPENDS_${PN} = "python-core"
9
10# riverbankcomputing is upstream, but keeps only latest version, sf usually have few older
11#SRC_URI = "http://www.riverbankcomputing.com/static/Downloads/sip4/sip-${PV}.tar.gz"
12SRC_URI = "${SOURCEFORGE_MIRROR}/project/pyqt/sip/sip-${PV}/sip-${PV}.tar.gz"
13SRC_URI[md5sum] = "b93442e745b3be2fad89de0686a76ce9"
14SRC_URI[sha256sum] = "1a9d3bf26c821f369c175f8e68946b79bc994da4f96e8f5ecff06e6ee7ac0528"
15
16S = "${WORKDIR}/sip-${PV}/siplib"
17
18inherit qt4x11 distutils-base
19
20EXTRA_QMAKEVARS_POST += " TEMPLATE=lib \
21 CONFIG=console \
22 DESTDIR= \
23 VERSION=1.0.0 \
24 TARGET=sip \
25 DEFINES=SIP_QT_SUPPORT \
26 INCLUDEPATH+=. \
27 INCLUDEPATH+=${STAGING_INCDIR}/${PYTHON_DIR} \
28 INCLUDEPATH+=${STAGING_INCDIR}"
29
30
31do_configure_prepend() {
32 cat siplib.sbf.in | sed s,target,TARGET, | sed s,sources,SOURCES, | sed s,headers,HEADERS, | sed s,@CFG_MODULE_BASENAME@,sip, > siplib.pro
33 cat siplib.c.in | sed s,@CFG_MODULE_BASENAME@,sip, > siplib.c
34 cat sip.h.in | sed -e s,@CFG_MODULE_NAME@,sip,g > sip.h
35}
36
37do_install() {
38 install -d ${D}${libdir}/${PYTHON_DIR}/site-packages/
39 install -m 0755 libsip.so.1.0.0 ${D}${libdir}/${PYTHON_DIR}/site-packages/sip.so
40 # sipconfig.py sipdistutils.py
41 install -d ${D}${includedir}
42 install -m 0644 ../siplib/sip.h ${D}${includedir}/sip.h
43}
44
45FILES_${PN} = "${libdir}/${PYTHON_DIR}/site-packages/sip.so"
46
diff --git a/meta-oe/recipes-extended/sip/sip-native_4.14.2.bb b/meta-oe/recipes-extended/sip/sip-native_4.14.2.bb
deleted file mode 100644
index 602dc250f..000000000
--- a/meta-oe/recipes-extended/sip/sip-native_4.14.2.bb
+++ /dev/null
@@ -1,35 +0,0 @@
1SUMMARY = "SIP is a C++/Python Wrapper Generator"
2AUTHOR = "Phil Thompson"
3HOMEPAGE = "http://www.riverbankcomputing.co.uk/sip"
4SECTION = "devel"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://sipgen.sbf;endline=15;md5=61b2ce7ddd624968411804d2fa9d776c"
7
8# riverbankcomputing is upstream, but keeps only latest version, sf usually have few older
9#SRC_URI = "http://www.riverbankcomputing.com/static/Downloads/sip4/sip-${PV}.tar.gz"
10SRC_URI = "${SOURCEFORGE_MIRROR}/project/pyqt/sip/sip-${PV}/sip-${PV}.tar.gz"
11SRC_URI[md5sum] = "b93442e745b3be2fad89de0686a76ce9"
12SRC_URI[sha256sum] = "1a9d3bf26c821f369c175f8e68946b79bc994da4f96e8f5ecff06e6ee7ac0528"
13S = "${WORKDIR}/sip-${PV}/sipgen"
14
15inherit qmake2 native python-dir
16
17EXTRA_QMAKEVARS_POST += "DESTDIR=${S} CONFIG=console"
18
19export BUILD_SYS
20export HOST_SYS
21export STAGING_LIBDIR
22export STAGING_INCDIR
23
24do_configure_prepend() {
25 cat sipgen.sbf | sed s,target,TARGET, | sed s,sources,SOURCES, | sed s,headers,HEADERS, > sipgen.pro
26}
27do_install() {
28 install -d ${D}${bindir}
29 install -m 0755 sip ${D}${bindir}/sip
30 # python-pyqt expects sip4
31 ln -sf sip ${D}${bindir}/sip4
32 cd ${WORKDIR}/sip-${PV} && python configure.py
33 install -d ${D}${PYTHON_SITEPACKAGES_DIR}
34 install -m 0755 sip*.py ${D}${PYTHON_SITEPACKAGES_DIR}
35}
diff --git a/meta-oe/recipes-extended/sip/sip_4.16.4.bb b/meta-oe/recipes-extended/sip/sip_4.16.4.bb
new file mode 100644
index 000000000..2a2674f91
--- /dev/null
+++ b/meta-oe/recipes-extended/sip/sip_4.16.4.bb
@@ -0,0 +1,50 @@
1SUMMARY = "SIP is a C++/Python Wrapper Generator"
2AUTHOR = "Phil Thompson"
3HOMEPAGE = "http://www.riverbankcomputing.co.uk/sip"
4SECTION = "devel"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://LICENSE-GPL2;md5=e91355d8a6f8bd8f7c699d62863c7303"
7DEPENDS_class-target = "qt4-x11-free python"
8
9# riverbankcomputing is upstream, but keeps only latest version, sf usually have few older
10#SRC_URI = "http://www.riverbankcomputing.com/static/Downloads/sip4/sip-${PV}.tar.gz"
11SRC_URI = "${SOURCEFORGE_MIRROR}/project/pyqt/sip/sip-${PV}/sip-${PV}.tar.gz"
12SRC_URI[md5sum] = "a9840670a064dbf8f63a8f653776fec9"
13SRC_URI[sha256sum] = "ceda443fc5e129e67a067e2cd7b73ff037f8b10b50e407baa2b1d9f2199d57f5"
14
15BBCLASSEXTEND = "native"
16
17inherit qmake2 python-dir pythonnative
18
19EXTRA_QMAKEVARS_POST += "CONFIG=console"
20
21export BUILD_SYS
22export HOST_SYS
23export STAGING_LIBDIR
24export STAGING_INCDIR
25
26do_configure_prepend_class-target() {
27 echo "py_platform = linux" > sip.cfg
28 echo "py_inc_dir = %(sysroot)/${includedir}/python%(py_major).%(py_minor)" >> sip.cfg
29 echo "sip_bin_dir = ${D}/${bindir}" >> sip.cfg
30 echo "sip_inc_dir = ${D}/${includedir}" >> sip.cfg
31 echo "sip_module_dir = ${D}/${libdir}/python%(py_major).%(py_minor)/site-packages" >> sip.cfg
32 echo "sip_sip_dir = ${D}/${datadir}/sip" >> sip.cfg
33 python configure.py --use-qmake --configuration sip.cfg --sysroot ${STAGING_DIR_HOST}
34}
35do_configure_prepend_class-native() {
36 echo "py_platform = linux" > sip.cfg
37 echo "py_inc_dir = ${includedir}/python%(py_major).%(py_minor)" >> sip.cfg
38 echo "sip_bin_dir = ${D}/${bindir}" >> sip.cfg
39 echo "sip_inc_dir = ${D}/${includedir}" >> sip.cfg
40 echo "sip_module_dir = ${D}/${libdir}/python%(py_major).%(py_minor)/site-packages" >> sip.cfg
41 echo "sip_sip_dir = ${D}/${datadir}/sip" >> sip.cfg
42 python configure.py --use-qmake --configuration sip.cfg --sysroot ${STAGING_DIR_NATIVE}
43}
44do_install() {
45 oe_runmake install
46}
47
48FILES_${PN} += "${libdir}/${PYTHON_DIR}/site-packages/"
49FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug"
50