summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-01-18 11:41:25 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-01-18 11:41:25 +0100
commit2414ce31087fa910437cae45703c3b13a5daf5a9 (patch)
treeb1c8a6c5307d020b963136d9823fed015844e5f2
parent898fc9f4c9c9efbcd50ce53e29ad2fb54b09eb21 (diff)
downloadmeta-openembedded-2414ce31087fa910437cae45703c3b13a5daf5a9.tar.gz
gcc: import yocto rev 0df3c481309e89b93e8a57773eb9c470b4dd13a7
From: Dexuan Cui <dexuan.cui@intel.com> Date: Sat, 15 Jan 2011 10:47:50 +0000 Subject: libgcc: use the new recipe (rather than gcc-runtime) to install libgcc_s.so* and crt*.o Currently gcc-runtime installs the files, but actually gcc-runtime's do_configure checks if the files are available, so before we build gcc-runtime, we should have some recipe install the files first! -- currently gcc-cross-intermediate actually does that(gcc-cross also installs the files, but it installs into the gcc-build-internal* directory), but gcc-cross-intermediate will have its own sysroot in future, after that, gcc-runtime won't build. So let us add this new target recipe and move the installation of the files from gcc-runtime into it changed to apply to gcc 4.5 Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--recipes-devtools/gcc/gcc-4.5.inc2
-rw-r--r--recipes-devtools/gcc/gcc-configure-runtime.inc16
-rw-r--r--recipes-devtools/gcc/gcc-package-runtime.inc8
-rw-r--r--recipes-devtools/gcc/libgcc_4.5.bb42
4 files changed, 44 insertions, 24 deletions
diff --git a/recipes-devtools/gcc/gcc-4.5.inc b/recipes-devtools/gcc/gcc-4.5.inc
index 793c7513d..fd36b3937 100644
--- a/recipes-devtools/gcc/gcc-4.5.inc
+++ b/recipes-devtools/gcc/gcc-4.5.inc
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
14 14
15SRCREV = "168622" 15SRCREV = "168622"
16PV = "4.5" 16PV = "4.5"
17INC_PR = "r30" 17INC_PR = "r31"
18 18
19# BINV should be incremented after updating to a revision 19# BINV should be incremented after updating to a revision
20# after a minor gcc release (e.g. 4.5.1 or 4.5.2) has been made 20# after a minor gcc release (e.g. 4.5.1 or 4.5.2) has been made
diff --git a/recipes-devtools/gcc/gcc-configure-runtime.inc b/recipes-devtools/gcc/gcc-configure-runtime.inc
index f9ad61d12..6cc11e2ff 100644
--- a/recipes-devtools/gcc/gcc-configure-runtime.inc
+++ b/recipes-devtools/gcc/gcc-configure-runtime.inc
@@ -31,28 +31,14 @@ do_compile () {
31} 31}
32 32
33do_install () { 33do_install () {
34 target=`echo ${MULTIMACH_TARGET_SYS} | sed -e s#-nativesdk##`
35
36 # Install libgcc from our gcc-cross saved data
37 install -d ${D}${base_libdir} ${D}${libdir}
38 cp -fpPR ${STAGING_INCDIR_NATIVE}/gcc-build-internal-$target/* ${D}
39
40 for d in ${RUNTIMETARGET}; do 34 for d in ${RUNTIMETARGET}; do
41 cd ${B}/$d/ 35 cd ${B}/$d/
42 oe_runmake 'DESTDIR=${D}' install 36 oe_runmake 'DESTDIR=${D}' install
43 done 37 done
44
45 # Move libgcc_s into /lib
46 mkdir -p ${D}${base_libdir}
47 if [ -f ${D}${libdir}/nof/libgcc_s.so ]; then
48 mv ${D}${libdir}/nof/libgcc* ${D}${base_libdir}
49 else
50 mv ${D}${libdir}/libgcc* ${D}${base_libdir} || true
51 fi
52} 38}
53 39
54INHIBIT_DEFAULT_DEPS = "1" 40INHIBIT_DEFAULT_DEPS = "1"
55DEPENDS = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++" 41DEPENDS = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++ libgcc"
56PROVIDES = "virtual/${TARGET_PREFIX}compilerlibs" 42PROVIDES = "virtual/${TARGET_PREFIX}compilerlibs"
57 43
58BBCLASSEXTEND = "nativesdk" 44BBCLASSEXTEND = "nativesdk"
diff --git a/recipes-devtools/gcc/gcc-package-runtime.inc b/recipes-devtools/gcc/gcc-package-runtime.inc
index 40a9ed0d7..e8c901131 100644
--- a/recipes-devtools/gcc/gcc-package-runtime.inc
+++ b/recipes-devtools/gcc/gcc-package-runtime.inc
@@ -1,6 +1,4 @@
1PACKAGES = "\ 1PACKAGES = "\
2 libgcc \
3 libgcc-dev \
4 libstdc++ \ 2 libstdc++ \
5 libstdc++-precompile-dev \ 3 libstdc++-precompile-dev \
6 libstdc++-dev \ 4 libstdc++-dev \
@@ -14,12 +12,6 @@ PACKAGES = "\
14 libmudflap-dev \ 12 libmudflap-dev \
15" 13"
16 14
17FILES_libgcc = "${base_libdir}/libgcc*.so.*"
18FILES_libgcc-dev = " \
19 ${base_libdir}/libgcc*.so \
20 ${libdir}/${TARGET_SYS}/${BINV}/crt* \
21 ${libdir}/${TARGET_SYS}/${BINV}/libgcc*"
22
23FILES_libg2c = "${target_libdir}/libg2c.so.*" 15FILES_libg2c = "${target_libdir}/libg2c.so.*"
24FILES_libg2c-dev = "\ 16FILES_libg2c-dev = "\
25 ${libdir}/libg2c.so \ 17 ${libdir}/libg2c.so \
diff --git a/recipes-devtools/gcc/libgcc_4.5.bb b/recipes-devtools/gcc/libgcc_4.5.bb
new file mode 100644
index 000000000..a99fdeffd
--- /dev/null
+++ b/recipes-devtools/gcc/libgcc_4.5.bb
@@ -0,0 +1,42 @@
1require gcc-${PV}.inc
2
3PR = "r0"
4
5INHIBIT_DEFAULT_DEPS = "1"
6DEPENDS = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
7
8PACKAGES = "\
9 ${PN} \
10 ${PN}-dev \
11 "
12
13FILES_${PN} = "${base_libdir}/libgcc*.so.*"
14FILES_${PN}-dev = " \
15 ${base_libdir}/libgcc*.so \
16 ${libdir}/${TARGET_SYS}/${BINV}/crt* \
17 ${libdir}/${TARGET_SYS}/${BINV}/libgcc*"
18
19do_fetch[noexec] = "1"
20do_unpack[noexec] = "1"
21do_patch[noexec] = "1"
22do_configure[noexec] = "1"
23do_compile[noexec] = "1"
24
25do_install () {
26 target=`echo ${MULTIMACH_TARGET_SYS} | sed -e s#-nativesdk##`
27
28 # Install libgcc from our gcc-cross saved data
29 install -d ${D}${base_libdir} ${D}${libdir}
30 cp -fpPR ${STAGING_INCDIR_NATIVE}/gcc-build-internal-$target/* ${D}
31
32 # Move libgcc_s into /lib
33 mkdir -p ${D}${base_libdir}
34 if [ -f ${D}${libdir}/nof/libgcc_s.so ]; then
35 mv ${D}${libdir}/nof/libgcc* ${D}${base_libdir}
36 else
37 mv ${D}${libdir}/libgcc* ${D}${base_libdir} || true
38 fi
39}
40
41BBCLASSEXTEND = "nativesdk"
42