summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2015-02-18 22:50:36 -0800
committerArmin Kuster <akuster808@gmail.com>2015-03-21 07:57:31 -0700
commit1379cdd22c26c123ba994209319c29a23b4f794d (patch)
treecef23d66761d158b7b19544265e515878c6b8575
parent66ca394c5b0b597b9eaaa22f8bf9fc924ef9ab54 (diff)
downloadmeta-openembedded-1379cdd22c26c123ba994209319c29a23b4f794d.tar.gz
log4c: fix undeclared dependency on expat
The original log4c configure.in is buggy and requires fixing before "configure --with-expat" works as expected. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/log4c/log4c/fix_configure_with-expat.patch21
-rw-r--r--meta-oe/recipes-support/log4c/log4c_1.2.4.bb13
2 files changed, 27 insertions, 7 deletions
diff --git a/meta-oe/recipes-support/log4c/log4c/fix_configure_with-expat.patch b/meta-oe/recipes-support/log4c/log4c/fix_configure_with-expat.patch
new file mode 100644
index 000000000..4872eb4f5
--- /dev/null
+++ b/meta-oe/recipes-support/log4c/log4c/fix_configure_with-expat.patch
@@ -0,0 +1,21 @@
1The original use of AC_ARG_WITH is buggy and causes expat support
2to be *disabled* if "--with-expat" is passed to configure.
3
4Upstream status: pending
5
6Index: log4c-1.2.4/configure.in
7===================================================================
8--- log4c-1.2.4.orig/configure.in
9+++ log4c-1.2.4/configure.in
10@@ -217,9 +217,9 @@ AC_ARG_WITH(expat,
11 have any effect and Log4C uses some bundled yacc/lex code
12 for parsing it's configuration file.
13 ]),
14- with_expat=no,
15+ [],
16 with_expat=yes)
17-if test x$with_expat = xyes ; then
18+if test x$with_expat != xno ; then
19 use_expat=yes
20 AM_PATH_EXPAT(1.95.1)
21 fi
diff --git a/meta-oe/recipes-support/log4c/log4c_1.2.4.bb b/meta-oe/recipes-support/log4c/log4c_1.2.4.bb
index 43e074699..ea75757f8 100644
--- a/meta-oe/recipes-support/log4c/log4c_1.2.4.bb
+++ b/meta-oe/recipes-support/log4c/log4c_1.2.4.bb
@@ -1,16 +1,15 @@
1SUMMARY = "Logging Framework for C" 1SUMMARY = "Log4c is a C library for flexible logging to files, syslog and other destinations"
2HOMEPAGE = "http://log4c.sourceforge.net" 2HOMEPAGE = "http://log4c.sourceforge.net"
3LICENSE = "LGPLv2" 3LICENSE = "LGPLv2"
4
5LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" 4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
6 5
7SRC_URI = "http://cznic.dl.sourceforge.net/project/log4c/log4c/${PV}/log4c-${PV}.tar.gz" 6SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz \
7 file://fix_configure_with-expat.patch"
8
8SRC_URI[md5sum] = "0d94919136e1d16b68427562e74cb3dd" 9SRC_URI[md5sum] = "0d94919136e1d16b68427562e74cb3dd"
9SRC_URI[sha256sum] = "5991020192f52cc40fa852fbf6bbf5bd5db5d5d00aa9905c67f6f0eadeed48ea" 10SRC_URI[sha256sum] = "5991020192f52cc40fa852fbf6bbf5bd5db5d5d00aa9905c67f6f0eadeed48ea"
10 11
11S = "${WORKDIR}/${PN}-${PV}" 12PACKAGECONFIG ??= "expat"
12 13PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat"
13EXTRA_OECONF = "--prefix=/usr"
14 14
15inherit autotools 15inherit autotools
16