summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-07-13 09:11:53 +0000
committerEric Bénard <eric@eukrea.com>2012-07-13 11:27:18 +0200
commite1a710624225537547936b07d7a2d45e2fd5ed17 (patch)
treef38417b01d8d408e3bb35ac87d52ba7d91d05adc
parentd1a498886b08b8c3efd75fc255bc731a4d530e4a (diff)
downloadmeta-openembedded-e1a710624225537547936b07d7a2d45e2fd5ed17.tar.gz
bootchart: update to v1.16
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
-rw-r--r--meta-oe/recipes-devtools/bootchart/bootchart/0001-svg-add-rudimentary-support-for-ARM-cpuinfo.patch49
-rw-r--r--meta-oe/recipes-devtools/bootchart/bootchart/0002-svg-open-etc-os-release-and-use-PRETTY_NAME-for-the-.patch39
-rw-r--r--meta-oe/recipes-devtools/bootchart/bootchart_git.bb16
3 files changed, 99 insertions, 5 deletions
diff --git a/meta-oe/recipes-devtools/bootchart/bootchart/0001-svg-add-rudimentary-support-for-ARM-cpuinfo.patch b/meta-oe/recipes-devtools/bootchart/bootchart/0001-svg-add-rudimentary-support-for-ARM-cpuinfo.patch
new file mode 100644
index 000000000..0494c4f78
--- /dev/null
+++ b/meta-oe/recipes-devtools/bootchart/bootchart/0001-svg-add-rudimentary-support-for-ARM-cpuinfo.patch
@@ -0,0 +1,49 @@
1From 8d40b4c286e005e82fa50b66fbbbde22b7e65e15 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Sun, 20 May 2012 21:35:34 +0200
4Subject: [PATCH 1/2] svg: add rudimentary support for ARM cpuinfo
5
6On ARM /proc/cpuinfo looks like this:
7
8root@beagleboneA3-0428:~# cat /proc/cpuinfo
9Processor : ARMv7 Processor rev 2 (v7l)
10BogoMIPS : 498.89
11Features : swp half thumb fastmult vfp edsp thumbee neon vfpv3 tls
12CPU implementer : 0x41
13CPU architecture: 7
14CPU variant : 0x3
15CPU part : 0xc08
16CPU revision : 2
17
18Hardware : am335xevm
19Revision : 0000
20Serial : 0000000000000000
21
22So no real way to get the actual SoC name, TI AM3359, but a lot better than 'Unknown'
23
24Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
25---
26
27Upstream-status: submitted
28
29 svg.c | 4 ++++
30 1 file changed, 4 insertions(+)
31
32diff --git a/svg.c b/svg.c
33index 80e0292..53724b2 100644
34--- a/svg.c
35+++ b/svg.c
36@@ -178,6 +178,10 @@ void svg_title(void)
37 strncpy(cpu, &buf[13], 255);
38 break;
39 }
40+ if (strstr(buf, "Processor")) {
41+ strncpy(cpu, &buf[12], 255);
42+ break;
43+ }
44 }
45 fclose(f);
46 }
47--
481.7.10
49
diff --git a/meta-oe/recipes-devtools/bootchart/bootchart/0002-svg-open-etc-os-release-and-use-PRETTY_NAME-for-the-.patch b/meta-oe/recipes-devtools/bootchart/bootchart/0002-svg-open-etc-os-release-and-use-PRETTY_NAME-for-the-.patch
new file mode 100644
index 000000000..b3bda4582
--- /dev/null
+++ b/meta-oe/recipes-devtools/bootchart/bootchart/0002-svg-open-etc-os-release-and-use-PRETTY_NAME-for-the-.patch
@@ -0,0 +1,39 @@
1From e3adb4c312c6ba3491b7c173559efac7a53e5abc Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Sun, 20 May 2012 22:12:29 +0200
4Subject: [PATCH 2/2] svg: open /etc/os-release and use PRETTY_NAME for the
5 'Build' name
6
7Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
8---
9
10Upstream-status: Submitted
11
12 svg.c | 11 +++++++++++
13 1 file changed, 11 insertions(+)
14
15diff --git a/svg.c b/svg.c
16index 53724b2..c675d84 100644
17--- a/svg.c
18+++ b/svg.c
19@@ -194,6 +194,17 @@ void svg_title(void)
20 fclose(f);
21 }
22
23+ f = fopen("/etc/os-release", "r");
24+ if(f) {
25+ while (fgets(buf, 255, f)) {
26+ if (strstr(buf, "PRETTY_NAME=")) {
27+ strncpy(build, &buf[12], 255);
28+ break;
29+ }
30+ }
31+ fclose(f);
32+ }
33+
34 svg("<text class=\"t1\" x=\"0\" y=\"30\">Bootchart for %s - %s</text>\n",
35 uts.nodename, date);
36 svg("<text class=\"t2\" x=\"20\" y=\"50\">System: %s %s %s %s</text>\n",
37--
381.7.10
39
diff --git a/meta-oe/recipes-devtools/bootchart/bootchart_git.bb b/meta-oe/recipes-devtools/bootchart/bootchart_git.bb
index 62705f6e5..f5ef58268 100644
--- a/meta-oe/recipes-devtools/bootchart/bootchart_git.bb
+++ b/meta-oe/recipes-devtools/bootchart/bootchart_git.bb
@@ -4,12 +4,18 @@ HOMEPAGE = "http://meego.gitorious.org/meego-developer-tools/bootchart"
4LICENSE = "GPLv2" 4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067" 5LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
6 6
7SRC_URI = "git://gitorious.org/meego-developer-tools/bootchart.git" 7PV = "1.16"
8SRCREV = "4420bc4318c4aada7c7d128105e56ecc8c84cb19" 8PR = "r1"
9PE = "1"
10
11SRC_URI = "git://gitorious.org/meego-developer-tools/bootchart.git \
12 file://0001-svg-add-rudimentary-support-for-ARM-cpuinfo.patch \
13 file://0002-svg-open-etc-os-release-and-use-PRETTY_NAME-for-the-.patch \
14 "
15
16SRCREV = "872fb107028e377eef3c0c7c8a6e0f7c32b8ebb8"
9 17
10S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
11 19
12do_install() { 20inherit autotools
13 oe_runmake install DESTDIR=${D}
14}
15 21