summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-09-17 10:58:06 +0000
committerEric Bénard <eric@eukrea.com>2012-12-16 10:50:24 +0100
commitf713db38526895eeaf97678aa0a41cb7ff641d41 (patch)
tree20214e3a0cd8ac43c6c2e0a5f0cdbdb96e853f62
parent06606bba4469492091490914bea448d8eb1df309 (diff)
downloadmeta-openembedded-f713db38526895eeaf97678aa0a41cb7ff641d41.tar.gz
systemd-systemctl-native: Add additional messages for better debugging
These messages helped me to fix the breakage of networkmanager/systemd Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
-rw-r--r--meta-oe/recipes-core/systemd/systemd-systemctl-native.bb2
-rwxr-xr-xmeta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl5
2 files changed, 6 insertions, 1 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb b/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb
index 78eb8f36b..7ca77ae18 100644
--- a/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb
+++ b/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Wrapper to enable of systemd services"
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" 4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
5 5
6PR = "r2" 6PR = "r3"
7 7
8inherit native 8inherit native
9 9
diff --git a/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl b/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl
index c4a0a3fad..46e74e847 100755
--- a/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl
+++ b/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl
@@ -1,4 +1,5 @@
1#!/bin/sh 1#!/bin/sh
2echo "Started $0 $*"
2 3
3ROOT= 4ROOT=
4 5
@@ -42,6 +43,7 @@ while [ $# != 0 ]; do
42done 43done
43 44
44for service in $services; do 45for service in $services; do
46 echo "Try to find location of $service..."
45 # find service file 47 # find service file
46 for p in $ROOT/etc/systemd/system \ 48 for p in $ROOT/etc/systemd/system \
47 $ROOT/lib/systemd/system \ 49 $ROOT/lib/systemd/system \
@@ -55,6 +57,7 @@ for service in $services; do
55 echo "'$service' couldn't be found; exiting with error" 57 echo "'$service' couldn't be found; exiting with error"
56 exit 1 58 exit 1
57 fi 59 fi
60 echo "Found $service in $service_file"
58 61
59 # create the required symbolic links 62 # create the required symbolic links
60 wanted_by=$(grep WantedBy $ROOT/$service_file \ 63 wanted_by=$(grep WantedBy $ROOT/$service_file \
@@ -63,6 +66,7 @@ for service in $services; do
63 | grep '\.target$') 66 | grep '\.target$')
64 67
65 for r in $wanted_by; do 68 for r in $wanted_by; do
69 echo "WantedBy=$r found in $service"
66 if [ "$action" = "enable" ]; then 70 if [ "$action" = "enable" ]; then
67 mkdir -p $ROOT/etc/systemd/system/$r.wants 71 mkdir -p $ROOT/etc/systemd/system/$r.wants
68 ln -s $service_file $ROOT/etc/systemd/system/$r.wants 72 ln -s $service_file $ROOT/etc/systemd/system/$r.wants
@@ -79,6 +83,7 @@ for service in $services; do
79 | sed 's,Also=,,g' \ 83 | sed 's,Also=,,g' \
80 | tr ',' '\n') 84 | tr ',' '\n')
81 for a in $also; do 85 for a in $also; do
86 echo "Also=$a found in $service"
82 if [ "$action" = "enable" ]; then 87 if [ "$action" = "enable" ]; then
83 $0 --root=$ROOT enable $a 88 $0 --root=$ROOT enable $a
84 fi 89 fi