summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-09-17 10:58:07 +0000
committerEric Bénard <eric@eukrea.com>2012-12-16 10:50:25 +0100
commite5b3091351d96dcb89cec287357c67be53e46e7d (patch)
tree23f8cbf6a47c09e245cd32d671bed253459875c8
parentf713db38526895eeaf97678aa0a41cb7ff641d41 (diff)
downloadmeta-openembedded-e5b3091351d96dcb89cec287357c67be53e46e7d.tar.gz
systemd-systemctl-native: extend systemctl wrapper to support mask action
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
-rw-r--r--meta-oe/recipes-core/systemd/systemd-systemctl-native.bb2
-rwxr-xr-xmeta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl18
2 files changed, 19 insertions, 1 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb b/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb
index 7ca77ae18..5f23e988e 100644
--- a/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb
+++ b/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Wrapper to enable of systemd services"
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" 4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
5 5
6PR = "r3" 6PR = "r4"
7 7
8inherit native 8inherit native
9 9
diff --git a/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl b/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl
index 46e74e847..f74adf6c6 100755
--- a/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl
+++ b/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl
@@ -25,6 +25,14 @@ while [ $# != 0 ]; do
25 cmd_args="1" 25 cmd_args="1"
26 shift 26 shift
27 ;; 27 ;;
28 mask)
29 shift
30
31 action="$opt"
32 services="$1"
33 cmd_args="1"
34 shift
35 ;;
28 --root=*) 36 --root=*)
29 ROOT=${opt##--root=} 37 ROOT=${opt##--root=}
30 cmd_args="0" 38 cmd_args="0"
@@ -43,6 +51,16 @@ while [ $# != 0 ]; do
43done 51done
44 52
45for service in $services; do 53for service in $services; do
54 if [ "$action" = "mask" ]; then
55 if [ ! -d $ROOT/etc/systemd/system/ ]; then
56 mkdir -p $ROOT/etc/systemd/system/
57 fi
58 cmd="ln -s /dev/null $ROOT/etc/systemd/system/$service"
59 echo "$cmd"
60 $cmd
61 exit 0
62 fi
63
46 echo "Try to find location of $service..." 64 echo "Try to find location of $service..."
47 # find service file 65 # find service file
48 for p in $ROOT/etc/systemd/system \ 66 for p in $ROOT/etc/systemd/system \