summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Bénard <eric@eukrea.com>2012-11-25 18:25:10 +0100
committerEric Bénard <eric@eukrea.com>2013-02-01 09:57:22 +0100
commitc5f4259852b0e90906b9b661af50a2212fcee9f1 (patch)
treeb7e9ad4f6cc9d00f78d498b4b6135bccde86a3fb
parentb5a0512b1af9dad63e18448daa997f648ed94878 (diff)
downloadmeta-openembedded-c5f4259852b0e90906b9b661af50a2212fcee9f1.tar.gz
hiawatha: add CONFFILES and a php example
- add CONFFILES so that configuration files don't get overwritten during upgrade - add an example on how to launch php-cgi using php-fcgi Signed-off-by: Eric Bénard <eric@eukrea.com>
-rw-r--r--meta-webserver/recipes-httpd/hiawatha/hiawatha_8.6.bb14
1 files changed, 13 insertions, 1 deletions
diff --git a/meta-webserver/recipes-httpd/hiawatha/hiawatha_8.6.bb b/meta-webserver/recipes-httpd/hiawatha/hiawatha_8.6.bb
index 2e6955e99..7dcbe9ed9 100644
--- a/meta-webserver/recipes-httpd/hiawatha/hiawatha_8.6.bb
+++ b/meta-webserver/recipes-httpd/hiawatha/hiawatha_8.6.bb
@@ -4,6 +4,8 @@ LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
5DEPENDS = "libxml2 libxslt" 5DEPENDS = "libxml2 libxslt"
6 6
7PR = "r1"
8
7SECTION = "net" 9SECTION = "net"
8 10
9SRC_URI = "http://hiawatha-webserver.org/files/${PN}-${PV}.tar.gz \ 11SRC_URI = "http://hiawatha-webserver.org/files/${PN}-${PV}.tar.gz \
@@ -36,10 +38,20 @@ EXTRA_OECMAKE = " -DENABLE_IPV6=OFF \
36 -DWORK_DIR=/var/lib/hiawatha " 38 -DWORK_DIR=/var/lib/hiawatha "
37 39
38do_install_append() { 40do_install_append() {
39
40 # Copy over init script and sed in the correct sbin path 41 # Copy over init script and sed in the correct sbin path
41 sed -i 's,sed_sbin_path,${sbindir},' ${WORKDIR}/hiawatha-init 42 sed -i 's,sed_sbin_path,${sbindir},' ${WORKDIR}/hiawatha-init
42 mkdir -p ${D}${sysconfdir}/init.d 43 mkdir -p ${D}${sysconfdir}/init.d
43 install -m 0755 ${WORKDIR}/hiawatha-init ${D}${sysconfdir}/init.d/hiawatha 44 install -m 0755 ${WORKDIR}/hiawatha-init ${D}${sysconfdir}/init.d/hiawatha
44 45
46 # configure php-fcgi to have a working configuration
47 # by default if php is installed
48 echo "Server = ${bindir}/php-cgi ; 2 ; 127.0.0.1:2005 ; nobody:nobody ; ${sysconfdir}/php/hiawatha-php5/php.ini" >> ${D}${sysconfdir}/hiawatha/php-fcgi.conf
45} 49}
50
51CONFFILES_${PN} = " \
52 ${sysconfdir}/hiawatha/cgi-wrapper.conf \
53 ${sysconfdir}/hiawatha/hiawatha.conf \
54 ${sysconfdir}/hiawatha/index.xslt \
55 ${sysconfdir}/hiawatha/mimetype.conf \
56 ${sysconfdir}/hiawatha/php-fcgi.conf \
57 "