summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Domenech Goulart <mario@ossystems.com.br>2013-04-15 20:45:39 +0000
committerEric Bénard <eric@eukrea.com>2013-04-22 22:31:58 +0200
commit0d1a2039e47249c61324d64fb05d364c2f694746 (patch)
treebc81843e954d858c1ff9f22673484ace467d2985
parent47de69536963046de85d382c7f1fe68c228d83b3 (diff)
downloadmeta-openembedded-0d1a2039e47249c61324d64fb05d364c2f694746.tar.gz
gnumeric: add recipe for version 1.12.0
Based on the OE classic recipe as of bd204492e0ed296bbac2999da29f831cbdf965f9 Signed-off-by: Mario Domenech Goulart <mario@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Eric Bénard <eric@eukrea.com>
-rw-r--r--meta-gnome/recipes-gnome/gnumeric/gnumeric_1.12.0.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnumeric/gnumeric_1.12.0.bb b/meta-gnome/recipes-gnome/gnumeric/gnumeric_1.12.0.bb
new file mode 100644
index 000000000..4f4059412
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnumeric/gnumeric_1.12.0.bb
@@ -0,0 +1,43 @@
1LICENSE = "GPLv2 | GPLv3"
2LIC_FILES_CHKSUM = "file://COPYING;md5=be0de417af78dd340558810d1ced52e6"
3SECTION = "x11/utils"
4S = "${WORKDIR}/gnumeric-${PV}"
5DEPENDS = "gdk-pixbuf libgsf gtk+3 libxml2 libglade libart-lgpl intltool-native libgnomecanvas libgnomeprint libbonoboui orbit2-native goffice"
6DESCRIPTION = "Gnumeric spreadsheet for GNOME"
7
8GNOME_COMPRESS_TYPE = "xz"
9
10SRC_URI[archive.md5sum] = "3fd87cca95334b5d8ac922989670fe27"
11SRC_URI[archive.sha256sum] = "037b53d909e5d1454b2afda8c4fb1e7838e260343e36d4e36245f4a5d0e04111"
12
13inherit gnome
14
15EXTRA_OECONF=" --without-perl "
16
17PACKAGES_DYNAMIC += "gnumeric-plugin-*"
18PACKAGES += "libspreadsheet libspreadsheet-dev gnumeric-goffice gnumeric-goffice-dbg"
19
20FILES_${PN}-dbg += "${libdir}/gnumeric/${PV}/plugins/*/.debug"
21FILES_${PN}-dev = "${includedir} ${libdir}/pkgconfig"
22FILES_${PN}-staticdev = "${libdir}/libspreadsheet.la"
23FILES_libspreadsheet = "${libdir}/libspreadsheet-${PV}.so"
24FILES_libspreadsheet-dev = "${libdir}/libspreadsheet.so"
25FILES_gnumeric-goffice-dbg += "${libdir}/goffice/*/plugins/gnumeric/.debug"
26FILES_gnumeric-goffice = "${libdir}/goffice/*/plugins/gnumeric/*"
27
28# This hack works around the problem mentioned here:
29# https://mail.gnome.org/archives/gnumeric-list/2010-February/msg00006.html
30do_install_prepend() {
31 sed -i ${S}/doc/C/Makefile -e 's/\tfor file in $(omffile); do/\t-for file in $(omffile); do/'
32}
33
34python populate_packages_prepend () {
35 gnumeric_libdir = bb.data.expand('${libdir}/gnumeric/${PV}/plugins', d)
36
37 do_split_packages(d, gnumeric_libdir, '^(.*)/.*$',
38 output_pattern='gnumeric-plugin-%s',
39 description='Gnumeric plugin %s',
40 extra_depends='',
41 recursive=True,
42 prepend=True)
43}