summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2014-08-06 14:44:27 +0800
committerCliff Brake <cbrake@bec-systems.com>2014-10-29 14:03:13 -0400
commit80764fddc4f6086a8941132ce36f23e79b2bf181 (patch)
tree3a11b4a90c2ab79489a04cfdb33854e702cc816b
parent518cd119a8724dbd485a5d5c5047de59e8fbd652 (diff)
downloadmeta-openembedded-80764fddc4f6086a8941132ce36f23e79b2bf181.tar.gz
ruby: fix a parallel building issue
Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Cliff Brake <cbrake@bec-systems.com>
-rw-r--r--meta-ruby/recipes-devtools/ruby/ruby/remove-the-dependency-on-dir.patch37
-rw-r--r--meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p429.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-ruby/recipes-devtools/ruby/ruby/remove-the-dependency-on-dir.patch b/meta-ruby/recipes-devtools/ruby/ruby/remove-the-dependency-on-dir.patch
new file mode 100644
index 000000000..a4ac3eacc
--- /dev/null
+++ b/meta-ruby/recipes-devtools/ruby/ruby/remove-the-dependency-on-dir.patch
@@ -0,0 +1,37 @@
1remove a duplicate dependency
2
3Upstream-status: Pending
4
5The install-rb-default dependency is as below:
6
7pre-install-rb-default:
8 mkdir -p $(RUBYLIBDIR)/bigdecimal
9
10install-rb-default: pre-install-rb-default $(RUBYLIBDIR)/bigdecimal
11
12In fact, dependency on $(RUBYLIBDIR)/bigdecimal is duplicate, and not rule
13for $(RUBYLIBDIR)/bigdecimal, once $(RUBYLIBDIR)/bigdecimal is checked before
14pre-install-rb-default, the below error will happen
15 *** No rule to make target `../../.ext/common/yaml', needed by `install-rb-default'. Stop
16
17Signed-off-by: Roy Li <rongqing.li@windriver.com>
18---
19 lib/mkmf.rb | 2 +-
20 1 file changed, 1 insertion(+), 1 deletion(-)
21
22diff --git a/lib/mkmf.rb b/lib/mkmf.rb
23index 1f5ed76..556684c 100644
24--- a/lib/mkmf.rb
25+++ b/lib/mkmf.rb
26@@ -2054,7 +2054,7 @@ static: $(STATIC_LIB)#{$extout ? " install-rb" : ""}
27 end
28 for f in files
29 dest = "#{dir}/#{File.basename(f)}"
30- mfile.print("install-rb#{sfx}: #{dest} #{dir}\n")
31+ mfile.print("install-rb#{sfx}: #{dest}\n")
32 mfile.print("#{dest}: #{f}\n")
33 mfile.print("\t$(Q) $(#{$extout ? 'COPY' : 'INSTALL_DATA'}) #{f} $(@D#{sep})\n")
34 if defined?($installed_list) and !$extout
35--
361.7.10.4
37
diff --git a/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p429.bb b/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p429.bb
index 48a65a948..7610602dc 100644
--- a/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p429.bb
+++ b/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p429.bb
@@ -11,6 +11,7 @@ SRC_URI += "\
11 file://rubygems-1.8.11-binary-extensions.patch \ 11 file://rubygems-1.8.11-binary-extensions.patch \
12 file://ruby-1.9.3-mkmf-verbose.patch \ 12 file://ruby-1.9.3-mkmf-verbose.patch \
13 file://ruby-1.9.3-install-cross.patch \ 13 file://ruby-1.9.3-install-cross.patch \
14 file://remove-the-dependency-on-dir.patch \
14" 15"
15SRC_URI[md5sum] = "993c72f7f805a9eb453f90b0b7fe0d2b" 16SRC_URI[md5sum] = "993c72f7f805a9eb453f90b0b7fe0d2b"
16SRC_URI[sha256sum] = "d192d1afc46a7ef27b9d0a3c7a67b509048984db2c38907aa82641bdf980acf4" 17SRC_URI[sha256sum] = "d192d1afc46a7ef27b9d0a3c7a67b509048984db2c38907aa82641bdf980acf4"