summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-08-16 08:28:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2012-08-20 10:02:09 +0200
commit695786ad0fac01f3dff2232a187e95ab7ef864b0 (patch)
tree19d952cd0d7e12cf2a20b0f17fd5b15b7d80f017
parentfc9fad42f0547b7d18ffda153ced2284f4e9d8f7 (diff)
downloadmeta-openembedded-695786ad0fac01f3dff2232a187e95ab7ef864b0.tar.gz
xf86-video-glamo: disable KMS, fix build with KMS disabled
* RDEPENDS are not needed without KMS * libdrm in meta-openmoko doesn't provide support for glamo, so not it would fail to build with KMS enabled Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo/0001-fix-build-with-KMS-disabled.patch29
-rw-r--r--meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo_git.bb6
2 files changed, 32 insertions, 3 deletions
diff --git a/meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo/0001-fix-build-with-KMS-disabled.patch b/meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo/0001-fix-build-with-KMS-disabled.patch
new file mode 100644
index 000000000..25e83209d
--- /dev/null
+++ b/meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo/0001-fix-build-with-KMS-disabled.patch
@@ -0,0 +1,29 @@
1From f485e878bc8bb0e381a38a30009308c82fa8d672 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Thu, 16 Aug 2012 08:18:56 +0200
4Subject: [PATCH] fix build with KMS disabled
5
6Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
7---
8 src/glamo.h | 3 +++
9 1 files changed, 3 insertions(+), 0 deletions(-)
10
11diff --git a/src/glamo.h b/src/glamo.h
12index d4a2f19..5fd5c04 100644
13--- a/src/glamo.h
14+++ b/src/glamo.h
15@@ -37,8 +37,11 @@
16 #include "xf86.h"
17 #include "exa.h"
18 #include <linux/fb.h>
19+
20+#ifdef HAVE_KMS
21 #include <libdrm/drm.h>
22 #include <libdrm/glamo_bo.h>
23+#endif
24
25 #define GLAMO_REG_BASE(c) ((c)->attr.address[0])
26 #define GLAMO_REG_SIZE(c) (0x2400)
27--
281.7.8.6
29
diff --git a/meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo_git.bb b/meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo_git.bb
index 5d752dbf7..6fb78abe5 100644
--- a/meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo_git.bb
+++ b/meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo_git.bb
@@ -4,16 +4,16 @@ DEPENDS += "libdrm"
4 4
5LIC_FILES_CHKSUM = "file://COPYING;md5=d8cbd99fff773f92e844948f74ef0df8" 5LIC_FILES_CHKSUM = "file://COPYING;md5=d8cbd99fff773f92e844948f74ef0df8"
6 6
7RDEPENDS_${PN} = "xserver-xorg-extension-dri xserver-xorg-extension-dri2 xserver-xorg-extension-glx"
8PE = "2" 7PE = "2"
9PV = "1.0.0+gitr${SRCPV}" 8PV = "1.0.0+gitr${SRCPV}"
10PR = "${INC_PR}.0" 9PR = "${INC_PR}.1"
11 10
12SRC_URI = "git://git.openmoko.org/git/xf86-video-glamo.git;protocol=git;branch=master \ 11SRC_URI = "git://git.openmoko.org/git/xf86-video-glamo.git;protocol=git;branch=master \
13 file://0001-glamo-kms-driver-drop-unused-xf86_config.patch \ 12 file://0001-glamo-kms-driver-drop-unused-xf86_config.patch \
13 file://0001-fix-build-with-KMS-disabled.patch \
14 " 14 "
15 15
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17SRCREV = "cb9ed17035a79e49dde26a1e7e2bc5f10fd8144b" 17SRCREV = "cb9ed17035a79e49dde26a1e7e2bc5f10fd8144b"
18 18
19EXTRA_OECONF = " --enable-kms " 19EXTRA_OECONF = " --disable-kms "