summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <TicoTimo@gmail.com>2014-05-07 10:47:37 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-05-09 14:57:59 +0200
commit589844d0debace14f86258c98a6665f6a18c02ae (patch)
treee571a8f8cf677f85cf99b8fa59283e107dadcd2f
parent9996dc3ede179f73a9e68b5f6503c5954c67fae0 (diff)
downloadmeta-openembedded-589844d0debace14f86258c98a6665f6a18c02ae.tar.gz
vlc: add dependencies, drop unrecognized options
First version had no "PATCH] on subject line and wrong layer [meta-perl] * add PKGCONFIG for libass, mkv * drop PKGCONFIG for id3tag, mpeg2dec * drop unrecognized options: --enable-v4l, --disable-opengl,-id3tag,-mpeg2dec * add dependencies from JaMa builds / configure.ac NOTE: requires fluidsynth >= 1.1.2 (will work on that next) Signed-off-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc.inc18
1 files changed, 11 insertions, 7 deletions
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc.inc b/meta-multimedia/recipes-multimedia/vlc/vlc.inc
index 1b2490b72..58f564821 100644
--- a/meta-multimedia/recipes-multimedia/vlc/vlc.inc
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc.inc
@@ -5,9 +5,13 @@ SECTION = "multimedia"
5LICENSE = "GPL-2.0" 5LICENSE = "GPL-2.0"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7 7
8DEPENDS = "libfribidi libtool libgcrypt gst-plugins-bad virtual/libsdl qt4-x11-free \ 8DEPENDS = "libfribidi libtool libgcrypt gst-plugins-bad virtual/libsdl \
9 dbus libxml2 gnutls tremor faad2 ffmpeg flac libxpm fluidsynth alsa-lib \ 9 libsdl-image qt4-x11-free dbus dbus-glib libxml2 gnutls tremor \
10 libdvdcss libdvdread lua-native lua" 10 faad2 ffmpeg flac libxpm libxinerama fluidsynth alsa-lib libdvdcss \
11 libdvdread lua-native lua libidn libnotify gtk+ gnome-vfs libdc1394 \
12 libraw1394 avahi libjpeg-turbo xz libmodplug mpeg2dec \
13 libmtp opencv libopus orc libusb1 schroedinger taglib \
14 tiff xcb-util-keysyms samba"
11 15
12SRC_URI = "http://download.videolan.org/pub/videolan/${BPN}/${PV}/${BP}.tar.xz" 16SRC_URI = "http://download.videolan.org/pub/videolan/${BPN}/${PV}/${BP}.tar.xz"
13 17
@@ -26,11 +30,11 @@ EXTRA_OECONF = "\
26 --enable-sdl \ 30 --enable-sdl \
27 --enable-png \ 31 --enable-png \
28 --enable-live555 --enable-tremor \ 32 --enable-live555 --enable-tremor \
29 --enable-v4l2 --enable-v4l --disable-aa --disable-faad \ 33 --enable-v4l2 --disable-aa --disable-faad \
30 --enable-dbus \ 34 --enable-dbus \
31 --without-contrib \ 35 --without-contrib \
32 --without-kde-solid \ 36 --without-kde-solid \
33 --disable-opengl --disable-glx \ 37 --disable-glx \
34 --enable-realrtsp \ 38 --enable-realrtsp \
35 ac_cv_path_MOC=${STAGING_BINDIR_NATIVE}/moc4 \ 39 ac_cv_path_MOC=${STAGING_BINDIR_NATIVE}/moc4 \
36 ac_cv_path_RCC=${STAGING_BINDIR_NATIVE}/rcc4 \ 40 ac_cv_path_RCC=${STAGING_BINDIR_NATIVE}/rcc4 \
@@ -38,11 +42,11 @@ EXTRA_OECONF = "\
38" 42"
39 43
40PACKAGECONFIG[mad] = "--enable-mad,--disable-mad,libmad" 44PACKAGECONFIG[mad] = "--enable-mad,--disable-mad,libmad"
41PACKAGECONFIG[id3tag] = "--enable-id3tag,--disable-id3tag,libid3tag"
42PACKAGECONFIG[a52] = "--enable-a52,--disable-a52,liba52" 45PACKAGECONFIG[a52] = "--enable-a52,--disable-a52,liba52"
43PACKAGECONFIG[mpeg2dec] = "--enable-mpeg2dec,--disable-mpeg2dec,mpeg2dec"
44PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack" 46PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack"
45PACKAGECONFIG[live555] = "--enable-live555,--disable-live555,live555" 47PACKAGECONFIG[live555] = "--enable-live555,--disable-live555,live555"
48PACKAGECONFIG[libass] = "--enable-libass,--disable-libass,libass"
49PACKAGECONFIG[mkv] = "--enable-mkv,--disable-mkv,libmatroska libebml"
46 50
47do_configure() { 51do_configure() {
48 cp ${STAGING_DATADIR}/aclocal/libgcrypt.m4 ${S}/m4/ 52 cp ${STAGING_DATADIR}/aclocal/libgcrypt.m4 ${S}/m4/