diff options
Diffstat (limited to 'recipes-extended')
3 files changed, 0 insertions, 74 deletions
diff --git a/recipes-extended/libarchive/libarchive/CVE-2016-10349_CVE-2016-10350.patch b/recipes-extended/libarchive/libarchive/CVE-2016-10349_CVE-2016-10350.patch deleted file mode 100644 index f2a922d..0000000 --- a/recipes-extended/libarchive/libarchive/CVE-2016-10349_CVE-2016-10350.patch +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | From 88eb9e1d73fef46f04677c25b1697b8e25777ed3 Mon Sep 17 00:00:00 2001 | ||
2 | From: Joerg Sonnenberger <joerg@bec.de> | ||
3 | Date: Thu, 1 Dec 2016 19:56:43 +0100 | ||
4 | Subject: [PATCH] Reread the CAB header skipping the self-extracting binary | ||
5 | code. | ||
6 | |||
7 | Fixes https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=15 as found | ||
8 | by the "OSS-Fuzz" project. | ||
9 | |||
10 | CVE: CVE-2016-10349 CVE-2016-10350 | ||
11 | Upstream-Status: Backport [https://github.com/libarchive/libarchive/commit/88eb9e1d73fef46f04677c25b1697b8e25777ed3] | ||
12 | |||
13 | Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com> | ||
14 | --- | ||
15 | libarchive/archive_read_support_format_cab.c | 5 +++-- | ||
16 | 1 file changed, 3 insertions(+), 2 deletions(-) | ||
17 | |||
18 | diff --git a/libarchive/archive_read_support_format_cab.c b/libarchive/archive_read_support_format_cab.c | ||
19 | index fc70684..099f4a8 100644 | ||
20 | --- a/libarchive/archive_read_support_format_cab.c | ||
21 | +++ b/libarchive/archive_read_support_format_cab.c | ||
22 | @@ -645,12 +645,13 @@ cab_read_header(struct archive_read *a) | ||
23 | cab = (struct cab *)(a->format->data); | ||
24 | if (cab->found_header == 0 && | ||
25 | p[0] == 'M' && p[1] == 'Z') { | ||
26 | - /* This is an executable? Must be self-extracting... */ | ||
27 | + /* This is an executable? Must be self-extracting... */ | ||
28 | err = cab_skip_sfx(a); | ||
29 | if (err < ARCHIVE_WARN) | ||
30 | return (err); | ||
31 | |||
32 | - if ((p = __archive_read_ahead(a, sizeof(*p), NULL)) == NULL) | ||
33 | + /* Re-read header after processing the SFX. */ | ||
34 | + if ((p = __archive_read_ahead(a, 42, NULL)) == NULL) | ||
35 | return (truncated_error(a)); | ||
36 | } | ||
37 | |||
38 | -- | ||
39 | 1.9.1 | ||
40 | |||
diff --git a/recipes-extended/libarchive/libarchive/CVE-2017-5601.patch b/recipes-extended/libarchive/libarchive/CVE-2017-5601.patch deleted file mode 100644 index a5298f5..0000000 --- a/recipes-extended/libarchive/libarchive/CVE-2017-5601.patch +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | From 98dcbbf0bf4854bf987557e55e55fff7abbf3ea9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Matuska <martin@matuska.org> | ||
3 | Date: Thu, 19 Jan 2017 22:00:18 +0100 | ||
4 | Subject: [PATCH] Fail with negative lha->compsize in lha_read_file_header_1() | ||
5 | Fixes a heap buffer overflow reported in Secunia SA74169 | ||
6 | |||
7 | CVE: CVE-2017-5601 | ||
8 | Upstream-Status: Backport [https://github.com/libarchive/libarchive/commit/98dcbbf0bf4854bf987557e55e55fff7abbf3ea9.patch] | ||
9 | |||
10 | Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com> | ||
11 | --- | ||
12 | libarchive/archive_read_support_format_lha.c | 3 +++ | ||
13 | 1 file changed, 3 insertions(+) | ||
14 | |||
15 | diff --git a/libarchive/archive_read_support_format_lha.c b/libarchive/archive_read_support_format_lha.c | ||
16 | index 52a5531b0..d77a7c2e4 100644 | ||
17 | --- a/libarchive/archive_read_support_format_lha.c | ||
18 | +++ b/libarchive/archive_read_support_format_lha.c | ||
19 | @@ -924,6 +924,9 @@ lha_read_file_header_1(struct archive_read *a, struct lha *lha) | ||
20 | /* Get a real compressed file size. */ | ||
21 | lha->compsize -= extdsize - 2; | ||
22 | |||
23 | + if (lha->compsize < 0) | ||
24 | + goto invalid; /* Invalid compressed file size */ | ||
25 | + | ||
26 | if (sum_calculated != headersum) { | ||
27 | archive_set_error(&a->archive, ARCHIVE_ERRNO_MISC, | ||
28 | "LHa header sum error"); | ||
diff --git a/recipes-extended/libarchive/libarchive_%.bbappend b/recipes-extended/libarchive/libarchive_%.bbappend deleted file mode 100644 index 6c273a6..0000000 --- a/recipes-extended/libarchive/libarchive_%.bbappend +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | # look for files in the layer first | ||
2 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
3 | |||
4 | SRC_URI += "file://CVE-2017-5601.patch \ | ||
5 | file://CVE-2016-10349_CVE-2016-10350.patch \ | ||
6 | " | ||