summaryrefslogtreecommitdiffstats
path: root/recipes-enea/bitcalc/bitcalc_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-enea/bitcalc/bitcalc_1.0.bb')
-rw-r--r--recipes-enea/bitcalc/bitcalc_1.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-enea/bitcalc/bitcalc_1.0.bb b/recipes-enea/bitcalc/bitcalc_1.0.bb
new file mode 100644
index 0000000..e9c677a
--- /dev/null
+++ b/recipes-enea/bitcalc/bitcalc_1.0.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Translate CPU list to a CPU mask"
2DESCRIPTION = "Translate CPU list given on command line to a hexadecimal CPU mask. Can use kernel boot parameters isolcpus or nohz_full as input as well as a list given on command line."
3SECTION = "utils"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b52bab7a403562f36be803f11489f1a4"
6
7PR = "r0"
8
9DEPENDS = "gcc-sanitizers"
10RDEPENDS_${PN} = "bash"
11
12FILESEXTRAPATHS_append := "${THISDIR}/${PN}"
13
14SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master \
15 file://0001-bitcalc-resolved-compilation-warnings.patch \
16 file://0001-bitcalc-resolved-memory-leaks.patch \
17 "
18
19SRCREV = "9d4d1ce26b58ada516466c30e53c75c2961d6f0a"
20
21S = "${WORKDIR}/git"
22
23EXTRA_OEMAKE += "'DESTDIR=${D}/usr/bin'"
24
25inherit pkgconfig cmake