diff options
-rw-r--r-- | recipes-extended/libarchive/libarchive/CVE-2017-5601.patch | 28 | ||||
-rw-r--r-- | recipes-extended/libarchive/libarchive_%.bbappend | 5 |
2 files changed, 33 insertions, 0 deletions
diff --git a/recipes-extended/libarchive/libarchive/CVE-2017-5601.patch b/recipes-extended/libarchive/libarchive/CVE-2017-5601.patch new file mode 100644 index 0000000..a5298f5 --- /dev/null +++ b/recipes-extended/libarchive/libarchive/CVE-2017-5601.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From 98dcbbf0bf4854bf987557e55e55fff7abbf3ea9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Matuska <martin@matuska.org> | ||
3 | Date: Thu, 19 Jan 2017 22:00:18 +0100 | ||
4 | Subject: [PATCH] Fail with negative lha->compsize in lha_read_file_header_1() | ||
5 | Fixes a heap buffer overflow reported in Secunia SA74169 | ||
6 | |||
7 | CVE: CVE-2017-5601 | ||
8 | Upstream-Status: Backport [https://github.com/libarchive/libarchive/commit/98dcbbf0bf4854bf987557e55e55fff7abbf3ea9.patch] | ||
9 | |||
10 | Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com> | ||
11 | --- | ||
12 | libarchive/archive_read_support_format_lha.c | 3 +++ | ||
13 | 1 file changed, 3 insertions(+) | ||
14 | |||
15 | diff --git a/libarchive/archive_read_support_format_lha.c b/libarchive/archive_read_support_format_lha.c | ||
16 | index 52a5531b0..d77a7c2e4 100644 | ||
17 | --- a/libarchive/archive_read_support_format_lha.c | ||
18 | +++ b/libarchive/archive_read_support_format_lha.c | ||
19 | @@ -924,6 +924,9 @@ lha_read_file_header_1(struct archive_read *a, struct lha *lha) | ||
20 | /* Get a real compressed file size. */ | ||
21 | lha->compsize -= extdsize - 2; | ||
22 | |||
23 | + if (lha->compsize < 0) | ||
24 | + goto invalid; /* Invalid compressed file size */ | ||
25 | + | ||
26 | if (sum_calculated != headersum) { | ||
27 | archive_set_error(&a->archive, ARCHIVE_ERRNO_MISC, | ||
28 | "LHa header sum error"); | ||
diff --git a/recipes-extended/libarchive/libarchive_%.bbappend b/recipes-extended/libarchive/libarchive_%.bbappend new file mode 100644 index 0000000..b57d134 --- /dev/null +++ b/recipes-extended/libarchive/libarchive_%.bbappend | |||
@@ -0,0 +1,5 @@ | |||
1 | # look for files in the layer first | ||
2 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
3 | |||
4 | SRC_URI += "file://CVE-2017-5601.patch \ | ||
5 | " | ||