diff options
-rw-r--r-- | recipes-devtools/elfutils/elfutils/add-ptest.patch | 23 | ||||
-rw-r--r-- | recipes-devtools/elfutils/elfutils/avoid_parallel_tests.patch | 20 | ||||
-rw-r--r-- | recipes-devtools/elfutils/elfutils/run-ptest | 3 | ||||
-rw-r--r-- | recipes-devtools/elfutils/elfutils_0.164.bbappend | 19 | ||||
-rw-r--r-- | recipes-devtools/gdb/gdb/0001-add-delay-before-run-exp-file.patch | 26 | ||||
-rw-r--r-- | recipes-devtools/gdb/gdb/0002-function-name-is-used-by-mistake.patch | 30 | ||||
-rw-r--r-- | recipes-devtools/gdb/gdb/gdb-ptest-attach.patch | 30 | ||||
-rwxr-xr-x | recipes-devtools/gdb/gdb/run-ptest | 2 | ||||
-rw-r--r-- | recipes-devtools/gdb/gdb/runtest-flags.patch | 30 | ||||
-rw-r--r-- | recipes-devtools/gdb/gdb_7.10.1.bbappend | 39 |
10 files changed, 0 insertions, 222 deletions
diff --git a/recipes-devtools/elfutils/elfutils/add-ptest.patch b/recipes-devtools/elfutils/elfutils/add-ptest.patch deleted file mode 100644 index 88f808d..0000000 --- a/recipes-devtools/elfutils/elfutils/add-ptest.patch +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | Add 'install-ptest' rule. | ||
2 | |||
3 | Signed-off-by: Mihaela Sendrea <mihaela.sendrea@enea.com> | ||
4 | Upstream-status: Pending | ||
5 | --- | ||
6 | diff -uNr a/tests/Makefile.am b/tests/Makefile.am | ||
7 | --- a/tests/Makefile.am 2013-08-19 14:05:23.256292155 +0200 | ||
8 | +++ b/tests/Makefile.am 2013-08-19 15:49:16.084543591 +0200 | ||
9 | @@ -240,3 +240,14 @@ | ||
10 | coverage: | ||
11 | -$(srcdir)/coverage.sh | ||
12 | endif | ||
13 | + | ||
14 | +install-ptest: | ||
15 | + @$(MKDIR_P) $(DESTDIR)/tests | ||
16 | + @$(MKDIR_P) $(DESTDIR)/src | ||
17 | + @install $(builddir)/*$(EXEEXT) $(DESTDIR)/tests | ||
18 | + @install $(srcdir)/*.sh $(DESTDIR)/tests | ||
19 | + @install $(builddir)/../src/*$(EXEEXT) $(DESTDIR)/src | ||
20 | + @cp $(builddir)/../Makefile $(DESTDIR) | ||
21 | + @sed -i -e 's|^Makefile:|_Makefile:|' $(DESTDIR)/tests/Makefile | ||
22 | + @sed -i -e 's|$(srcdir)|.|' $(DESTDIR)/tests/Makefile | ||
23 | + | ||
diff --git a/recipes-devtools/elfutils/elfutils/avoid_parallel_tests.patch b/recipes-devtools/elfutils/elfutils/avoid_parallel_tests.patch deleted file mode 100644 index 95afc54..0000000 --- a/recipes-devtools/elfutils/elfutils/avoid_parallel_tests.patch +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | ptest needs buildtest-TESTS and runtest-TESTS targets. | ||
2 | serial-tests is required to generate those targets. | ||
3 | |||
4 | Signed-off-by: Alexandra Safta <alexandra.safta@enea.com> | ||
5 | Signed-off-by: Tudor Florea <tudor.florea@enea.com> | ||
6 | Signed-off-by: Martin Borg <martin.borg@enea.com> | ||
7 | Upstream-Status: Inappropriate | ||
8 | |||
9 | --- a/configure.ac 2015-10-15 15:16:57.000000000 +0200 | ||
10 | +++ b/configure.ac 2016-02-02 12:03:17.432986965 +0100 | ||
11 | |||
12 | @@ -26,7 +26,7 @@ | ||
13 | AC_PREREQ(2.63) dnl Minimum Autoconf version required. | ||
14 | |||
15 | dnl We use GNU make extensions; automake 1.10 defaults to -Wportability. | ||
16 | -AM_INIT_AUTOMAKE([gnits 1.11 -Wno-portability dist-bzip2 no-dist-gzip parallel-tests]) | ||
17 | +AM_INIT_AUTOMAKE([gnits 1.11 -Wno-portability dist-bzip2 no-dist-gzip serial-tests]) | ||
18 | AM_MAINTAINER_MODE | ||
19 | |||
20 | AM_SILENT_RULES([yes]) | ||
diff --git a/recipes-devtools/elfutils/elfutils/run-ptest b/recipes-devtools/elfutils/elfutils/run-ptest deleted file mode 100644 index 51ea6df..0000000 --- a/recipes-devtools/elfutils/elfutils/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | make -C tests -k runtest-TESTS | ||
diff --git a/recipes-devtools/elfutils/elfutils_0.164.bbappend b/recipes-devtools/elfutils/elfutils_0.164.bbappend deleted file mode 100644 index 704829a..0000000 --- a/recipes-devtools/elfutils/elfutils_0.164.bbappend +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | SRC_URI += "\ | ||
4 | file://add-ptest.patch \ | ||
5 | file://run-ptest \ | ||
6 | file://avoid_parallel_tests.patch \ | ||
7 | " | ||
8 | |||
9 | inherit ptest | ||
10 | |||
11 | do_compile_ptest() { | ||
12 | oe_runmake -C tests buildtest-TESTS | ||
13 | } | ||
14 | |||
15 | do_install_ptest() { | ||
16 | oe_runmake -C tests install-ptest DESTDIR=${D}${PTEST_PATH} | ||
17 | } | ||
18 | |||
19 | RDEPENDS_${PN}-ptest += " bash" | ||
diff --git a/recipes-devtools/gdb/gdb/0001-add-delay-before-run-exp-file.patch b/recipes-devtools/gdb/gdb/0001-add-delay-before-run-exp-file.patch deleted file mode 100644 index 1c41562..0000000 --- a/recipes-devtools/gdb/gdb/0001-add-delay-before-run-exp-file.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | Description: Add delay for stable running | ||
2 | |||
3 | Author: jack zhang <jack.zhang@enea.com> | ||
4 | Date: Mon, 12 Nov 2012 04:10:20 +0100 | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: jack zhang <jack.zhang@enea.com> | ||
9 | Signed-off-by: Ciprian Barbu <ciprian.barbu@enea.com> | ||
10 | --- | ||
11 | gdb/testsuite/dg-extract-results.sh | 1 + | ||
12 | 1 files changed, 1 insertions(+), 0 deletions(-) | ||
13 | |||
14 | diff --git a/gdb/testsuite/dg-extract-results.sh b/gdb/testsuite/dg-extract-results.sh | ||
15 | --- a/gdb/testsuite/dg-extract-results.sh | ||
16 | +++ b/gdb/testsuite/dg-extract-results.sh | ||
17 | @@ -322,6 +322,7 @@ END { | ||
18 | n=1 | ||
19 | while (n < expfileno) { | ||
20 | if (expfileseen[expfiles[n]]) { | ||
21 | + sleep 1 | ||
22 | print "Running "expfiles[n]" ..." | ||
23 | if (filewritten["${TMP}/list"n]) { | ||
24 | if (expfileseen[expfiles[n]] == 1) | ||
25 | -- | ||
26 | 1.7.5.4 | ||
diff --git a/recipes-devtools/gdb/gdb/0002-function-name-is-used-by-mistake.patch b/recipes-devtools/gdb/gdb/0002-function-name-is-used-by-mistake.patch deleted file mode 100644 index 7f25a35..0000000 --- a/recipes-devtools/gdb/gdb/0002-function-name-is-used-by-mistake.patch +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | Description: function name is used by mistake | ||
2 | |||
3 | Author: jack zhang <jack.zhang@enea.com> | ||
4 | Date: Tue, 13 Nov 2012 09:56:54 +0100 | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: jack zhang <jack.zhang@enea.com> | ||
9 | Signed-off-by: Ciprian Barbu <ciprian.barbu@enea.com> | ||
10 | --- | ||
11 | gdb/testsuite/gdb.base/skip.exp | 4 ++-- | ||
12 | 1 files changed, 2 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/gdb/testsuite/gdb.base/skip.exp b/gdb/testsuite/gdb.base/skip.exp | ||
15 | --- a/gdb/testsuite/gdb.base/skip.exp | ||
16 | +++ b/gdb/testsuite/gdb.base/skip.exp | ||
17 | @@ -113,9 +113,9 @@ gdb_test "info skip 3" ".*\\n3\\s+file\\s+n.*" \ | ||
18 | "info skip shows entry as disabled" | ||
19 | |||
20 | if ![runto_main] { fail "skip tests suppressed" } | ||
21 | -gdb_test "step" "bar \\(\\) at.*" "step after disabling 3 (1)" | ||
22 | +gdb_test "step" "foo \\(\\) at.*" "step after disabling 3 (1)" | ||
23 | gdb_test "step" ".*" "step after disabling 3 (2)"; # Return from foo() | ||
24 | -gdb_test "step" "foo \\(\\) at.*" "step after disabling 3 (3)" | ||
25 | +gdb_test "step" "bar \\(\\) at.*" "step after disabling 3 (3)" | ||
26 | gdb_test "step" ".*" "step after disabling 3 (4)"; # Return from bar() | ||
27 | gdb_test "step" "main \\(\\) at.*" "step after disabling 3 (5)" | ||
28 | |||
29 | -- | ||
30 | 1.7.5.4 | ||
diff --git a/recipes-devtools/gdb/gdb/gdb-ptest-attach.patch b/recipes-devtools/gdb/gdb/gdb-ptest-attach.patch deleted file mode 100644 index b95ac2c..0000000 --- a/recipes-devtools/gdb/gdb/gdb-ptest-attach.patch +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | From f442dc426b0346e1e413a7c3ae5b07725837135c Mon Sep 17 00:00:00 2001 | ||
2 | From: "Rick.Yang" <rick.yang@enea.com> | ||
3 | Date: Sun, 11 Nov 2012 10:05:50 +0100 | ||
4 | Subject: [PATCH] Fix the failed test case. | ||
5 | |||
6 | Description: Fixed failing test case | ||
7 | In fact, the test case is passing, but the output does not completely | ||
8 | match the expected pattern in some special case. Modified the pattern | ||
9 | to resolve it. | ||
10 | |||
11 | Signed-off-by: Rick.Yang <rick.yang@enea.com> | ||
12 | Signed-off-by: Ciprian Barbu <ciprian.barbu@enea.com> | ||
13 | --- | ||
14 | gdb/testsuite/gdb.base/attach.exp | 2 +- | ||
15 | 1 files changed, 1 insertions(+), 1 deletions(-) | ||
16 | |||
17 | diff --git a/gdb/testsuite/gdb.base/attach.exp b/gdb/testsuite/gdb.base/attach.exp | ||
18 | --- a/gdb/testsuite/gdb.base/attach.exp | ||
19 | +++ b/gdb/testsuite/gdb.base/attach.exp | ||
20 | @@ -285,7 +285,7 @@ proc do_attach_tests {} { | ||
21 | gdb_test "dir ${objdir}/${subdir}" "Source directories searched: .*" \ | ||
22 | "set source path" | ||
23 | |||
24 | - gdb_test "cd /tmp" "Working directory /tmp." \ | ||
25 | + gdb_test "cd /tmp" "Working directory /tmp.*" \ | ||
26 | "cd away from process working directory" | ||
27 | |||
28 | # Explicitly flush out any knowledge of the previous attachment. | ||
29 | -- | ||
30 | 1.7.5.4 | ||
diff --git a/recipes-devtools/gdb/gdb/run-ptest b/recipes-devtools/gdb/gdb/run-ptest deleted file mode 100755 index e8587e8..0000000 --- a/recipes-devtools/gdb/gdb/run-ptest +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | make -C testsuite check-single | sed -e 's/XFAIL/PASS/' -e 's/UNRESOLVED/SKIP/' -e 's/UNTESTED/SKIP/' -e 's/UNSUPPORTED/SKIP/' | ||
diff --git a/recipes-devtools/gdb/gdb/runtest-flags.patch b/recipes-devtools/gdb/gdb/runtest-flags.patch deleted file mode 100644 index 054abc3..0000000 --- a/recipes-devtools/gdb/gdb/runtest-flags.patch +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | Description: add -a to runtest | ||
2 | Pass "-a" to runtest so that everything is printed to output | ||
3 | (e.g. unsupported test cases) | ||
4 | |||
5 | Author: "Gordon.Sun" <gordon.sun@enea.com> | ||
6 | Date: Wed, 28 Nov 2012 03:39:58 +0100 | ||
7 | |||
8 | Upstream-Status: Inappropriate (other) | ||
9 | |||
10 | Signed-off-by: Gordon.Sun <gordon.sun@enea.com> | ||
11 | Signed-off-by: Ciprian Barbu <ciprian.barbu@enea.com> | ||
12 | --- | ||
13 | gdb/testsuite/Makefile.in | 2 +- | ||
14 | 1 files changed, 1 insertions(+), 1 deletions(-) | ||
15 | |||
16 | diff --git a/gdb/testsuite/Makefile.in b/gdb/testsuite/Makefile.in | ||
17 | index fab124e..f5cddb2 100644 | ||
18 | --- a/gdb/testsuite/Makefile.in | ||
19 | +++ b/gdb/testsuite/Makefile.in | ||
20 | @@ -46,7 +46,7 @@ EXPECT = `if [ -f $${rootme}/../../expect/expect ] ; then \ | ||
21 | |||
22 | RUNTEST = $(RUNTEST_FOR_TARGET) | ||
23 | |||
24 | -RUNTESTFLAGS = | ||
25 | +RUNTESTFLAGS = -a | ||
26 | |||
27 | FORCE_PARALLEL = | ||
28 | |||
29 | -- | ||
30 | 1.7.5.4 | ||
diff --git a/recipes-devtools/gdb/gdb_7.10.1.bbappend b/recipes-devtools/gdb/gdb_7.10.1.bbappend deleted file mode 100644 index 89404b1..0000000 --- a/recipes-devtools/gdb/gdb_7.10.1.bbappend +++ /dev/null | |||
@@ -1,39 +0,0 @@ | |||
1 | inherit ptest | ||
2 | |||
3 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
4 | |||
5 | SRC_URI += "file://run-ptest \ | ||
6 | file://runtest-flags.patch \ | ||
7 | file://0001-add-delay-before-run-exp-file.patch \ | ||
8 | file://0002-function-name-is-used-by-mistake.patch \ | ||
9 | file://gdb-ptest-attach.patch \ | ||
10 | " | ||
11 | |||
12 | |||
13 | |||
14 | DEPENDS_${PN}-ptest += "expect dejagnu tcl" | ||
15 | RDEPENDS_${PN}-ptest += "glibc-charmap-ibm1047 \ | ||
16 | glibc-gconv-ibm1047 \ | ||
17 | glibc-charmap-ebcdic-us \ | ||
18 | glibc-gconv-ebcdic-us \ | ||
19 | glibc-gconv-utf-32 \ | ||
20 | glibc-gconv-utf-16 \ | ||
21 | prelink \ | ||
22 | expect \ | ||
23 | dejagnu \ | ||
24 | make \ | ||
25 | bash \ | ||
26 | " | ||
27 | do_configure_ptest () { | ||
28 | cd ${S}/gdb/testsuite/ | ||
29 | ./configure --host=${HOST_SYS} --build=${BUILD_SYS} | ||
30 | make site.exp | ||
31 | } | ||
32 | |||
33 | do_install_ptest () { | ||
34 | cp -pr ${S}/gdb/testsuite/ ${D}${PTEST_PATH} | ||
35 | cp -pr ${S}/gdb/features/ ${D}${PTEST_PATH} | ||
36 | install -p ${S}/config.sub ${D}${PTEST_PATH}/testsuite/ | ||
37 | install -p ${S}/config.guess ${D}${PTEST_PATH}/testsuite/ | ||
38 | install -p ${S}/install-sh ${D}${PTEST_PATH}/testsuite/ | ||
39 | } | ||