summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/intel-ethernet/files/disable_MDD_by_default.patch15
-rw-r--r--recipes-kernel/intel-ethernet/ixgbe_5.10.2.bbappend4
2 files changed, 19 insertions, 0 deletions
diff --git a/recipes-kernel/intel-ethernet/files/disable_MDD_by_default.patch b/recipes-kernel/intel-ethernet/files/disable_MDD_by_default.patch
new file mode 100644
index 0000000..3da16c5
--- /dev/null
+++ b/recipes-kernel/intel-ethernet/files/disable_MDD_by_default.patch
@@ -0,0 +1,15 @@
1Index: src/ixgbe_param.c
2===================================================================
3--- src.orig/ixgbe_param.c
4+++ src/ixgbe_param.c
5@@ -1232,8 +1232,8 @@ void ixgbe_check_options(struct ixgbe_ad
6 struct ixgbe_option opt = {
7 .type = enable_option,
8 .name = "Malicious Driver Detection",
9- .err = "defaulting to Enabled",
10- .def = OPTION_ENABLED,
11+ .err = "defaulting to Disabled",
12+ .def = OPTION_DISABLED,
13 };
14
15 switch (adapter->hw.mac.type) {
diff --git a/recipes-kernel/intel-ethernet/ixgbe_5.10.2.bbappend b/recipes-kernel/intel-ethernet/ixgbe_5.10.2.bbappend
new file mode 100644
index 0000000..3193ade
--- /dev/null
+++ b/recipes-kernel/intel-ethernet/ixgbe_5.10.2.bbappend
@@ -0,0 +1,4 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2SRC_URI += " \
3 file://disable_MDD_by_default.patch \
4 "