summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCatalin Iova <Catalin.Iova@enea.com>2021-11-26 05:52:56 +0100
committerAdrian Calianu <Adrian.Calianu@enea.com>2021-11-26 08:42:33 +0100
commitd903fd11d6023c646edf09c1a31ad2e55480020b (patch)
tree954295eb2de4db9f6bc7560347e714a643408b24
parent9159176013f053a8294ce512b6408a8235871f0d (diff)
downloadmeta-nfv-access-bsp-arm-d903fd11d6023c646edf09c1a31ad2e55480020b.tar.gz
recipes: Add support for lx2160
Change-Id: I5ed1de25386032c9a28beb3ea605aff3f9325dba Signed-off-by: Catalin Iova <Catalin.Iova@enea.com>
-rw-r--r--conf/layer.conf4
-rw-r--r--conf/machine/enea_lx2160ardb.conf22
-rw-r--r--recipes-core/ovmf/ovmf_git.bbappend5
-rw-r--r--recipes-devtools/syslinux/syslinux_%.bbappend2
4 files changed, 29 insertions, 4 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 50199be..fc3130d 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -8,5 +8,7 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
8 8
9BBFILE_COLLECTIONS += "nfv-access-bsp-arm" 9BBFILE_COLLECTIONS += "nfv-access-bsp-arm"
10BBFILE_PATTERN_nfv-access-bsp-arm = "^${LAYERDIR}/" 10BBFILE_PATTERN_nfv-access-bsp-arm = "^${LAYERDIR}/"
11BBFILE_PRIORITY_nfv-access-bsp-arm = "6" 11LAYERSERIES_COMPAT_nfv-access-bsp-arm = "hardknott"
12LAYERDEPENDS_nfv-access-bsp-arm = "nfv-access-bsp-common" 12LAYERDEPENDS_nfv-access-bsp-arm = "nfv-access-bsp-common"
13
14include conf/machine/enea_lx2160ardb.conf
diff --git a/conf/machine/enea_lx2160ardb.conf b/conf/machine/enea_lx2160ardb.conf
new file mode 100644
index 0000000..c2acf45
--- /dev/null
+++ b/conf/machine/enea_lx2160ardb.conf
@@ -0,0 +1,22 @@
1#@TYPE: Machine
2#@NAME: xeon-d
3#@SUMMARY: Intel Xeon D1521
4#@DESCRIPTION: Machine configuration for 64 bit Intel Core i7 CPU (and later) with MMX, SSE, SSE2, SSE3, and SSSE3 instruction set support. Supports a moderately wide range of drivers that should boot and be usable on "typical" hardware.
5
6# This is a clean-up version of conf/machine/intel-corei7-64.conf
7# If the configuration need to be updated please check first the original .conf
8
9MACHINE_FEATURES_remove_lx2160ardb = "pcbios"
10MACHINE_FEATURES_append_lx2160ardb = " efi"
11
12WKS_FILE_DEPENDS_BOOTLOADERS_aarch64 = "grub-efi systemd-boot"
13
14PREFERRED_PROVIDER_qemu_lx2160ardb ?= "qemu-qoriq"
15PREFERRED_PROVIDER_qemu-dev_lx2160ardb ?= "qemu-qoriq"
16
17EXTRA_IMAGEDEPENDS_remove_lx2160ardb = "u-boot"
18EXTRA_IMAGEDEPENDS_remove_lx2160ardb = "qoriq-atf"
19
20SOTA_MACHINE_lx2160ardb = "${MACHINE}"
21
22KERNEL_DEVICETREE_remove_lx2160ardb = "freescale/fsl-lx2160a-rdb.dtb freescale/fsl-lx2160a-qds.dtb"
diff --git a/recipes-core/ovmf/ovmf_git.bbappend b/recipes-core/ovmf/ovmf_git.bbappend
index 9fc7cb7..54507ca 100644
--- a/recipes-core/ovmf/ovmf_git.bbappend
+++ b/recipes-core/ovmf/ovmf_git.bbappend
@@ -1,10 +1,10 @@
1# Overwrite the "do_compile" step in order to support AARCH64 targets. 1# Overwrite the "do_compile" step in order to support AARCH64 targets.
2 2
3COMPATIBLE_HOST='(i.86|x86_64|aarch64).*' 3COMPATIBLE_HOST_class-target='(i.86|x86_64|aarch64).*'
4 4
5do_compile_class-target() { 5do_compile_class-target() {
6 export LFLAGS="${LDFLAGS}" 6 export LFLAGS="${LDFLAGS}"
7 PARALLEL_JOBS="${@ '${PARALLEL_MAKE}'.replace('-j', '-n ')}" 7 PARALLEL_JOBS="${@oe.utils.parallel_make_argument(d, '-n %d')}"
8 OVMF_ARCH="X64" 8 OVMF_ARCH="X64"
9 if [ "${TARGET_ARCH}" != "x86_64" ] ; then 9 if [ "${TARGET_ARCH}" != "x86_64" ] ; then
10 OVMF_ARCH="IA32" 10 OVMF_ARCH="IA32"
@@ -110,3 +110,4 @@ do_deploy_class-target() {
110 done 110 done
111 fi 111 fi
112} 112}
113
diff --git a/recipes-devtools/syslinux/syslinux_%.bbappend b/recipes-devtools/syslinux/syslinux_%.bbappend
index 045830a..a5a7216 100644
--- a/recipes-devtools/syslinux/syslinux_%.bbappend
+++ b/recipes-devtools/syslinux/syslinux_%.bbappend
@@ -1,7 +1,7 @@
1# Syslinux is not supposed to be available on ARM. 1# Syslinux is not supposed to be available on ARM.
2# Some recipes/image-classes mark it as a dependency even if it's not used. 2# Some recipes/image-classes mark it as a dependency even if it's not used.
3 3
4COMPATIBLE_HOST = '(x86_64|i.86|aarch64).*-(linux|freebsd.*)' 4COMPATIBLE_HOST_class-target = '(x86_64|i.86|aarch64|arm64).*-(linux|freebsd.*)'
5 5
6do_fetch[noexec] = "1" 6do_fetch[noexec] = "1"
7do_unpack[noexec] = "1" 7do_unpack[noexec] = "1"