summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_7.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_7.0.0.bb')
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_7.0.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_7.0.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_7.0.0.bb
new file mode 100644
index 0000000..cf39c6a
--- /dev/null
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_7.0.0.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Runtime libraries from MinGW-w64 project"
2
3require mingw-w64.inc
4
5S = "${WORKDIR}/mingw-w64-v${PV}/mingw-w64-crt"
6B = "${WORKDIR}/build-${TARGET_SYS}"
7
8inherit autotools nativesdk
9
10BUILDSDK_CPPFLAGS_append = " -isystem${STAGING_INCDIR}"
11
12INHIBIT_DEFAULT_DEPS = "1"
13DEPENDS = "nativesdk-mingw-w64-headers virtual/${TARGET_PREFIX}gcc "
14
15PROVIDES += "virtual/nativesdk-libc"
16
17# Work around pulling in eglibc for now...
18PROVIDES += "virtual/nativesdk-libintl"
19
20TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TARGET}"
21
22do_configure() {
23 oe_runconf
24}
25
26FILES_${PN} += "${exec_prefix}/libsrc"
27