diff options
author | Mark Hatle <mark.hatle@windriver.com> | 2014-06-27 10:45:16 -0500 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2014-07-08 09:53:34 +0000 |
commit | 7e2e23972e0b93eed7e2164036be3aa657b0e9c6 (patch) | |
tree | 680ab8bc77c6f466d2a21345fd96b8a65f0e731d /recipes-devtools | |
parent | aa04ad46bbad56f7a385147bd393b399119187ac (diff) | |
download | meta-mingw-7e2e23972e0b93eed7e2164036be3aa657b0e9c6.tar.gz |
gcc: Uprev gcc and related to latest version
Uprev gcc to match master, and resync with latest mingw runtime.
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'recipes-devtools')
-rw-r--r-- | recipes-devtools/gcc/gcc-cross-canadian_4.9.bbappend (renamed from recipes-devtools/gcc/gcc-cross-canadian_4.8.bbappend) | 0 | ||||
-rw-r--r-- | recipes-devtools/gcc/gcc-crosssdk-initial_4.9.bbappend (renamed from recipes-devtools/gcc/gcc-crosssdk-initial_4.8.bbappend) | 0 | ||||
-rw-r--r-- | recipes-devtools/gcc/gcc-crosssdk_4.9.bbappend (renamed from recipes-devtools/gcc/gcc-crosssdk_4.8.bbappend) | 0 | ||||
-rw-r--r-- | recipes-devtools/gcc/gcc-runtime_4.9.bbappend (renamed from recipes-devtools/gcc/gcc-runtime_4.8.bbappend) | 0 | ||||
-rw-r--r-- | recipes-devtools/gcc/libgcc_4.9.bbappend (renamed from recipes-devtools/gcc/libgcc_4.8.bbappend) | 0 | ||||
-rw-r--r-- | recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_2.0.8.bb | 41 | ||||
-rw-r--r-- | recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_3.1.0.bb | 29 | ||||
-rw-r--r-- | recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_3.1.0.bb (renamed from recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_2.0.8.bb) | 13 |
8 files changed, 33 insertions, 50 deletions
diff --git a/recipes-devtools/gcc/gcc-cross-canadian_4.8.bbappend b/recipes-devtools/gcc/gcc-cross-canadian_4.9.bbappend index 030a9b9..030a9b9 100644 --- a/recipes-devtools/gcc/gcc-cross-canadian_4.8.bbappend +++ b/recipes-devtools/gcc/gcc-cross-canadian_4.9.bbappend | |||
diff --git a/recipes-devtools/gcc/gcc-crosssdk-initial_4.8.bbappend b/recipes-devtools/gcc/gcc-crosssdk-initial_4.9.bbappend index 1c09342..1c09342 100644 --- a/recipes-devtools/gcc/gcc-crosssdk-initial_4.8.bbappend +++ b/recipes-devtools/gcc/gcc-crosssdk-initial_4.9.bbappend | |||
diff --git a/recipes-devtools/gcc/gcc-crosssdk_4.8.bbappend b/recipes-devtools/gcc/gcc-crosssdk_4.9.bbappend index 77ba57f..77ba57f 100644 --- a/recipes-devtools/gcc/gcc-crosssdk_4.8.bbappend +++ b/recipes-devtools/gcc/gcc-crosssdk_4.9.bbappend | |||
diff --git a/recipes-devtools/gcc/gcc-runtime_4.8.bbappend b/recipes-devtools/gcc/gcc-runtime_4.9.bbappend index 50ca3ca..50ca3ca 100644 --- a/recipes-devtools/gcc/gcc-runtime_4.8.bbappend +++ b/recipes-devtools/gcc/gcc-runtime_4.9.bbappend | |||
diff --git a/recipes-devtools/gcc/libgcc_4.8.bbappend b/recipes-devtools/gcc/libgcc_4.9.bbappend index dd95317..dd95317 100644 --- a/recipes-devtools/gcc/libgcc_4.8.bbappend +++ b/recipes-devtools/gcc/libgcc_4.9.bbappend | |||
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_2.0.8.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_2.0.8.bb deleted file mode 100644 index a3d0e46..0000000 --- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_2.0.8.bb +++ /dev/null | |||
@@ -1,41 +0,0 @@ | |||
1 | DESCRIPTION = "Header files from the MingGW-w64 project" | ||
2 | LICENSE = "ZPL" | ||
3 | LIC_FILES_CHKSUM = "file://../COPYING;md5=3194ff3a0d16f018784d1847bc6a3c4d" | ||
4 | |||
5 | COMPATIBLE_HOST = ".*-mingw.*" | ||
6 | |||
7 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.gz \ | ||
8 | file://epsilon.patch" | ||
9 | |||
10 | SRC_URI[md5sum] = "659e5baf45ac8e8b8526f29786ee1112" | ||
11 | SRC_URI[sha256sum] = "1a5a2c57f90c7f1b5eb8402a52f93de645925a8af62c2cfe748f39ce66008cf4" | ||
12 | |||
13 | S = "${WORKDIR}/mingw-w64-v${PV}/mingw-w64-headers" | ||
14 | B = "${WORKDIR}/build-${TARGET_SYS}" | ||
15 | |||
16 | inherit autotools nativesdk | ||
17 | |||
18 | INHIBIT_DEFAULT_DEPS = "1" | ||
19 | DEPENDS = "" | ||
20 | |||
21 | do_configure() { | ||
22 | oe_runconf | ||
23 | } | ||
24 | |||
25 | do_compile() { | ||
26 | : | ||
27 | } | ||
28 | |||
29 | FILES_${PN} += "${exec_prefix}/${TARGET_SYS}" | ||
30 | |||
31 | do_install_append() { | ||
32 | # Move files to include folder where gcc-crosssdk-initial is looking | ||
33 | mv ${D}${exec_prefix}/${HOST_SYS}/include ${D}${exec_prefix} | ||
34 | rmdir ${D}${exec_prefix}/${HOST_SYS} | ||
35 | |||
36 | ln -s ./ ${D}/${exec_prefix}/${HOST_SYS} | ||
37 | } | ||
38 | |||
39 | sysroot_stage_all_append_mingw32 () { | ||
40 | ln -s ./ ${SYSROOT_DESTDIR}${exec_prefix}/${HOST_SYS} | ||
41 | } | ||
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_3.1.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_3.1.0.bb new file mode 100644 index 0000000..33e8bbb --- /dev/null +++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_3.1.0.bb | |||
@@ -0,0 +1,29 @@ | |||
1 | DESCRIPTION = "Header files from the MingGW-w64 project" | ||
2 | LICENSE = "ZPL" | ||
3 | LIC_FILES_CHKSUM = "file://../COPYING;md5=bb936f0e04d8f1e19ad545100cee9654" | ||
4 | |||
5 | COMPATIBLE_HOST = ".*-mingw.*" | ||
6 | |||
7 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.bz2 \ | ||
8 | file://epsilon.patch" | ||
9 | |||
10 | SRC_URI[md5sum] = "df0e7657f46cbd59ed9cbe2a50c66e15" | ||
11 | SRC_URI[sha256sum] = "ece7a7e7e1ab5e25d5ce469f8e4de7223696146fffa71c16e2a9b017d0e017d2" | ||
12 | |||
13 | S = "${WORKDIR}/mingw-w64-v${PV}/mingw-w64-headers" | ||
14 | B = "${WORKDIR}/build-${TARGET_SYS}" | ||
15 | |||
16 | inherit autotools nativesdk | ||
17 | |||
18 | INHIBIT_DEFAULT_DEPS = "1" | ||
19 | DEPENDS = "" | ||
20 | |||
21 | do_configure() { | ||
22 | oe_runconf | ||
23 | } | ||
24 | |||
25 | do_compile() { | ||
26 | : | ||
27 | } | ||
28 | |||
29 | FILES_${PN} += "${exec_prefix}/${TARGET_SYS}" | ||
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_2.0.8.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_3.1.0.bb index 14b5c7d..4c56c70 100644 --- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_2.0.8.bb +++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_3.1.0.bb | |||
@@ -1,12 +1,12 @@ | |||
1 | DESCRIPTION = "Runtime libraries from MinGW-w64 project" | 1 | DESCRIPTION = "Runtime libraries from MinGW-w64 project" |
2 | LICENSE = "ZPL" | 2 | LICENSE = "ZPL" |
3 | LIC_FILES_CHKSUM = "file://../COPYING;md5=3194ff3a0d16f018784d1847bc6a3c4d" | 3 | LIC_FILES_CHKSUM = "file://../COPYING;md5=bb936f0e04d8f1e19ad545100cee9654" |
4 | 4 | ||
5 | COMPATIBLE_HOST = ".*-mingw.*" | 5 | COMPATIBLE_HOST = ".*-mingw.*" |
6 | 6 | ||
7 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.gz" | 7 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.bz2" |
8 | SRC_URI[md5sum] = "659e5baf45ac8e8b8526f29786ee1112" | 8 | SRC_URI[md5sum] = "df0e7657f46cbd59ed9cbe2a50c66e15" |
9 | SRC_URI[sha256sum] = "1a5a2c57f90c7f1b5eb8402a52f93de645925a8af62c2cfe748f39ce66008cf4" | 9 | SRC_URI[sha256sum] = "ece7a7e7e1ab5e25d5ce469f8e4de7223696146fffa71c16e2a9b017d0e017d2" |
10 | 10 | ||
11 | S = "${WORKDIR}/mingw-w64-v${PV}/mingw-w64-crt" | 11 | S = "${WORKDIR}/mingw-w64-v${PV}/mingw-w64-crt" |
12 | B = "${WORKDIR}/build-${TARGET_SYS}" | 12 | B = "${WORKDIR}/build-${TARGET_SYS}" |
@@ -32,10 +32,5 @@ do_configure() { | |||
32 | oe_runconf | 32 | oe_runconf |
33 | } | 33 | } |
34 | 34 | ||
35 | do_install_append() { | ||
36 | # Move files to folder where gcc-crosssdk is looking | ||
37 | mv ${D}${exec_prefix}/${HOST_SYS}/lib* ${D}${exec_prefix} | ||
38 | rmdir ${D}${exec_prefix}/${HOST_SYS} | ||
39 | } | ||
40 | FILES_${PN} += "${exec_prefix}/libsrc" | 35 | FILES_${PN} += "${exec_prefix}/libsrc" |
41 | 36 | ||