summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-20 10:53:30 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-20 11:00:20 +0000
commit423433e3d31a32dbb80203c628e808442d440ad1 (patch)
tree1edbad91e321e3c40f3d09a6f797513feba426b8 /recipes-devtools
parentfa4ea76d93c87a2ad3ce88b052c282106b2761e4 (diff)
downloadmeta-mingw-423433e3d31a32dbb80203c628e808442d440ad1.tar.gz
mingw-w64/gcc: Adapt to removal of gcc-initial from OE-Core2.7_M2
OE-Core dropped gcc-initial, we can do the same for mingw. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/gcc/gcc-crosssdk-initial_%.bbappend3
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_6.0.0.bb7
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_6.0.0.bb5
3 files changed, 2 insertions, 13 deletions
diff --git a/recipes-devtools/gcc/gcc-crosssdk-initial_%.bbappend b/recipes-devtools/gcc/gcc-crosssdk-initial_%.bbappend
deleted file mode 100644
index 135a776..0000000
--- a/recipes-devtools/gcc/gcc-crosssdk-initial_%.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
1DEPENDS_append_mingw32 = " nativesdk-mingw-w64-headers"
2EXTRA_OECONF_remove_mingw32 = "--enable-initfini-array"
3EXTRA_OECONF_append_mingw32 = " --disable-initfini-array"
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_6.0.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_6.0.0.bb
index fc83ca8..cf39c6a 100644
--- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_6.0.0.bb
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_6.0.0.bb
@@ -10,19 +10,14 @@ inherit autotools nativesdk
10BUILDSDK_CPPFLAGS_append = " -isystem${STAGING_INCDIR}" 10BUILDSDK_CPPFLAGS_append = " -isystem${STAGING_INCDIR}"
11 11
12INHIBIT_DEFAULT_DEPS = "1" 12INHIBIT_DEFAULT_DEPS = "1"
13DEPENDS = "nativesdk-mingw-w64-headers virtual/${TARGET_PREFIX}gcc-initial " 13DEPENDS = "nativesdk-mingw-w64-headers virtual/${TARGET_PREFIX}gcc "
14 14
15PROVIDES += "virtual/nativesdk-libc" 15PROVIDES += "virtual/nativesdk-libc"
16PROVIDES += "virtual/nativesdk-${SDK_PREFIX}libc-initial"
17PROVIDES += "virtual/nativesdk-${SDK_PREFIX}libc-for-gcc"
18 16
19# Work around pulling in eglibc for now... 17# Work around pulling in eglibc for now...
20PROVIDES += "virtual/nativesdk-libintl" 18PROVIDES += "virtual/nativesdk-libintl"
21 19
22STAGINGCC = "gcc-cross-initial-${TARGET_ARCH}"
23STAGINGCC_class-nativesdk = "gcc-crosssdk-initial-${SDK_SYS}"
24TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TARGET}" 20TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TARGET}"
25PATH_prepend = "${STAGING_BINDIR_TOOLCHAIN}.${STAGINGCC}:"
26 21
27do_configure() { 22do_configure() {
28 oe_runconf 23 oe_runconf
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_6.0.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_6.0.0.bb
index b278ad7..e694e5b 100644
--- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_6.0.0.bb
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_6.0.0.bb
@@ -8,16 +8,13 @@ B = "${WORKDIR}/build-${TARGET_SYS}"
8inherit autotools nativesdk 8inherit autotools nativesdk
9 9
10INHIBIT_DEFAULT_DEPS = "1" 10INHIBIT_DEFAULT_DEPS = "1"
11DEPENDS = "nativesdk-mingw-w64-runtime virtual/${TARGET_PREFIX}gcc-initial" 11DEPENDS = "nativesdk-mingw-w64-runtime virtual/${TARGET_PREFIX}gcc"
12 12
13do_configure() { 13do_configure() {
14 oe_runconf 14 oe_runconf
15} 15}
16 16
17STAGINGCC = "gcc-cross-initial-${TARGET_ARCH}"
18STAGINGCC_class-nativesdk = "gcc-crosssdk-initial-${SDK_SYS}"
19TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TARGET}" 17TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TARGET}"
20PATH_prepend = "${STAGING_BINDIR_TOOLCHAIN}.${STAGINGCC}:"
21 18
22do_install_append() { 19do_install_append() {
23 # headers are already installed by mingw-w64-headers 20 # headers are already installed by mingw-w64-headers