summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Morrow <pemorrow@linux.microsoft.com>2021-04-07 03:31:07 -0700
committerJoshua Watt <JPEWhacker@gmail.com>2021-04-13 22:07:17 -0500
commit5543c32b8addb6cb88b43d296c0eac5ee57b018d (patch)
tree55699bd84c42936e0d8333b7b7002de7a79db115
parent422b96cb2b6116442be1f40dfb5bd77447d1219e (diff)
downloadmeta-mingw-5543c32b8addb6cb88b43d296c0eac5ee57b018d.tar.gz
go: add environment setup batch file for go
When building the nativesdk for mingw we need to set GOROOT in order to build anything out of the box. Signed-off-by: Peter Morrow <pemorrow@linux.microsoft.com> Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
-rw-r--r--recipes-devtools/go/go_%.bbappend9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes-devtools/go/go_%.bbappend b/recipes-devtools/go/go_%.bbappend
new file mode 100644
index 0000000..9933108
--- /dev/null
+++ b/recipes-devtools/go/go_%.bbappend
@@ -0,0 +1,9 @@
1do_install_append_class-nativesdk_mingw32() {
2 install -d ${D}${SDKPATHNATIVE}/environment-setup.d
3
4 cat <<EOF > ${D}${SDKPATHNATIVE}/environment-setup.d/go.bat
5set GOROOT=%OECORE_NATIVE_SYSROOT%\\usr\\lib\\${BPN}
6EOF
7}
8
9FILES_${PN}_append_class-nativesdk_mingw32 = " ${SDKPATHNATIVE}/environment-setup.d"