summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Watt <JPEWhacker@gmail.com>2020-07-21 12:55:36 -0500
committerJoshua Watt <JPEWhacker@gmail.com>2020-07-21 12:55:36 -0500
commitc8a0d13a5525fb4acc6da9793ad102b4fc5c141b (patch)
tree3e131b82165049a9a1b57e344490ff877e80e3eb
parentff018b12fde68c772a028bd8a2d93fb29174ec32 (diff)
downloadmeta-mingw-c8a0d13a5525fb4acc6da9793ad102b4fc5c141b.tar.gz
cmake: Remove toolchain append3.2_M2
Now that cmake.bbclass in OE-core correctly accounts for MinGW hosts, it is no longer necessary to manually specify that CMAKE_SYSTEM_NAME as "Windows" Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
-rw-r--r--recipes-devtools/cmake/cmake_%.bbappend6
1 files changed, 0 insertions, 6 deletions
diff --git a/recipes-devtools/cmake/cmake_%.bbappend b/recipes-devtools/cmake/cmake_%.bbappend
index d9d7ceb..42d36ac 100644
--- a/recipes-devtools/cmake/cmake_%.bbappend
+++ b/recipes-devtools/cmake/cmake_%.bbappend
@@ -1,7 +1 @@
1DEPENDS_remove_mingw32 = "ncurses" DEPENDS_remove_mingw32 = "ncurses"
2
3cmake_do_generate_toolchain_file_append_mingw32() {
4 cat >> ${WORKDIR}/toolchain.cmake <<EOF
5set( CMAKE_SYSTEM_NAME Windows )
6EOF
7}