summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2017-03-12 10:23:16 -0700
committerJuro Bystricky <juro.bystricky@intel.com>2017-03-12 11:12:46 -0700
commitb4ef177e6ebdc0aded3e202e0decbf1cb21c73dd (patch)
tree0627898953af4788409d5ef9e2068a11658efe4e
parentb44509e4665dc33b5bdb08b4e7b2f6543643f249 (diff)
downloadmeta-mingw-b4ef177e6ebdc0aded3e202e0decbf1cb21c73dd.tar.gz
gcc-runtime: Drop libmpx for mingw32 runtime
Intel Memory Protection Extension library for x86 builds are now enabled by default. However, the library does not build for mingw32, so remove it from mingw builds. Signed-off-by: Juro Bystricky <juro.bystricky@intel.com>
-rw-r--r--recipes-devtools/gcc/gcc-runtime_%.bbappend5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-devtools/gcc/gcc-runtime_%.bbappend b/recipes-devtools/gcc/gcc-runtime_%.bbappend
index df0ac9e..1641cb9 100644
--- a/recipes-devtools/gcc/gcc-runtime_%.bbappend
+++ b/recipes-devtools/gcc/gcc-runtime_%.bbappend
@@ -6,4 +6,9 @@ FILES_libssp_append_mingw32 = " ${bindir}/libssp*.dll"
6RUNTIMETARGET_remove_mingw32 = "libatomic libgomp" 6RUNTIMETARGET_remove_mingw32 = "libatomic libgomp"
7RUNTIMETARGET_remove_mingw32 = "libitm" 7RUNTIMETARGET_remove_mingw32 = "libitm"
8 8
9# Intel Memory Protection Extension library for x86 builds are now enabled
10# by default. However, it does not build for mingw32, so remove it from
11# mingw builds
12RUNTIMETARGET_remove_mingw32 = "libmpx"
13
9DEPENDS_append_mingw32 = " pthreads-win32" 14DEPENDS_append_mingw32 = " pthreads-win32"