summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2017-03-09 23:59:31 +1000
committerJuro Bystricky <juro.bystricky@intel.com>2017-04-06 13:47:39 -0700
commit7214dd703c982ec521cc9046557731c43f914694 (patch)
tree418db2f265a441ba8c995246361ad5e5896fb49d
parentd21fbaa987b54d8f18232b452e87e4f26bbed7a8 (diff)
downloadmeta-mingw-7214dd703c982ec521cc9046557731c43f914694.tar.gz
libsdl: Windows specific PACKAGECONFIG
Add a PACKAGECONFIG for 'stdio-redirect'. This configure option enables/disables the Windows only option for redirecting the stdout/stderr to files instead of to the console. Add the 'directx' PACKAGECONFIG to configure whether to build with DirectX support. By default this is enabled (when targeting mingw32/windows) however this requires the DirectX libraries in order to include and link against. Disable X11 support when building for the nativesdk mingw32. Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
-rw-r--r--recipes-graphics/libsdl/libsdl_%.bbappend7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-graphics/libsdl/libsdl_%.bbappend b/recipes-graphics/libsdl/libsdl_%.bbappend
new file mode 100644
index 0000000..5f5787d
--- /dev/null
+++ b/recipes-graphics/libsdl/libsdl_%.bbappend
@@ -0,0 +1,7 @@
1# Disable default x11 support
2PACKAGECONFIG_class-nativesdk_mingw32 = ""
3
4# Configs that only apply to Windows/MinGW
5PACKAGECONFIG[stdio-redirect] = "--enable-stdio-redirect,--disable-stdio-redirect"
6PACKAGECONFIG[directx] = "--enable-directx,--disable-directx"
7