summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2017-03-09 23:59:31 +1000
committerJuro Bystricky <juro.bystricky@intel.com>2017-04-06 13:47:39 -0700
commit6bda685e411317a8737547b6c0354dd48709bced (patch)
tree8d6f7dfa4039eee63cec3f7d2d75ca5b414380c9
parent11da907606ac657cfa6000d9063529ea0e825c23 (diff)
downloadmeta-mingw-6bda685e411317a8737547b6c0354dd48709bced.tar.gz
gettext_0.19.%.bbappend: Fix/enable shared building of gettext
Fix building of shared gettext for i686/32-bit mingw32. This adds a patch which fixes an issue with gnulib that is included in gettext. This patch does not need to be submitted upstream as it is fixing an issue with the included version of gnulib. Upstream gnulib has already fixed this issue and upstream gettext has already updated the included gnulib, however gettext has not yet made a release that includes this fix. Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
-rw-r--r--recipes-core/gettext/gettext/fix-gl_cv_prog_as_underscore-test.patch67
-rw-r--r--recipes-core/gettext/gettext_0.19.%.bbappend7
2 files changed, 73 insertions, 1 deletions
diff --git a/recipes-core/gettext/gettext/fix-gl_cv_prog_as_underscore-test.patch b/recipes-core/gettext/gettext/fix-gl_cv_prog_as_underscore-test.patch
new file mode 100644
index 0000000..636789f
--- /dev/null
+++ b/recipes-core/gettext/gettext/fix-gl_cv_prog_as_underscore-test.patch
@@ -0,0 +1,67 @@
1Backport gnulib fix for mingw into gettext's included version of gnulib
2
3http://git.savannah.gnu.org/cgit/gnulib.git/commit/?id=68b6adebef05670a312fb92b05e7bd089d2ed43a
4
5Upstream-Status: Backport
6Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
7
8--- a/gettext-runtime/gnulib-m4/asm-underscore.m4
9+++ b/gettext-runtime/gnulib-m4/asm-underscore.m4
10@@ -27,11 +27,11 @@
11 #endif
12 int foo(void) { return 0; }
13 EOF
14 # Look for the assembly language name in the .s file.
15 AC_TRY_COMMAND(${CC-cc} $CFLAGS $CPPFLAGS $gl_c_asm_opt conftest.c) >/dev/null 2>&1
16- if LC_ALL=C grep -E '(^|[^a-zA-Z0-9_])_foo([^a-zA-Z0-9_]|$)' conftest.$gl_asmext >/dev/null; then
17+ if LC_ALL=C grep -E '(^|[[^a-zA-Z0-9_]])_foo([[^a-zA-Z0-9_]]|$)' conftest.$gl_asmext >/dev/null; then
18 gl_cv_prog_as_underscore=yes
19 else
20 gl_cv_prog_as_underscore=no
21 fi
22 rm -f conftest*
23--- a/gettext-runtime/configure
24+++ b/gettext-runtime/configure
25@@ -24601,11 +24601,11 @@
26 { { eval echo "\"\$as_me\":${as_lineno-$LINENO}: \"$ac_try\""; } >&5
27 (eval $ac_try) 2>&5
28 ac_status=$?
29 $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
30 test $ac_status = 0; }; } >/dev/null 2>&1
31- if LC_ALL=C grep -E '(^|^a-zA-Z0-9_)_foo(^a-zA-Z0-9_|$)' conftest.$gl_asmext >/dev/null; then
32+ if LC_ALL=C grep -E '(^|[^a-zA-Z0-9_])_foo([^a-zA-Z0-9_]|$)' conftest.$gl_asmext >/dev/null; then
33 gl_cv_prog_as_underscore=yes
34 else
35 gl_cv_prog_as_underscore=no
36 fi
37 rm -f conftest*
38--- a/gettext-tools/gnulib-m4/asm-underscore.m4
39+++ b/gettext-tools/gnulib-m4/asm-underscore.m4
40@@ -27,11 +27,11 @@
41 #endif
42 int foo(void) { return 0; }
43 EOF
44 # Look for the assembly language name in the .s file.
45 AC_TRY_COMMAND(${CC-cc} $CFLAGS $CPPFLAGS $gl_c_asm_opt conftest.c) >/dev/null 2>&1
46- if LC_ALL=C grep -E '(^|[^a-zA-Z0-9_])_foo([^a-zA-Z0-9_]|$)' conftest.$gl_asmext >/dev/null; then
47+ if LC_ALL=C grep -E '(^|[[^a-zA-Z0-9_]])_foo([[^a-zA-Z0-9_]]|$)' conftest.$gl_asmext >/dev/null; then
48 gl_cv_prog_as_underscore=yes
49 else
50 gl_cv_prog_as_underscore=no
51 fi
52 rm -f conftest*
53--- a/gettext-tools/configure
54+++ b/gettext-tools/configure
55@@ -32284,11 +32284,11 @@
56 { { eval echo "\"\$as_me\":${as_lineno-$LINENO}: \"$ac_try\""; } >&5
57 (eval $ac_try) 2>&5
58 ac_status=$?
59 $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
60 test $ac_status = 0; }; } >/dev/null 2>&1
61- if LC_ALL=C grep -E '(^|^a-zA-Z0-9_)_foo(^a-zA-Z0-9_|$)' conftest.$gl_asmext >/dev/null; then
62+ if LC_ALL=C grep -E '(^|[^a-zA-Z0-9_])_foo([^a-zA-Z0-9_]|$)' conftest.$gl_asmext >/dev/null; then
63 gl_cv_prog_as_underscore=yes
64 else
65 gl_cv_prog_as_underscore=no
66 fi
67 rm -f conftest*
diff --git a/recipes-core/gettext/gettext_0.19.%.bbappend b/recipes-core/gettext/gettext_0.19.%.bbappend
index efd10d6..1cf0188 100644
--- a/recipes-core/gettext/gettext_0.19.%.bbappend
+++ b/recipes-core/gettext/gettext_0.19.%.bbappend
@@ -2,5 +2,10 @@ DEPENDS_append_mingw32 = " pthreads-win32"
2LDFLAGS_prepend_mingw32 = " -lpthread " 2LDFLAGS_prepend_mingw32 = " -lpthread "
3 3
4CFLAGS_append_mingw32 = " -DLIBXML_STATIC" 4CFLAGS_append_mingw32 = " -DLIBXML_STATIC"
5EXTRA_OECONF_append_mingw32 = " --enable-threads=windows --enable-static --disable-shared " 5EXTRA_OECONF_append_mingw32 = " --enable-threads=windows --enable-static"
6
7FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
8SRC_URI_append = " \
9 file://fix-gl_cv_prog_as_underscore-test.patch \
10 "
6 11