summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2020-09-18 15:29:51 +0300
committerJoshua Watt <JPEWhacker@gmail.com>2020-09-21 07:54:05 -0500
commitb7d37809364f5928777eb26a33a4f7949c18aa42 (patch)
tree09ef7c81aae8418137839ab3aa59377ef0eb149a
parent30a051401c0a73dfff486ca4d0303b434816200f (diff)
downloadmeta-mingw-b7d37809364f5928777eb26a33a4f7949c18aa42.tar.gz
Override SDK_VENDOR
Set SDK_VENDOR to '-w64', which makes the host triplet match what GCC expect to find when using mingw32-w64. This enables features that are not functional in the classic mingw32, but have been implemented in the mingw32-w64. Disable 32bit libs from the runtime component when compiling for 64bit, which were enabled as a side effect of the GCC config change. Signed-off-by: Samuli Piippo <samuli.piippo@qt.io> Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
-rw-r--r--conf/machine-sdk/include/mingw32-common.inc3
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_7.0.0.bb2
2 files changed, 5 insertions, 0 deletions
diff --git a/conf/machine-sdk/include/mingw32-common.inc b/conf/machine-sdk/include/mingw32-common.inc
index 9011ded..bc6c91e 100644
--- a/conf/machine-sdk/include/mingw32-common.inc
+++ b/conf/machine-sdk/include/mingw32-common.inc
@@ -1,4 +1,7 @@
1SDK_OS = "mingw32" 1SDK_OS = "mingw32"
2SDK_VENDOR_mingw32 = "-w64"
3SDK_VENDOR_sdkmingw32 = "-w64"
4
2NATIVESDKLIBC = "libc-mingw" 5NATIVESDKLIBC = "libc-mingw"
3 6
4PREFERRED_PROVIDER_virtual/nativesdk-${SDK_PREFIX}libc-for-gcc_mingw32 = "nativesdk-mingw-w64-runtime" 7PREFERRED_PROVIDER_virtual/nativesdk-${SDK_PREFIX}libc-for-gcc_mingw32 = "nativesdk-mingw-w64-runtime"
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_7.0.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_7.0.0.bb
index cf39c6a..9f79ffe 100644
--- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_7.0.0.bb
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_7.0.0.bb
@@ -19,6 +19,8 @@ PROVIDES += "virtual/nativesdk-libintl"
19 19
20TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TARGET}" 20TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TARGET}"
21 21
22EXTRA_OECONF_x86-64 = "--disable-lib32"
23
22do_configure() { 24do_configure() {
23 oe_runconf 25 oe_runconf
24} 26}