summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@kernel.crashing.org>2020-02-19 09:11:16 -0600
committerJoshua Watt <JPEWhacker@gmail.com>2020-02-21 14:57:58 -0600
commit2ffc8682f178c60b95b45ba2135105e1f0074e4c (patch)
treeb70ecff1fe8939d9cc4bc7f03edb869e9e40edb0
parent4e4f8abc700ec1131f62cd25fd5eaab020b483a6 (diff)
downloadmeta-mingw-2ffc8682f178c60b95b45ba2135105e1f0074e4c.tar.gz
gcc/binutils: Allow plugins to be enabled on cross-canadian toolchain
As of GCC 8, plugin support is available with mingw. If the plugins are enabled in the regular binutils/gcc configurations, carry over that configuration with the mingw versions as well. When plugins are enabled, they produce a file called [plugin].dll.a. This causes the debugsrc processor to find the file and attempt to pull out dwarf information. However, we need to prevent this as the files are not ELF, but in Microsoft PE format, and trigger an error if processed. Signed-off-by: Mark Hatle <mark.hatle@kernel.crashing.org> Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
-rw-r--r--recipes-devtools/binutils/binutils-cross-canadian_2.%.bbappend2
-rw-r--r--recipes-devtools/gcc/gcc-cross-canadian_%.bbappend7
2 files changed, 7 insertions, 2 deletions
diff --git a/recipes-devtools/binutils/binutils-cross-canadian_2.%.bbappend b/recipes-devtools/binutils/binutils-cross-canadian_2.%.bbappend
index 026c932..5845fe0 100644
--- a/recipes-devtools/binutils/binutils-cross-canadian_2.%.bbappend
+++ b/recipes-devtools/binutils/binutils-cross-canadian_2.%.bbappend
@@ -1,4 +1,4 @@
1EXTRA_OECONF_append_sdkmingw32 = " --disable-plugins --disable-nls" 1EXTRA_OECONF_append_sdkmingw32 = " --disable-nls"
2LDFLAGS_append_sdkmingw32 = " -Wl,-static" 2LDFLAGS_append_sdkmingw32 = " -Wl,-static"
3 3
4DEPENDS_remove_sdkmingw32 = "nativesdk-gettext" 4DEPENDS_remove_sdkmingw32 = "nativesdk-gettext"
diff --git a/recipes-devtools/gcc/gcc-cross-canadian_%.bbappend b/recipes-devtools/gcc/gcc-cross-canadian_%.bbappend
index 888d610..9c0d828 100644
--- a/recipes-devtools/gcc/gcc-cross-canadian_%.bbappend
+++ b/recipes-devtools/gcc/gcc-cross-canadian_%.bbappend
@@ -1,6 +1,11 @@
1INSANE_SKIP_${PN}_append_sdkmingw32 = " staticdev" 1INSANE_SKIP_${PN}_append_sdkmingw32 = " staticdev"
2EXTRA_OECONF_append_sdkmingw32 = " --disable-nls --disable-lto" 2EXTRA_OECONF_append_sdkmingw32 = " --disable-nls"
3LDFLAGS_append_sdkmingw32 = " -Wl,-static" 3LDFLAGS_append_sdkmingw32 = " -Wl,-static"
4EXEEXT_sdkmingw32 = ".exe" 4EXEEXT_sdkmingw32 = ".exe"
5ELFUTILS_sdkmingw32 = "" 5ELFUTILS_sdkmingw32 = ""
6DEPENDS_remove_sdkmingw32 = "nativesdk-gettext" 6DEPENDS_remove_sdkmingw32 = "nativesdk-gettext"
7
8# With plugins enabled, it will output 'dll.a' files that are mistaken
9# for ELF which can trigger a failure. Simply avoid processing these
10# to avoid the error condition.
11INHIBIT_PACKAGE_DEBUG_SPLIT = '1'