diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2014-05-27 14:39:52 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2014-05-27 15:59:44 +0000 |
commit | aa04ad46bbad56f7a385147bd393b399119187ac (patch) | |
tree | 04a048fc072cc4b414dfa7a49667f6c4ab955416 | |
parent | bda37a98bccb69e71e11524f4b6364020136133c (diff) | |
download | meta-mingw-aa04ad46bbad56f7a385147bd393b399119187ac.tar.gz |
gcc/nativesdk-mingw-w84-headers: Move symlinking to headers recipe
The symlinking is really an artefact of the way the headers are
provided. Move all the code into one place.
Also have the initial compiler depend on the headers else the build
can fail. High parallelism prevented the issue from being seen
in most cases.
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r-- | recipes-devtools/gcc/gcc-crosssdk-initial_4.8.bbappend | 9 | ||||
-rw-r--r-- | recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_2.0.8.bb | 8 |
2 files changed, 9 insertions, 8 deletions
diff --git a/recipes-devtools/gcc/gcc-crosssdk-initial_4.8.bbappend b/recipes-devtools/gcc/gcc-crosssdk-initial_4.8.bbappend index 7a7ca37..1c09342 100644 --- a/recipes-devtools/gcc/gcc-crosssdk-initial_4.8.bbappend +++ b/recipes-devtools/gcc/gcc-crosssdk-initial_4.8.bbappend | |||
@@ -1,8 +1 @@ | |||
1 | DEPENDS_append_mingw32 = " nativesdk-mingw-w64-headers" | ||
2 | do_install_append_mingw32 () { | ||
3 | ln -s ${STAGING_DIR_TARGET}/${target_exec_prefix}/ ${D}/${exec_prefix}/${TARGET_SYS} | ||
4 | } | ||
5 | |||
6 | sysroot_stage_all_append_mingw32 () { | ||
7 | sysroot_stage_dir ${D}${exec_prefix}/${TARGET_SYS} ${SYSROOT_DESTDIR}${exec_prefix}/${TARGET_SYS} | ||
8 | } \ No newline at end of file | ||
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_2.0.8.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_2.0.8.bb index b12a04e..a3d0e46 100644 --- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_2.0.8.bb +++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_2.0.8.bb | |||
@@ -26,8 +26,16 @@ do_compile() { | |||
26 | : | 26 | : |
27 | } | 27 | } |
28 | 28 | ||
29 | FILES_${PN} += "${exec_prefix}/${TARGET_SYS}" | ||
30 | |||
29 | do_install_append() { | 31 | do_install_append() { |
30 | # Move files to include folder where gcc-crosssdk-initial is looking | 32 | # Move files to include folder where gcc-crosssdk-initial is looking |
31 | mv ${D}${exec_prefix}/${HOST_SYS}/include ${D}${exec_prefix} | 33 | mv ${D}${exec_prefix}/${HOST_SYS}/include ${D}${exec_prefix} |
32 | rmdir ${D}${exec_prefix}/${HOST_SYS} | 34 | rmdir ${D}${exec_prefix}/${HOST_SYS} |
35 | |||
36 | ln -s ./ ${D}/${exec_prefix}/${HOST_SYS} | ||
37 | } | ||
38 | |||
39 | sysroot_stage_all_append_mingw32 () { | ||
40 | ln -s ./ ${SYSROOT_DESTDIR}${exec_prefix}/${HOST_SYS} | ||
33 | } | 41 | } |