summaryrefslogtreecommitdiffstats
path: root/meta-linaro/recipes-linaro/images
diff options
context:
space:
mode:
Diffstat (limited to 'meta-linaro/recipes-linaro/images')
-rw-r--r--meta-linaro/recipes-linaro/images/linaro-image-alip.bb9
-rw-r--r--meta-linaro/recipes-linaro/images/linaro-image-arago.bb20
-rw-r--r--meta-linaro/recipes-linaro/images/linaro-image-common.inc93
-rw-r--r--meta-linaro/recipes-linaro/images/linaro-image-kvm.bb6
-rw-r--r--meta-linaro/recipes-linaro/images/linaro-image-lamp.bb20
-rw-r--r--meta-linaro/recipes-linaro/images/linaro-image-leg-java.bb29
-rw-r--r--meta-linaro/recipes-linaro/images/linaro-image-lng.bb64
-rw-r--r--meta-linaro/recipes-linaro/images/linaro-image-minimal-initramfs.bb39
-rw-r--r--meta-linaro/recipes-linaro/images/linaro-image-minimal.bb2
-rw-r--r--meta-linaro/recipes-linaro/images/linaro-image-sdk.bb12
-rw-r--r--meta-linaro/recipes-linaro/images/linaro-image-toolchain-benchmark.bb18
-rw-r--r--meta-linaro/recipes-linaro/images/linaro-sysroot-alip.bb19
-rw-r--r--meta-linaro/recipes-linaro/images/linaro-sysroot-lamp.bb24
13 files changed, 355 insertions, 0 deletions
diff --git a/meta-linaro/recipes-linaro/images/linaro-image-alip.bb b/meta-linaro/recipes-linaro/images/linaro-image-alip.bb
new file mode 100644
index 0000000..8a76907
--- /dev/null
+++ b/meta-linaro/recipes-linaro/images/linaro-image-alip.bb
@@ -0,0 +1,9 @@
1DESCRIPTION = "Linaro image with basic X11 and firefox"
2
3inherit core-image
4
5IMAGE_FEATURES += "splash package-management x11-base x11-sato ssh-server-openssh"
6
7LICENSE = "MIT"
8
9IMAGE_INSTALL += "firefox gator openssh-sftp-server"
diff --git a/meta-linaro/recipes-linaro/images/linaro-image-arago.bb b/meta-linaro/recipes-linaro/images/linaro-image-arago.bb
new file mode 100644
index 0000000..ac61feb
--- /dev/null
+++ b/meta-linaro/recipes-linaro/images/linaro-image-arago.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Arago based image for testing"
2DESCRIPTION = "Image capable of booting and testing device."
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6require linaro-image-common.inc
7
8# List of packages to install
9IMAGE_INSTALL += "\
10 bc \
11 bonnie++ \
12 bridge-utils \
13 evtest \
14 hdparm \
15 iozone3 \
16 iperf \
17 lmbench \
18 memtester \
19 rt-tests \
20 "
diff --git a/meta-linaro/recipes-linaro/images/linaro-image-common.inc b/meta-linaro/recipes-linaro/images/linaro-image-common.inc
new file mode 100644
index 0000000..223df3a
--- /dev/null
+++ b/meta-linaro/recipes-linaro/images/linaro-image-common.inc
@@ -0,0 +1,93 @@
1inherit core-image
2
3IMAGE_FEATURES += "ssh-server-openssh nfs-server package-management"
4
5HUGETLB_armv7a = "libhugetlbfs-tests"
6HUGETLB_aarch64 = "libhugetlbfs-tests"
7HUGETLB ?= ""
8
9IMAGE_INSTALL += " \
10 bash \
11 e2fsprogs-e2fsck \
12 kexec-tools \
13 linaro-lava-tests \
14 nss-myhostname \
15 procps \
16 stress \
17 stress-dbg \
18 sudo \
19 util-linux-fsck \
20 "
21
22SDK_IMAGE_INSTALL += "\
23 acpica \
24 bison \
25 boost-date-time \
26 boost-filesystem \
27 boost-graph \
28 boost-iostreams \
29 boost-program-options \
30 boost-regex \
31 boost-signals \
32 boost-system \
33 boost-thread \
34 cmake \
35 curl \
36 dmidecode \
37 efibootmgr \
38 elfutils-dev \
39 expat \
40 flex \
41 gator \
42 gd \
43 git \
44 glog \
45 icu \
46 idlestat \
47 libbz2 \
48 libc-client-dev \
49 libcap \
50 libdwarf-dev \
51 libevent-fb \
52 libmcrypt \
53 libmemcached \
54 libmysqlclient-r \
55 libpam \
56 libpcre \
57 libunwind \
58 libxml2 \
59 lshw \
60 ltp \
61 ncurses \
62 onig \
63 openldap \
64 openssh-sftp-server \
65 openssl \
66 perf \
67 pm-qa \
68 powerdebug \
69 powertop \
70 python \
71 python-misc \
72 python-multiprocessing \
73 python-numpy \
74 python-scons \
75 python-shell \
76 python-threading \
77 qemu \
78 readline \
79 sshfs-fuse \
80 tbb \
81 trace-cmd \
82 xserver-xorg-xvfb \
83 xz \
84 zlib \
85 ${HUGETLB} \
86 "
87
88IMAGE_PREPROCESS_COMMAND += "make_boot_verbose; "
89
90
91fakeroot make_boot_verbose () {
92 sed -i -e 's/VERBOSE=no/VERBOSE=yes/' ${IMAGE_ROOTFS}/etc/default/rcS
93}
diff --git a/meta-linaro/recipes-linaro/images/linaro-image-kvm.bb b/meta-linaro/recipes-linaro/images/linaro-image-kvm.bb
new file mode 100644
index 0000000..e9512fa
--- /dev/null
+++ b/meta-linaro/recipes-linaro/images/linaro-image-kvm.bb
@@ -0,0 +1,6 @@
1require linaro-image-common.inc
2
3DESCRIPTION = "A small image for Linaro KVM validation."
4
5IMAGE_INSTALL += "qemu kernel-image kernel-bootwrapper"
6
diff --git a/meta-linaro/recipes-linaro/images/linaro-image-lamp.bb b/meta-linaro/recipes-linaro/images/linaro-image-lamp.bb
new file mode 100644
index 0000000..2eec075
--- /dev/null
+++ b/meta-linaro/recipes-linaro/images/linaro-image-lamp.bb
@@ -0,0 +1,20 @@
1require linaro-image-common.inc
2
3IMAGE_INSTALL += " \
4 apache2 \
5 fwts \
6 acpitests \
7 grub \
8 mysql5-server \
9 mysql5-client \
10 php-fpm \
11 php-fpm-apache2 \
12 packagegroup-core-buildessential \
13 ${SDK_IMAGE_INSTALL}"
14
15IMAGE_FEATURES += "\
16 dev-pkgs \
17 staticdev-pkgs \
18 tools-debug \
19 tools-sdk \
20 "
diff --git a/meta-linaro/recipes-linaro/images/linaro-image-leg-java.bb b/meta-linaro/recipes-linaro/images/linaro-image-leg-java.bb
new file mode 100644
index 0000000..c0f2c47
--- /dev/null
+++ b/meta-linaro/recipes-linaro/images/linaro-image-leg-java.bb
@@ -0,0 +1,29 @@
1require linaro-image-lamp.bb
2
3DESCRIPTION = "A Lamp-based image for Linaro Enterprise Java validation."
4
5IMAGE_INSTALL += " \
6 alsa-conf \
7 alsa-lib-dev \
8 alsa-lib \
9 alsa-oss \
10 alsa-utils-alsaconf \
11 alsa-utils-alsamixer \
12 cups-dev \
13 ganglia \
14 git \
15 htop \
16 links \
17 openjdk-8-doc \
18 openjdk-8-jdk \
19 openjdk-8-jre \
20 openjdk-8-jtreg \
21 openjdk-8-source \
22 sed \
23 tmux \
24 vim \
25 x11vnc \
26 xauth \
27 xserver-xorg-xvfb \
28 zip \
29 "
diff --git a/meta-linaro/recipes-linaro/images/linaro-image-lng.bb b/meta-linaro/recipes-linaro/images/linaro-image-lng.bb
new file mode 100644
index 0000000..7d46d68
--- /dev/null
+++ b/meta-linaro/recipes-linaro/images/linaro-image-lng.bb
@@ -0,0 +1,64 @@
1require linaro-image-common.inc
2
3IMAGE_INSTALL += " \
4 arndale-pre-boot \
5 bridge-utils \
6 calibrator \
7 curl \
8 cronie \
9 daq-odp \
10 fping \
11 git \
12 lmbench \
13 lng-network-config \
14 ltp \
15 netperf \
16 odp \
17 openssh-sftp-server \
18 openvswitch \
19 packagegroup-core-buildessential \
20 procps \
21 python-numpy \
22 qemu \
23 rt-tests \
24 snort \
25 trace-cmd \
26 tunctl \
27 usecpu \
28 "
29
30IMAGE_INSTALL_append_armv7a = " \
31 latency-test \
32 systemtap \
33 valgrind \
34 trinity-example \
35 "
36
37IMAGE_INSTALL_append_aarch64 = " \
38 trinity-example \
39 "
40
41IMAGE_INSTALL_append_qemux86 = " \
42 "
43
44IMAGE_FEATURES += "\
45 dev-pkgs \
46 staticdev-pkgs \
47 tools-debug \
48 tools-sdk \
49 "
50IMAGE_FSTYPES_append_qemux86 += "cpio.gz"
51IMAGE_FSTYPES_lng-x86-64 = "tar.gz cpio.gz"
52IMAGE_FSTYPES_lng-rt-x86-64 = "tar.gz cpio.gz"
53
54EXTRA_IMAGE_FEATURES_append_qemux86 = " autoserial"
55FEATURE_PACKAGES_autoserial = "auto-serial-console"
56
57IMAGE_PREPROCESS_COMMAND_qemux86 += "qemux86_fixup;"
58
59qemux86_fixup() {
60 sed -i '/getty 115200 ttyS0/d' ${IMAGE_ROOTFS}/etc/inittab
61
62 echo "auto eth0" >> ${IMAGE_ROOTFS}/etc/network/interfaces
63 echo "iface eth0 inet dhcp" >> ${IMAGE_ROOTFS}/etc/network/interfaces
64}
diff --git a/meta-linaro/recipes-linaro/images/linaro-image-minimal-initramfs.bb b/meta-linaro/recipes-linaro/images/linaro-image-minimal-initramfs.bb
new file mode 100644
index 0000000..f928797
--- /dev/null
+++ b/meta-linaro/recipes-linaro/images/linaro-image-minimal-initramfs.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Initramfs image for kernel boot testing"
2DESCRIPTION = "Small image capable of booting a device."
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6BAD_RECOMMENDATIONS += "busybox-syslog"
7
8export IMAGE_BASENAME = "linaro-image-minimal-initramfs"
9
10IMAGE_FSTYPES = "${INITRAMFS_FSTYPES} ${INITRAMFS_FSTYPES}.u-boot"
11
12# Do not pollute the initrd image with rootfs features
13IMAGE_FEATURES = ""
14
15# List of packages to install
16IMAGE_INSTALL = "\
17 base-passwd \
18 bash \
19 busybox \
20 bzip2 \
21 dhcp-client \
22 dosfstools \
23 e2fsprogs \
24 e2fsprogs-mke2fs \
25 gzip \
26 initramfs-boot-linaro \
27 net-tools \
28 parted \
29 tar \
30 u-boot-mkimage \
31 wget \
32 "
33
34# Keep extra language files from being installed
35IMAGE_LINGUAS = ""
36
37IMAGE_ROOTFS_SIZE = "8192"
38
39inherit core-image image_types_uboot
diff --git a/meta-linaro/recipes-linaro/images/linaro-image-minimal.bb b/meta-linaro/recipes-linaro/images/linaro-image-minimal.bb
new file mode 100644
index 0000000..abe579b
--- /dev/null
+++ b/meta-linaro/recipes-linaro/images/linaro-image-minimal.bb
@@ -0,0 +1,2 @@
1require recipes-core/images/core-image-minimal.bb
2require linaro-image-common.inc
diff --git a/meta-linaro/recipes-linaro/images/linaro-image-sdk.bb b/meta-linaro/recipes-linaro/images/linaro-image-sdk.bb
new file mode 100644
index 0000000..560da60
--- /dev/null
+++ b/meta-linaro/recipes-linaro/images/linaro-image-sdk.bb
@@ -0,0 +1,12 @@
1require linaro-image-common.inc
2
3DESCRIPTION = "A small SDK based image for Linaro development work."
4
5IMAGE_INSTALL += "${SDK_IMAGE_INSTALL}"
6
7IMAGE_FEATURES += "\
8 dev-pkgs \
9 staticdev-pkgs \
10 tools-debug \
11 tools-sdk \
12 "
diff --git a/meta-linaro/recipes-linaro/images/linaro-image-toolchain-benchmark.bb b/meta-linaro/recipes-linaro/images/linaro-image-toolchain-benchmark.bb
new file mode 100644
index 0000000..16aa531
--- /dev/null
+++ b/meta-linaro/recipes-linaro/images/linaro-image-toolchain-benchmark.bb
@@ -0,0 +1,18 @@
1SUMMARY = "Base image for toolchain benchmarking"
2DESCRIPTION = "Image capable of benchmarking the toolchain."
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6require recipes-core/images/core-image-minimal.bb
7require linaro-image-common.inc
8
9IMAGE_INSTALL += "\
10 bzip2 \
11 cpufrequtils \
12 netcat \
13 openssh-sftp-server \
14 rsync \
15 tar \
16 util-linux \
17 xz \
18 "
diff --git a/meta-linaro/recipes-linaro/images/linaro-sysroot-alip.bb b/meta-linaro/recipes-linaro/images/linaro-sysroot-alip.bb
new file mode 100644
index 0000000..3d0d1cc
--- /dev/null
+++ b/meta-linaro/recipes-linaro/images/linaro-sysroot-alip.bb
@@ -0,0 +1,19 @@
1require linaro-image-alip.bb
2
3IMAGE_FEATURES += "\
4 dev-pkgs \
5 "
6
7IMAGE_PREPROCESS_COMMAND += "do_delete_not_needed_dirs; "
8
9fakeroot do_delete_not_needed_dirs () {
10 for dir in bin boot dev etc home media mnt opt proc run sbin sys tmp var;
11 do
12 rm -rf ${IMAGE_ROOTFS}/${dir}
13 done
14
15 for dir in arm-oe-linux-gnueabi aarch64-oe-linux bin games sbin share src
16 do
17 rm -rf ${IMAGE_ROOTFS}/usr/${dir}
18 done
19}
diff --git a/meta-linaro/recipes-linaro/images/linaro-sysroot-lamp.bb b/meta-linaro/recipes-linaro/images/linaro-sysroot-lamp.bb
new file mode 100644
index 0000000..67eeb0f
--- /dev/null
+++ b/meta-linaro/recipes-linaro/images/linaro-sysroot-lamp.bb
@@ -0,0 +1,24 @@
1inherit core-image
2
3IMAGE_INSTALL = " \
4 packagegroup-core-standalone-hhvm-sdk-target \
5 "
6
7IMAGE_FEATURES += "\
8 dev-pkgs \
9 staticdev-pkgs \
10 "
11
12IMAGE_PREPROCESS_COMMAND += "do_delete_not_needed_dirs; "
13
14fakeroot do_delete_not_needed_dirs () {
15 for dir in bin boot dev etc home media mnt opt proc run sbin sys tmp var;
16 do
17 rm -rf ${IMAGE_ROOTFS}/${dir}
18 done
19
20 for dir in aarch64-oe-linux bin games sbin share src
21 do
22 rm -rf ${IMAGE_ROOTFS}/usr/${dir}
23 done
24}