summaryrefslogtreecommitdiffstats
path: root/meta-linaro/recipes-extra/lshw/lshw_02.16.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-linaro/recipes-extra/lshw/lshw_02.16.bb')
-rw-r--r--meta-linaro/recipes-extra/lshw/lshw_02.16.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-linaro/recipes-extra/lshw/lshw_02.16.bb b/meta-linaro/recipes-extra/lshw/lshw_02.16.bb
new file mode 100644
index 0000000..214d2ba
--- /dev/null
+++ b/meta-linaro/recipes-extra/lshw/lshw_02.16.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "A small tool to provide detailed information on the hardware \
2configuration of the machine. It can report exact memory configuration, \
3firmware version, mainboard configuration, CPU version and speed, cache \
4configuration, bus speed, etc. on DMI-capable or EFI systems."
5SUMMARY = "Hardware lister"
6HOMEPAGE = "http://ezix.org/project/wiki/HardwareLiSter"
7SECTION = "console/tools"
8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
10DEPENDS = "pciutils \
11 usbutils"
12COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
13
14PR="r1"
15
16SRC_URI="http://ezix.org/software/files/lshw-B.${PV}.tar.gz \
17 file://cross-compile.patch"
18
19SRC_URI[md5sum] = "67479167add605e8f001097c30e96d0d"
20SRC_URI[sha256sum] = "809882429555b93259785cc261dbff04c16c93d064db5f445a51945bc47157cb"
21
22S="${WORKDIR}/lshw-B.${PV}"
23
24do_compile() {
25 # build core only - don't ship gui
26 oe_runmake -C src core
27}
28
29do_install() {
30 oe_runmake install DESTDIR=${D}
31 # data files provided by dependencies
32 rm -rf ${D}/usr/share/lshw
33}