summaryrefslogtreecommitdiffstats
path: root/meta-linaro/recipes-extra/hiphopvm/hiphopvm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-linaro/recipes-extra/hiphopvm/hiphopvm_git.bb')
-rw-r--r--meta-linaro/recipes-extra/hiphopvm/hiphopvm_git.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/meta-linaro/recipes-extra/hiphopvm/hiphopvm_git.bb b/meta-linaro/recipes-extra/hiphopvm/hiphopvm_git.bb
new file mode 100644
index 0000000..77cd299
--- /dev/null
+++ b/meta-linaro/recipes-extra/hiphopvm/hiphopvm_git.bb
@@ -0,0 +1,67 @@
1DEPENDS = " \
2binutils \
3bison-native \
4boost \
5bzip2 \
6cmake \
7elfutils \
8expat \
9flex-native \
10gd \
11glog \
12icu \
13libcap \
14libc-client \
15libdwarf \
16libevent-fb \
17libmcrypt \
18libmemcached \
19libunwind \
20libxml2 \
21mysql5 \
22ncurses \
23onig \
24openldap \
25openssl \
26libpam \
27pcre \
28readline \
29zlib \
30tbb \
31${EXTRA_DEPENDS} \
32"
33
34# optional (for now) dependencies:
35EXTRA_DEPENDS = "gperftools"
36EXTRA_DEPENDS_aarch64 = ""
37
38# 64-bit platforms only
39COMPATIBLE_HOST = '(x86_64.*|aarch64.*)-linux'
40
41LICENSE = "PHP Zend"
42
43LIC_FILES_CHKSUM = " \
44 file://LICENSE.PHP;md5=cb564efdf78cce8ea6e4b5a4f7c05d97 \
45 file://LICENSE.ZEND;md5=69e7a9c51846dd6692f1b946f95f6c60"
46
47SRC_URI = "git://github.com/facebook/hhvm.git \
48 file://hrw-check-for-libdwarf-in-our-place-first.patch \
49 "
50
51SRCREV = "4c4d11304aef8857dcce8524e7fd9223e00191b5"
52
53PV = "2.0.2+git${SRCPV}"
54
55S = "${WORKDIR}/git"
56
57do_configure_prepend() {
58 export HPHP_HOME="${B}"
59 export HPHP_LIB="${B}"/bin
60 export USE_HHVM=1
61 export BOOST_INCLUDEDIR=${STAGING_INCDIR}
62 export BOOST_LIBRARYDIR=${STAGING_LIBDIR}
63 export LIBGLOG_INCLUDE_DIR=${STAGING_INCDIR}
64 export LIBGLOG_LIBRARY=${STAGING_LIBDIR}
65}
66
67inherit cmake