summaryrefslogtreecommitdiffstats
path: root/meta-linaro/recipes-extra/calibrator/calibrator_0.9e.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:46:13 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:46:13 +0200
commit8d89651ef729e560ad96dcfc002fcde6ff7f923b (patch)
treeeb5be01c25f735d12fe9881ee6327c9b7e8bbe39 /meta-linaro/recipes-extra/calibrator/calibrator_0.9e.bb
downloadmeta-linaro-8d89651ef729e560ad96dcfc002fcde6ff7f923b.tar.gz
initial commit for Enea Linux 5.0 armdizzy-enea
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-linaro/recipes-extra/calibrator/calibrator_0.9e.bb')
-rw-r--r--meta-linaro/recipes-extra/calibrator/calibrator_0.9e.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-linaro/recipes-extra/calibrator/calibrator_0.9e.bb b/meta-linaro/recipes-extra/calibrator/calibrator_0.9e.bb
new file mode 100644
index 0000000..7911e0f
--- /dev/null
+++ b/meta-linaro/recipes-extra/calibrator/calibrator_0.9e.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Cache-Memory and TLB calibration tool"
2DESCRIPTION = "The Calibrator is a small C program that is supposed to \
3analyze a computers (cache-) memory system and extract the following \
4parameters: \
5number of cache levels, main memory access latency, number of TLB levels."
6HOMEPAGE = "http://homepages.cwi.nl/~manegold/Calibrator/"
7SECTION = "console/tools"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://calibrator.c;endline=39;md5=102be98d5b443582cffa8eb4ee776af8"
10PR = "r0"
11
12SRC_URI = "http://homepages.cwi.nl/~manegold/Calibrator/src/calibrator.c \
13 file://fix_conflicting_types_for_round.patch"
14SRC_URI[md5sum] = "5355f07ab1103e6d2948e08936d1ff54"
15SRC_URI[sha256sum] = "2018ed8fa733155d44ceb1c0066c5cf8df7771cdf7cfca0a07b8dd9bebd9c221"
16
17S = "${WORKDIR}"
18
19do_compile() {
20 ${CC} ${CFLAGS} calibrator.c -o calibrator -lm
21}
22
23do_install() {
24 install -D -p -m0755 calibrator ${D}${bindir}/calibrator
25}
26
27COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"