summaryrefslogtreecommitdiffstats
path: root/meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.8/0040-fix-g++-sysroot.patch
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:46:13 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:46:13 +0200
commit8d89651ef729e560ad96dcfc002fcde6ff7f923b (patch)
treeeb5be01c25f735d12fe9881ee6327c9b7e8bbe39 /meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.8/0040-fix-g++-sysroot.patch
downloadmeta-linaro-8d89651ef729e560ad96dcfc002fcde6ff7f923b.tar.gz
initial commit for Enea Linux 5.0 armdizzy-enea
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.8/0040-fix-g++-sysroot.patch')
-rw-r--r--meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.8/0040-fix-g++-sysroot.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.8/0040-fix-g++-sysroot.patch b/meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.8/0040-fix-g++-sysroot.patch
new file mode 100644
index 0000000..d50aa5c
--- /dev/null
+++ b/meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.8/0040-fix-g++-sysroot.patch
@@ -0,0 +1,40 @@
1Portions of
2
3http://www.mail-archive.com/gcc-patches@gcc.gnu.org/msg26013.html
4
5are not upstreamed yet. So lets keep missing pieces.
6
7Upstream-Status: Pending
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10
11Index: gcc-4.8.1/gcc/configure.ac
12===================================================================
13--- gcc-4.8.1.orig/gcc/configure.ac 2013-07-15 15:55:49.488399132 -0700
14+++ gcc-4.8.1/gcc/configure.ac 2013-07-15 16:02:31.772406679 -0700
15@@ -148,7 +148,9 @@
16 if test "${with_sysroot+set}" = set; then
17 gcc_gxx_without_sysroot=`expr "${gcc_gxx_include_dir}" : "${with_sysroot}"'\(.*\)'`
18 if test "${gcc_gxx_without_sysroot}"; then
19- gcc_gxx_include_dir="${gcc_gxx_without_sysroot}"
20+ if test x${with_sysroot} != x/; then
21+ gcc_gxx_include_dir="${gcc_gxx_without_sysroot}"
22+ fi
23 gcc_gxx_include_dir_add_sysroot=1
24 fi
25 fi
26Index: gcc-4.8.1/gcc/configure
27===================================================================
28--- gcc-4.8.1.orig/gcc/configure 2013-07-15 15:55:49.472399132 -0700
29+++ gcc-4.8.1/gcc/configure 2013-07-15 16:02:31.780406680 -0700
30@@ -3325,7 +3325,9 @@
31 if test "${with_sysroot+set}" = set; then
32 gcc_gxx_without_sysroot=`expr "${gcc_gxx_include_dir}" : "${with_sysroot}"'\(.*\)'`
33 if test "${gcc_gxx_without_sysroot}"; then
34- gcc_gxx_include_dir="${gcc_gxx_without_sysroot}"
35+ if test x${with_sysroot} != x/; then
36+ gcc_gxx_include_dir="${gcc_gxx_without_sysroot}"
37+ fi
38 gcc_gxx_include_dir_add_sysroot=1
39 fi
40 fi