diff options
author | Tudor Florea <tudor.florea@enea.com> | 2015-10-08 22:46:13 +0200 |
---|---|---|
committer | Tudor Florea <tudor.florea@enea.com> | 2015-10-08 22:46:13 +0200 |
commit | 8d89651ef729e560ad96dcfc002fcde6ff7f923b (patch) | |
tree | eb5be01c25f735d12fe9881ee6327c9b7e8bbe39 /meta-bigendian/recipes-devtools/python | |
download | meta-linaro-8d89651ef729e560ad96dcfc002fcde6ff7f923b.tar.gz |
initial commit for Enea Linux 5.0 armdizzy-enea
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-bigendian/recipes-devtools/python')
3 files changed, 45 insertions, 0 deletions
diff --git a/meta-bigendian/recipes-devtools/python/python-numpy_1.7.0.bbappend b/meta-bigendian/recipes-devtools/python/python-numpy_1.7.0.bbappend new file mode 100644 index 0000000..aa9df9a --- /dev/null +++ b/meta-bigendian/recipes-devtools/python/python-numpy_1.7.0.bbappend | |||
@@ -0,0 +1,8 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | SRC_URI += " ${CONFIGFILESURI} " | ||
4 | |||
5 | CONFIGFILESURI_armeb = " \ | ||
6 | file://config.h \ | ||
7 | file://numpyconfig.h \ | ||
8 | " | ||
diff --git a/meta-bigendian/recipes-devtools/python/python/python_ffi_armeb_be8.patch b/meta-bigendian/recipes-devtools/python/python/python_ffi_armeb_be8.patch new file mode 100644 index 0000000..afd090b --- /dev/null +++ b/meta-bigendian/recipes-devtools/python/python/python_ffi_armeb_be8.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | Index: Python-2.7.3/Modules/_ctypes/libffi/src/arm/ffi.c | ||
2 | =================================================================== | ||
3 | --- Python-2.7.3.orig/Modules/_ctypes/libffi/src/arm/ffi.c | ||
4 | +++ Python-2.7.3/Modules/_ctypes/libffi/src/arm/ffi.c | ||
5 | @@ -272,7 +272,7 @@ ffi_prep_incoming_args_SYSV(char *stack, | ||
6 | } | ||
7 | |||
8 | /* How to make a trampoline. */ | ||
9 | - | ||
10 | +#if !(defined(__ARMEB__) && defined(__ARM_ARCH_7A__)) | ||
11 | #define FFI_INIT_TRAMPOLINE(TRAMP,FUN,CTX) \ | ||
12 | ({ unsigned char *__tramp = (unsigned char*)(TRAMP); \ | ||
13 | unsigned int __fun = (unsigned int)(FUN); \ | ||
14 | @@ -284,7 +284,19 @@ ffi_prep_incoming_args_SYSV(char *stack, | ||
15 | *(unsigned int*) &__tramp[16] = __fun; \ | ||
16 | __clear_cache((&__tramp[0]), (&__tramp[19])); \ | ||
17 | }) | ||
18 | - | ||
19 | +#else /* armv7 big endian: be8 instructions are still little endian */ | ||
20 | +#define FFI_INIT_TRAMPOLINE(TRAMP,FUN,CTX) \ | ||
21 | +({ unsigned char *__tramp = (unsigned char*)(TRAMP); \ | ||
22 | + unsigned int __fun = (unsigned int)(FUN); \ | ||
23 | + unsigned int __ctx = (unsigned int)(CTX); \ | ||
24 | + *(unsigned int*) &__tramp[0] = 0x0f002de9; /* swab(0xe92d000f, 4) - stmfd sp!, {r0-r3} */ \ | ||
25 | + *(unsigned int*) &__tramp[4] = 0x00009fe5; /* swab(0xe59f0000, 4) - ldr r0, [pc] */ \ | ||
26 | + *(unsigned int*) &__tramp[8] = 0x00f09fe5; /* swab(0xe59ff000, 4) - ldr pc, [pc] */ \ | ||
27 | + *(unsigned int*) &__tramp[12] = __ctx; \ | ||
28 | + *(unsigned int*) &__tramp[16] = __fun; \ | ||
29 | + __clear_cache((&__tramp[0]), (&__tramp[19])); \ | ||
30 | + }) | ||
31 | +#endif | ||
32 | |||
33 | /* the cif must already be prep'ed */ | ||
34 | |||
diff --git a/meta-bigendian/recipes-devtools/python/python_2.7.3.bbappend b/meta-bigendian/recipes-devtools/python/python_2.7.3.bbappend new file mode 100644 index 0000000..db79a4a --- /dev/null +++ b/meta-bigendian/recipes-devtools/python/python_2.7.3.bbappend | |||
@@ -0,0 +1,3 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | SRC_URI += "file://python_ffi_armeb_be8.patch" | ||