diff options
Diffstat (limited to 'recipes-core')
-rw-r--r-- | recipes-core/openjdk/openjdk-7_91b01-2.6.2.bb | 2 | ||||
-rw-r--r-- | recipes-core/openjdk/patches-openjdk-7/icedtea-dtrace-std_h.patch | 40 |
2 files changed, 42 insertions, 0 deletions
diff --git a/recipes-core/openjdk/openjdk-7_91b01-2.6.2.bb b/recipes-core/openjdk/openjdk-7_91b01-2.6.2.bb index 1431301..047aac4 100644 --- a/recipes-core/openjdk/openjdk-7_91b01-2.6.2.bb +++ b/recipes-core/openjdk/openjdk-7_91b01-2.6.2.bb | |||
@@ -57,6 +57,7 @@ ICEDTEAPATCHES = "\ | |||
57 | file://icedtea-crosscompile-fix.patch;apply=no \ | 57 | file://icedtea-crosscompile-fix.patch;apply=no \ |
58 | file://icedtea-xawt-crosscompile-fix.patch;apply=no \ | 58 | file://icedtea-xawt-crosscompile-fix.patch;apply=no \ |
59 | file://icedtea-jdk-unzip.patch;apply=no \ | 59 | file://icedtea-jdk-unzip.patch;apply=no \ |
60 | file://icedtea-dtrace-std_h.patch;apply=no \ | ||
60 | " | 61 | " |
61 | 62 | ||
62 | DISTRIBUTION_PATCHES = "\ | 63 | DISTRIBUTION_PATCHES = "\ |
@@ -66,6 +67,7 @@ DISTRIBUTION_PATCHES = "\ | |||
66 | patches/icedtea-crosscompile-fix.patch \ | 67 | patches/icedtea-crosscompile-fix.patch \ |
67 | patches/icedtea-xawt-crosscompile-fix.patch \ | 68 | patches/icedtea-xawt-crosscompile-fix.patch \ |
68 | patches/icedtea-jdk-unzip.patch \ | 69 | patches/icedtea-jdk-unzip.patch \ |
70 | patches/icedtea-dtrace-std_h.patch \ | ||
69 | " | 71 | " |
70 | 72 | ||
71 | export DISTRIBUTION_PATCHES | 73 | export DISTRIBUTION_PATCHES |
diff --git a/recipes-core/openjdk/patches-openjdk-7/icedtea-dtrace-std_h.patch b/recipes-core/openjdk/patches-openjdk-7/icedtea-dtrace-std_h.patch new file mode 100644 index 0000000..9ec59b7 --- /dev/null +++ b/recipes-core/openjdk/patches-openjdk-7/icedtea-dtrace-std_h.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | openjdk hotspot build system std.h fix | ||
2 | |||
3 | Backport from upstream from jdk9 | ||
4 | |||
5 | OpenJDK / jdk9 / hs-rt / hotspot | ||
6 | |||
7 | changeset 6671:465eb6bc50d1 | ||
8 | |||
9 | 8046818: Hotspot build system looking for sdt.h in the wrong place | ||
10 | Reviewed-by: sla, dholmes | ||
11 | author mikael | ||
12 | date Thu, 03 Jul 2014 09:16:56 -0700 (14 months ago) | ||
13 | parents 35de71d2af77 | ||
14 | children da4514678bcf | ||
15 | files make/linux/makefiles/dtrace.make | ||
16 | diffstat 1 files changed, 8 insertions(+), 1 deletions(-) [+] | ||
17 | |||
18 | Upstream-Status: Backport | ||
19 | --- | ||
20 | openjdk/hotspot/make/linux/makefiles/dtrace.make | 9 ++++++++- | ||
21 | 1 file changed, 8 insertions(+), 1 deletion(-) | ||
22 | |||
23 | --- openjdk/hotspot/make/linux/makefiles/dtrace.make | ||
24 | +++ openjdk/hotspot/make/linux/makefiles/dtrace.make | ||
25 | @@ -40,7 +40,14 @@ | ||
26 | ifneq ($(ALT_SDT_H),) | ||
27 | SDT_H_FILE = $(ALT_SDT_H) | ||
28 | else | ||
29 | - SDT_H_FILE = /usr/include/sys/sdt.h | ||
30 | + ifeq ($(USE_CLANG), true) | ||
31 | + # Clang doesn't support the -print-sysroot option and there is no known equivalent | ||
32 | + # option, so fall back to using / as sysroot | ||
33 | + SDT_SYSROOT= | ||
34 | + else | ||
35 | + SDT_SYSROOT=$(shell $(CXX) -print-sysroot) | ||
36 | + endif | ||
37 | + SDT_H_FILE = $(SDT_SYSROOT)/usr/include/sys/sdt.h | ||
38 | endif | ||
39 | DTRACE_ENABLED = $(shell test -f $(SDT_H_FILE) && echo $(SDT_H_FILE)) | ||
40 | REASON = "$(SDT_H_FILE) not found" | ||