diff options
Diffstat (limited to 'recipes-core')
-rw-r--r-- | recipes-core/ant-contrib/ant-contrib-native_1.0b3.bb | 37 |
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-core/ant-contrib/ant-contrib-native_1.0b3.bb b/recipes-core/ant-contrib/ant-contrib-native_1.0b3.bb new file mode 100644 index 0000000..2a44ea2 --- /dev/null +++ b/recipes-core/ant-contrib/ant-contrib-native_1.0b3.bb | |||
@@ -0,0 +1,37 @@ | |||
1 | SUMMARY = "(java): collection of tasks, types and other tools for Apache Ant" | ||
2 | DESCRIPTION = "The Ant-Contrib project is a collection of tasks (and at one \ | ||
3 | point maybe types and other tools) for Apache Ant." | ||
4 | HOMEPAGE = "http://ant-contrib.sourceforge.net" | ||
5 | PRIORITY = "optional" | ||
6 | SECTION = "libs" | ||
7 | LICENSE = "Apache-2.0" | ||
8 | LIC_FILES_CHKSUM = "file://docs/LICENSE.txt;md5=f84919efee8dbf5c7730927c5b8716f9" | ||
9 | |||
10 | DEPENDS = "ant-native commons-cli-native commons-codec-native \ | ||
11 | commons-httpclient-native commons-logging-native \ | ||
12 | oro-native bcel-native xerces-j-native \ | ||
13 | " | ||
14 | |||
15 | inherit java-library java-native | ||
16 | |||
17 | SRC_URI = "${SOURCEFORGE_MIRROR}/ant-contrib/ant-contrib-${PV}-src.zip" | ||
18 | |||
19 | SRC_URI[md5sum] = "07b23539bef04ec56970c876a33f7665" | ||
20 | SRC_URI[sha256sum] = "ba3621f397af14d5a19375f391ec9bf2908c46c5558ca0df8365e04fe3ac3633" | ||
21 | |||
22 | S = "${WORKDIR}/ant-contrib" | ||
23 | |||
24 | do_compile() { | ||
25 | mkdir -p build | ||
26 | |||
27 | oe_makeclasspath cp -s ant commons-cli commons-codec commons-httpclient commons-logging oro bcel xercesImpl | ||
28 | cp=build:${S}/lib/ivy/jars/ivy-1.3.1.jar:$cp | ||
29 | |||
30 | find src/java -name "*.java" > java_files | ||
31 | |||
32 | javac -sourcepath src/java -cp $cp -d build @java_files | ||
33 | |||
34 | (cd src/java && find . \( -name "*.properties" -or -name "*.xml" -or -name "*.mf" \) -exec cp {} ../../build/{} \;) | ||
35 | |||
36 | fastjar cf ${JARFILENAME} -C build . | ||
37 | } | ||