summaryrefslogtreecommitdiffstats
path: root/recipes-core/xml-commons/xom_1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/xml-commons/xom_1.1.bb')
-rw-r--r--recipes-core/xml-commons/xom_1.1.bb54
1 files changed, 0 insertions, 54 deletions
diff --git a/recipes-core/xml-commons/xom_1.1.bb b/recipes-core/xml-commons/xom_1.1.bb
deleted file mode 100644
index c37965b..0000000
--- a/recipes-core/xml-commons/xom_1.1.bb
+++ /dev/null
@@ -1,54 +0,0 @@
1DESCRIPTION = "Tree-based API for processing XML with Java"
2LICENSE = "LGPL-2.1"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=456080cf80cd56d4d58118c1d10d824f"
4
5HOMEPAGE = "http://xom.nu"
6
7SRC_URI = "\
8 http://www.cafeconleche.org/XOM/${P}-src.tar.gz;name=archive \
9 http://dist.codehaus.org/jaxen/distributions/jaxen-1.1.1-src.tar.gz;name=jaxen \
10 file://04_remove_sun_import.patch \
11 "
12
13# DEBUG: Executing shell function do_compile
14# ----------
15# 1. ERROR in src/nu/xom/UnicodeUtil.java (at line 0)
16# /* Copyright 2005 Elliotte Rusty Harold
17# ^
18# Internal compiler error: java.lang.StackOverflowError at org.eclipse.jdt.internal.compiler.ast.Expression.checkNPE(Expression.java:511)
19# ----------
20# Exception in thread "main" java.lang.StackOverflowError
21# at org.eclipse.jdt.internal.compiler.ast.Expression.checkNPE(Expression.java:511)
22PNBLACKLIST[xom] ?= "BROKEN: do_compile fails with internal javac error"
23
24S = "${WORKDIR}/XOM"
25
26inherit java-library
27
28DEPENDS = "fastjar-native xerces-j xalan-j"
29
30do_compile() {
31 mkdir -p build
32
33 oe_makeclasspath cp -s xercesImpl xalan2
34 cp=build:$cp
35
36 scp="${WORKDIR}/jaxen-1.1.1/src/java/main"
37
38 javac -sourcepath src:$scp -cp $cp -d build `find src -name "*.java" -and -not \( -wholename "*tests*" -or -wholename "*samples*" -or -wholename "*tools*" \)`
39 javac -sourcepath fatsrc:$scp -cp $cp -d build `find fatsrc -name "*.java" -and -not \( -wholename "*tests*" -or -wholename "*samples*" -or -wholename "*tools*" \)`
40 javac -sourcepath src15:$scp -cp $cp -d build `find src15 -name "*.java" -and -not \( -wholename "*tests*" -or -wholename "*samples*" -or -wholename "*tools*" \)`
41
42 (cd src && find . -name "*.properties" -exec cp {} ../build/{} \;)
43
44 # Remove Jaxen classes from build
45 rm -rf build/org/jaxen
46 rm -rf build/org/w3c
47
48 fastjar -C build -c -f ${JARFILENAME} .
49}
50
51SRC_URI[archive.md5sum] = "e5ae82568d7b1faeb950140c34fbbcb1"
52SRC_URI[archive.sha256sum] = "d648fd1f7b7437123afa63df06f6a6409a0487c99ca8f8beba75aaa474d65818"
53SRC_URI[jaxen.md5sum] = "b598ae6b7e765a92e13667b0a80392f4"
54SRC_URI[jaxen.sha256sum] = "f24ae604a20da87e3716bb1d441c483e56479eaef4e99888f41be06059790bca"