summaryrefslogtreecommitdiffstats
path: root/recipes-core/xml-commons/jdom_1.1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/xml-commons/jdom_1.1.3.bb')
-rw-r--r--recipes-core/xml-commons/jdom_1.1.3.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-core/xml-commons/jdom_1.1.3.bb b/recipes-core/xml-commons/jdom_1.1.3.bb
new file mode 100644
index 0000000..8997bcc
--- /dev/null
+++ b/recipes-core/xml-commons/jdom_1.1.3.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Parses, manipulates, and outputs XML using standard Java constructs"
2DESCRIPTION = "JDOM aims to provide a complete, Java-based solution for \
3accessing, manipulating, and outputting XML data from Java code."
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=897c700e4c122d8f4ef8f6d253a6f744"
6
7HOMEPAGE = "http://jdom.org/"
8
9DEPENDS = "fastjar-native virtual/javac-native jaxen"
10
11SRC_URI = "http://www.jdom.org/dist/source/archive/jdom-${PV}.tar.gz"
12SRC_URI[md5sum] = "dc8391e84cfdb170fcd8279aa370019f"
13SRC_URI[sha256sum] = "d471718c4ac7a1a2f10715b93cb3fcd2ecbab60384b73ad1c089712e47bd8d1f"
14
15inherit java-library
16
17do_compile() {
18 mkdir -p build
19
20 oe_makeclasspath cp -s jaxen
21
22 javac -sourcepath src/java -cp $cp -d build `find src/java -name "*.java"`
23
24 fastjar -C build -c -f ${JARFILENAME} .
25}