summaryrefslogtreecommitdiffstats
path: root/recipes-core/xml-commons/jaxen_1.1.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/xml-commons/jaxen_1.1.6.bb')
-rw-r--r--recipes-core/xml-commons/jaxen_1.1.6.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes-core/xml-commons/jaxen_1.1.6.bb b/recipes-core/xml-commons/jaxen_1.1.6.bb
new file mode 100644
index 0000000..2e313fa
--- /dev/null
+++ b/recipes-core/xml-commons/jaxen_1.1.6.bb
@@ -0,0 +1,40 @@
1SUMMARY = "XPath library written in Java"
2DESCRIPTION = "Adaptable to many different object models, including \
3DOM, XOM, dom4j, and JDOM. Is it also possible to write adapters that \
4treat non-XML trees such as compiled Java byte code or Java beans as XML, \
5thus enabling you to query these trees with XPath too.\
6"
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a2e66c2e2482aa23c11342f1469fa3b6"
9
10HOMEPAGE = "http://jaxen.org/"
11
12DEPENDS = "fastjar-native xerces-j xom"
13
14# upstream has moved to github, do not rely on ephemeral tarball, use git
15SRCREV = "7d7755ac8b19daa2ff6f319f432b864cc72d89b6"
16
17SRC_URI = "\
18 git://github.com/codehaus/${BPN} \
19 http://www.jdom.org/dist/binary/archive/jdom-1.1.tar.gz;name=jdom \
20"
21SRC_URI[jdom.md5sum] = "22745cbaaddb12884ed8ee09083d8fe2"
22SRC_URI[jdom.sha256sum] = "a13549087141be24ad176b659afdc2c675f1ffa5288ff999a193d6d44a282056"
23
24S = "${WORKDIR}/git/jaxen"
25
26inherit java-library
27
28do_compile() {
29 mkdir -p build
30
31 oe_makeclasspath cp -s xercesImpl xom
32 scp="src/java/main:${WORKDIR}/jdom-1.1/src/java"
33
34 javac -sourcepath $scp -cp $cp -d build `find src/java/main -name "*.java" -and -not -wholename "*dom4j*"`
35 (cd src/java/main && find org -name "*.properties" -exec cp {} ../../../build/{} \;)
36
37 rm -rf build/org/jdom
38
39 fastjar -C build -c -f ${JARFILENAME} .
40}