summaryrefslogtreecommitdiffstats
path: root/recipes-core/xml-commons/jaxen_1.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/xml-commons/jaxen_1.1.1.bb')
-rw-r--r--recipes-core/xml-commons/jaxen_1.1.1.bb35
1 files changed, 0 insertions, 35 deletions
diff --git a/recipes-core/xml-commons/jaxen_1.1.1.bb b/recipes-core/xml-commons/jaxen_1.1.1.bb
deleted file mode 100644
index 4853683..0000000
--- a/recipes-core/xml-commons/jaxen_1.1.1.bb
+++ /dev/null
@@ -1,35 +0,0 @@
1DESCRIPTION = "XPath library written in Java"
2LICENSE = "BSD"
3
4HOMEPAGE = "http://jaxen.codehaus.org/"
5
6DEPENDS = "fastjar-native xerces-j xom"
7
8SRC_URI = "\
9 http://dist.codehaus.org/jaxen/distributions/jaxen-${PV}-src.tar.gz;name=archive \
10 http://www.jdom.org/dist/binary/archive/jdom-1.1.tar.gz;name=jdom \
11 "
12
13PNBLACKLIST[jaxen] ?= "BROKEN: depends on broken 'xom'"
14
15inherit java-library
16
17do_compile() {
18 mkdir -p build
19
20 oe_makeclasspath cp -s xercesImpl xom
21 scp="src/java/main:${WORKDIR}/jdom-1.1/src/java"
22
23 javac -sourcepath $scp -cp $cp -d build `find src/java/main -name "*.java" -and -not -wholename "*dom4j*"`
24 (cd src && find org -name "*.properties" -exec cp {} ../build/{} \;)
25
26 rm -rf build/org/jdom
27
28 fastjar -C build -c -f ${JARFILENAME} .
29}
30
31
32SRC_URI[archive.md5sum] = "b598ae6b7e765a92e13667b0a80392f4"
33SRC_URI[archive.sha256sum] = "f24ae604a20da87e3716bb1d441c483e56479eaef4e99888f41be06059790bca"
34SRC_URI[jdom.md5sum] = "22745cbaaddb12884ed8ee09083d8fe2"
35SRC_URI[jdom.sha256sum] = "a13549087141be24ad176b659afdc2c675f1ffa5288ff999a193d6d44a282056"