summaryrefslogtreecommitdiffstats
path: root/recipes-core/xerces-j/xerces-j_2.12.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/xerces-j/xerces-j_2.12.2.bb')
-rw-r--r--recipes-core/xerces-j/xerces-j_2.12.2.bb69
1 files changed, 69 insertions, 0 deletions
diff --git a/recipes-core/xerces-j/xerces-j_2.12.2.bb b/recipes-core/xerces-j/xerces-j_2.12.2.bb
new file mode 100644
index 0000000..bc2780e
--- /dev/null
+++ b/recipes-core/xerces-j/xerces-j_2.12.2.bb
@@ -0,0 +1,69 @@
1DESCRIPTION = "Reference implementation of XNI, the Xerces Native Interface, and also a fully conforming XML Schema processor."
2AUTHOR = "Apache Software Foundation"
3LICENSE = "Apache-2.0"
4
5PR = "r1"
6
7LIC_FILES_CHKSUM = " \
8 file://LICENSE;md5=d273d63619c9aeaf15cdaf76422c4f87 \
9 file://LICENSE.DOM-documentation.html;md5=77c27084ca92e9a8efe9314f284acc05 \
10 file://LICENSE.DOM-software.html;md5=1f920675d8473fd5cbabf133a7e39e0d \
11 file://LICENSE.resolver.txt;md5=d229da563da18fe5d58cd95a6467d584 \
12 file://LICENSE.serializer.txt;md5=d229da563da18fe5d58cd95a6467d584 \
13 "
14
15SRC_URI = "http://archive.apache.org/dist/xerces/j/source/Xerces-J-src.${PV}.tar.gz"
16
17# CVE only applies to some Oracle Java SE and Red Hat Enterprise Linux versions.
18# Already fixed with updates and closed.
19# https://access.redhat.com/security/cve/CVE-2018-2799
20# https://bugzilla.redhat.com/show_bug.cgi?id=1567542
21CVE_CHECK_WHITELIST += "CVE-2018-2799"
22
23S = "${WORKDIR}/xerces-2_12_2"
24
25inherit java-library
26
27JPN = "libxerces2-java"
28
29DEPENDS = "fastjar-native jaxp1.3 xml-commons-resolver1.1"
30
31RDEPENDS:${PN} = "libjaxp1.3-java libxml-commons-resolver1.1-java"
32RDEPENDS:${PN}:class-native = ""
33
34do_unpackpost[dirs] = "${B}"
35do_unpackpost() {
36 find src -exec \
37 sed -i -e "s|@impl.name@|Xerces-J ${PV}|" \
38 -e "s|@impl.version@|${PV}|" {} \;
39}
40
41addtask unpackpost after do_unpack before do_patch
42
43JARFILENAME = "xercesImpl.jar"
44ALTJARFILENAMES = ""
45
46do_compile() {
47 mkdir -p build
48
49 # Prepend the bootclasspath with the earlier XML API to make
50 # compilation succeed.
51 oe_makeclasspath bcp -s jaxp-1.3 resolver
52 bcp=$bcp:${STAGING_DATADIR_NATIVE}/classpath/glibj.zip
53
54 javac -sourcepath src -d build -cp $bcp `find src -name "*.java"`
55
56 (cd src && find org ! -name "*.java" -exec cp {} ../build/{} \;)
57
58 fastjar cfm ${JARFILENAME} src/manifest.xerces -C build .
59
60 # Like Debian we provide a symlink called xmlParserAPIs.jar pointing to the JAXP
61 # classes.
62 ln -sf ${D}${datadir_java}/xmlParserAPIs.jar jaxp-1.3.jar
63
64}
65
66SRC_URI[md5sum] = "41dde3c515fca8d307416123bc07a739"
67SRC_URI[sha256sum] = "6dd1ebd4c88e935c182375346cd7365514bd8dd2ad2f30f0d0b05257bab34ee8"
68
69BBCLASSEXTEND = "native"