summaryrefslogtreecommitdiffstats
path: root/recipes-core/openjdk/patches-openjdk-8/1010-hotspot-fix-shark-build-common.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/openjdk/patches-openjdk-8/1010-hotspot-fix-shark-build-common.patch')
-rw-r--r--recipes-core/openjdk/patches-openjdk-8/1010-hotspot-fix-shark-build-common.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/recipes-core/openjdk/patches-openjdk-8/1010-hotspot-fix-shark-build-common.patch b/recipes-core/openjdk/patches-openjdk-8/1010-hotspot-fix-shark-build-common.patch
index 8e70cab..711d17b 100644
--- a/recipes-core/openjdk/patches-openjdk-8/1010-hotspot-fix-shark-build-common.patch
+++ b/recipes-core/openjdk/patches-openjdk-8/1010-hotspot-fix-shark-build-common.patch
@@ -22,10 +22,10 @@ Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
22 14 files changed, 123 insertions(+), 12 deletions(-) 22 14 files changed, 123 insertions(+), 12 deletions(-)
23 23
24diff --git a/hotspot/make/Makefile b/hotspot/make/Makefile 24diff --git a/hotspot/make/Makefile b/hotspot/make/Makefile
25index ad195763b..53b5ea046 100644 25index de2607c71..3054c3fe8 100644
26--- a/hotspot/make/Makefile 26--- a/hotspot/make/Makefile
27+++ b/hotspot/make/Makefile 27+++ b/hotspot/make/Makefile
28@@ -525,7 +525,7 @@ $(EXPORT_INCLUDE_DIR)/%: $(SHARK_BUILD_DIR)/../generated/jvmtifiles/% 28@@ -536,7 +536,7 @@ $(EXPORT_INCLUDE_DIR)/%: $(SHARK_BUILD_DIR)/../generated/jvmtifiles/%
29 # Unix 29 # Unix
30 $(EXPORT_JRE_LIB_ARCH_DIR)/%.$(LIBRARY_SUFFIX): $(SHARK_BUILD_DIR)/%.$(LIBRARY_SUFFIX) 30 $(EXPORT_JRE_LIB_ARCH_DIR)/%.$(LIBRARY_SUFFIX): $(SHARK_BUILD_DIR)/%.$(LIBRARY_SUFFIX)
31 $(install-file) 31 $(install-file)
@@ -79,10 +79,10 @@ index 4707cc96e..a2b297ca0 100644
79 flow_block(blk, temp_vector, temp_set); 79 flow_block(blk, temp_vector, temp_set);
80 if (failing()) return; // Watch for bailouts. 80 if (failing()) return; // Watch for bailouts.
81diff --git a/hotspot/src/share/vm/classfile/systemDictionary.cpp b/hotspot/src/share/vm/classfile/systemDictionary.cpp 81diff --git a/hotspot/src/share/vm/classfile/systemDictionary.cpp b/hotspot/src/share/vm/classfile/systemDictionary.cpp
82index 98412e1e1..f62731c43 100644 82index df4d56f6f..b1dd335cb 100644
83--- a/hotspot/src/share/vm/classfile/systemDictionary.cpp 83--- a/hotspot/src/share/vm/classfile/systemDictionary.cpp
84+++ b/hotspot/src/share/vm/classfile/systemDictionary.cpp 84+++ b/hotspot/src/share/vm/classfile/systemDictionary.cpp
85@@ -2392,6 +2392,7 @@ methodHandle SystemDictionary::find_method_handle_intrinsic(vmIntrinsics::ID iid 85@@ -2371,6 +2371,7 @@ methodHandle SystemDictionary::find_method_handle_intrinsic(vmIntrinsics::ID iid
86 spe = NULL; 86 spe = NULL;
87 // Must create lots of stuff here, but outside of the SystemDictionary lock. 87 // Must create lots of stuff here, but outside of the SystemDictionary lock.
88 m = Method::make_method_handle_intrinsic(iid, signature, CHECK_(empty)); 88 m = Method::make_method_handle_intrinsic(iid, signature, CHECK_(empty));
@@ -90,7 +90,7 @@ index 98412e1e1..f62731c43 100644
90 if (!Arguments::is_interpreter_only()) { 90 if (!Arguments::is_interpreter_only()) {
91 // Generate a compiled form of the MH intrinsic. 91 // Generate a compiled form of the MH intrinsic.
92 AdapterHandlerLibrary::create_native_wrapper(m); 92 AdapterHandlerLibrary::create_native_wrapper(m);
93@@ -2401,6 +2402,7 @@ methodHandle SystemDictionary::find_method_handle_intrinsic(vmIntrinsics::ID iid 93@@ -2380,6 +2381,7 @@ methodHandle SystemDictionary::find_method_handle_intrinsic(vmIntrinsics::ID iid
94 "out of space in CodeCache for method handle intrinsic", empty); 94 "out of space in CodeCache for method handle intrinsic", empty);
95 } 95 }
96 } 96 }
@@ -98,7 +98,7 @@ index 98412e1e1..f62731c43 100644
98 // Now grab the lock. We might have to throw away the new method, 98 // Now grab the lock. We might have to throw away the new method,
99 // if a racing thread has managed to install one at the same time. 99 // if a racing thread has managed to install one at the same time.
100 { 100 {
101@@ -2414,9 +2416,11 @@ methodHandle SystemDictionary::find_method_handle_intrinsic(vmIntrinsics::ID iid 101@@ -2393,9 +2395,11 @@ methodHandle SystemDictionary::find_method_handle_intrinsic(vmIntrinsics::ID iid
102 } 102 }
103 103
104 assert(spe != NULL && spe->method() != NULL, ""); 104 assert(spe != NULL && spe->method() != NULL, "");