summaryrefslogtreecommitdiffstats
path: root/recipes-core/openjdk/openjdk-6-6b27/fix_hotspot_crosscompile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/openjdk/openjdk-6-6b27/fix_hotspot_crosscompile.patch')
-rw-r--r--recipes-core/openjdk/openjdk-6-6b27/fix_hotspot_crosscompile.patch51
1 files changed, 0 insertions, 51 deletions
diff --git a/recipes-core/openjdk/openjdk-6-6b27/fix_hotspot_crosscompile.patch b/recipes-core/openjdk/openjdk-6-6b27/fix_hotspot_crosscompile.patch
deleted file mode 100644
index 9741ed0..0000000
--- a/recipes-core/openjdk/openjdk-6-6b27/fix_hotspot_crosscompile.patch
+++ /dev/null
@@ -1,51 +0,0 @@
1Index: icedtea6-1.12.4/acinclude.m4
2===================================================================
3--- icedtea6-1.12.4.orig/acinclude.m4 2013-03-04 22:29:36.000000000 +0100
4+++ icedtea6-1.12.4/acinclude.m4 2013-03-10 13:45:56.032412186 +0100
5@@ -938,6 +938,21 @@
6 AC_SUBST(ALT_CACAO_SRC_DIR)
7 ])
8
9+AC_DEFUN([AC_CHECK_WITH_CC_FOR_BUILD],
10+[
11+ AC_MSG_CHECKING(for compiler used for subsidiary programs)
12+ AC_ARG_WITH([cc-for-build],
13+ [AS_HELP_STRING(--with-cc-for-build,specify the compiler for subsidiary (helper) programs)],
14+ [
15+ CC_FOR_BUILD="${withval}"
16+ ],
17+ [
18+ CC_FOR_BUILD="\$(CC)"
19+ ])
20+ AC_MSG_RESULT(${CC_FOR_BUILD})
21+ AC_SUBST(CC_FOR_BUILD)
22+])
23+
24 AC_DEFUN([IT_WITH_GCJ],
25 [
26 AC_MSG_CHECKING([whether to compile ecj natively])
27Index: icedtea6-1.12.4/Makefile.am
28===================================================================
29--- icedtea6-1.12.4.orig/Makefile.am 2013-03-10 13:44:55.000000000 +0100
30+++ icedtea6-1.12.4/Makefile.am 2013-03-10 13:46:27.540523062 +0100
31@@ -656,6 +656,7 @@
32 JAVAC="" \
33 JAVA_HOME="" \
34 JDK_HOME="" \
35+ CC_FOR_BUILD="$(CC_FOR_BUILD)" \
36 OE_CFLAGS="$(OE_CFLAGS)" \
37 OE_CPPFLAGS="$(OE_CPPFLAGS)" \
38 OE_CXXFLAGS="$(OE_CXXFLAGS)" \
39Index: icedtea6-1.12.4/configure.ac
40===================================================================
41--- icedtea6-1.12.4.orig/configure.ac 2013-03-04 22:38:51.000000000 +0100
42+++ icedtea6-1.12.4/configure.ac 2013-03-10 13:45:56.032412186 +0100
43@@ -18,6 +18,8 @@
44 AC_PROG_CC
45 AC_PROG_CXX
46
47+AC_CHECK_WITH_CC_FOR_BUILD
48+
49 IT_FIND_TOOL([MAKE], [make])
50 IT_FIND_TOOL([GZIP], [gzip])
51 IT_FIND_TOOL([ANT], [ant])