summaryrefslogtreecommitdiffstats
path: root/recipes-core/openjdk/openjdk-6-6b27/build-hacks.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/openjdk/openjdk-6-6b27/build-hacks.patch')
-rw-r--r--recipes-core/openjdk/openjdk-6-6b27/build-hacks.patch86
1 files changed, 0 insertions, 86 deletions
diff --git a/recipes-core/openjdk/openjdk-6-6b27/build-hacks.patch b/recipes-core/openjdk/openjdk-6-6b27/build-hacks.patch
deleted file mode 100644
index 1ecdef6..0000000
--- a/recipes-core/openjdk/openjdk-6-6b27/build-hacks.patch
+++ /dev/null
@@ -1,86 +0,0 @@
1Index: icedtea6-1.12.4/Makefile.am
2===================================================================
3--- icedtea6-1.12.4.orig/Makefile.am 2013-03-04 22:31:44.256894152 +0100
4+++ icedtea6-1.12.4/Makefile.am 2013-03-10 14:30:16.089527572 +0100
5@@ -656,6 +656,11 @@
6 JAVAC="" \
7 JAVA_HOME="" \
8 JDK_HOME="" \
9+ OE_CFLAGS="$(OE_CFLAGS)" \
10+ OE_CPPFLAGS="$(OE_CPPFLAGS)" \
11+ OE_CXXFLAGS="$(OE_CXXFLAGS)" \
12+ OE_LDFLAGS="$(OE_LDFLAGS)" \
13+ OE_LAUNCHER_LDFLAGS="$(OE_LAUNCHER_LDFLAGS)" \
14 ANT_RESPECT_JAVA_HOME="TRUE" \
15 DISTRIBUTION_ID="$(DIST_ID)" \
16 DERIVATIVE_ID="$(ICEDTEA_NAME) $(PACKAGE_VERSION)$(ICEDTEA_REV)" \
17@@ -2249,10 +2254,14 @@
18 if BUILD_JAMVM
19 cd jamvm/jamvm && \
20 LDFLAGS="-Xlinker -z -Xlinker noexecstack" \
21- ./autogen.sh --with-java-runtime-library=openjdk6 \
22- --prefix=$(abs_top_builddir)/jamvm/install ; \
23- $(MAKE) ; \
24- $(MAKE) install
25+ $(ARCH_PREFIX) ./autogen.sh --with-java-runtime-library=openjdk6 \
26+ --prefix=$(abs_top_builddir)/jamvm/install \
27+ --host=$(host_alias) \
28+ --build=$(build_alias) \
29+ --target=$(target_alias) \
30+ --with-libtool-sysroot=${ALT_FREETYPE_LIB_PATH} ; \
31+ $(ARCH_PREFIX) $(MAKE) ; \
32+ $(ARCH_PREFIX) $(MAKE) install
33 mkdir -p $(abs_top_builddir)/jamvm/install/hotspot/jre/lib/$(INSTALL_ARCH_DIR)/server
34 cp $(abs_top_builddir)/jamvm/install/lib/libjvm.so $(abs_top_builddir)/jamvm/install/hotspot/jre/lib/$(INSTALL_ARCH_DIR)/server
35 ln -sf server $(abs_top_builddir)/jamvm/install/hotspot/jre/lib/$(INSTALL_ARCH_DIR)/client
36@@ -2316,6 +2325,7 @@
37 --host=$(host_alias) \
38 --build=$(build_alias) \
39 --target=$(target_alias) \
40+ --with-libtool-sysroot=${ALT_FREETYPE_LIB_PATH} \
41 --prefix=$(abs_top_builddir)/cacao/install \
42 --with-java-runtime-library=openjdk \
43 --with-java-runtime-library-prefix=$(abs_top_builddir)/openjdk \
44@@ -2384,7 +2394,7 @@
45 # configure script arguments, quoted in single quotes
46 CONFIGURE_ARGS = @CONFIGURE_ARGS@
47 ADD_ZERO_CONFIGURE_ARGS = \
48- --with-jdk-home=$(BUILD_OUTPUT_DIR)/j2sdk-image \
49+ --with-jdk-home=$(abs_top_builddir)/bootstrap/jdk1.6.0 \
50 --enable-zero
51 if ADD_SHARK_BUILD
52 ADD_ZERO_CONFIGURE_ARGS += \
53Index: icedtea6-1.12.4/javac.in
54===================================================================
55--- icedtea6-1.12.4.orig/javac.in 2013-03-04 22:29:36.932613635 +0100
56+++ icedtea6-1.12.4/javac.in 2013-03-10 14:20:35.244778409 +0100
57@@ -18,7 +18,7 @@
58 {
59 my @new_args = @{$_[0]};
60
61- for my $opt (NO_DUP_ARGS)
62+ for my $opt (NO_DUP_ARGS)
63 {
64 my @indices = reverse grep {$new_args[$_] eq $opt} 0..$#new_args;
65 if (@indices > 1) {
66@@ -27,7 +27,7 @@
67 }
68 }
69
70- for my $opt (STRIP_ARGS)
71+ for my $opt (STRIP_ARGS)
72 {
73 my @indices = reverse grep {$new_args[$_] eq $opt} 0..$#new_args;
74 splice @new_args, $_, 1 for @indices;
75@@ -69,7 +69,10 @@
76 my @CLASSPATH = ('@ECJ_JAR@');
77 push @CLASSPATH, split /:/, $ENV{"CLASSPATH"} if exists $ENV{"CLASSPATH"};
78 $ENV{"CLASSPATH"} = join ':', @CLASSPATH;
79- exec '@JAVA@', @$vm_args, 'org.eclipse.jdt.internal.compiler.batch.Main', @ecj_parms, @$javac_args;
80+
81+ # Compiling hotspot-tools consumes tons of memory and exceeds any default
82+ # limits for jamvm and cacao.
83+ exec '@JAVA@', '-Xmx1024m', @$vm_args, 'org.eclipse.jdt.internal.compiler.batch.Main', @ecj_parms, @$javac_args;
84 }
85 else
86 {