diff options
Diffstat (limited to 'recipes-core/openjdk/openjdk-6-6b24')
-rw-r--r-- | recipes-core/openjdk/openjdk-6-6b24/cacao-arm-ucontext.patch | 24 | ||||
-rw-r--r-- | recipes-core/openjdk/openjdk-6-6b24/cacao-loadavg-makefile.patch | 11 |
2 files changed, 30 insertions, 5 deletions
diff --git a/recipes-core/openjdk/openjdk-6-6b24/cacao-arm-ucontext.patch b/recipes-core/openjdk/openjdk-6-6b24/cacao-arm-ucontext.patch new file mode 100644 index 0000000..c21fcf1 --- /dev/null +++ b/recipes-core/openjdk/openjdk-6-6b24/cacao-arm-ucontext.patch | |||
@@ -0,0 +1,24 @@ | |||
1 | Index: cacao-a567bcb7f589/src/vm/jit/arm/linux/md-os.c | ||
2 | =================================================================== | ||
3 | --- cacao-a567bcb7f589/src/vm/jit/arm/linux/md-os.c 2013-01-26 21:30:54.206581090 +0100 | ||
4 | +++ cacao-a567bcb7f589/src/vm/jit/arm/linux/md-os.c 2013-01-26 21:31:34.406991316 +0100 | ||
5 | @@ -28,19 +28,7 @@ | ||
6 | |||
7 | #include <stdint.h> | ||
8 | |||
9 | -#define ucontext broken_glibc_ucontext | ||
10 | -#define ucontext_t broken_glibc_ucontext_t | ||
11 | #include <ucontext.h> | ||
12 | -#undef ucontext | ||
13 | -#undef ucontext_t | ||
14 | - | ||
15 | -typedef struct ucontext { | ||
16 | - unsigned long uc_flags; | ||
17 | - struct ucontext *uc_link; | ||
18 | - stack_t uc_stack; | ||
19 | - struct sigcontext uc_mcontext; | ||
20 | - sigset_t uc_sigmask; | ||
21 | -} ucontext_t; | ||
22 | |||
23 | #define scontext_t struct sigcontext | ||
24 | |||
diff --git a/recipes-core/openjdk/openjdk-6-6b24/cacao-loadavg-makefile.patch b/recipes-core/openjdk/openjdk-6-6b24/cacao-loadavg-makefile.patch index 0f50c6c..95cb802 100644 --- a/recipes-core/openjdk/openjdk-6-6b24/cacao-loadavg-makefile.patch +++ b/recipes-core/openjdk/openjdk-6-6b24/cacao-loadavg-makefile.patch | |||
@@ -1,12 +1,13 @@ | |||
1 | Index: icedtea6/Makefile.am | 1 | Index: icedtea6-1.11.5/Makefile.am |
2 | =================================================================== | 2 | =================================================================== |
3 | --- icedtea6.orig/Makefile.am 2011-12-20 10:54:09.000000000 +0100 | 3 | --- icedtea6-1.11.5.orig/Makefile.am 2013-01-27 21:47:24.609119623 +0100 |
4 | +++ icedtea6/Makefile.am 2011-12-20 11:49:12.810009279 +0100 | 4 | +++ icedtea6-1.11.5/Makefile.am 2013-01-27 21:49:31.250516775 +0100 |
5 | @@ -1921,6 +1921,7 @@ | 5 | @@ -1993,6 +1993,8 @@ |
6 | if BUILD_CACAO | 6 | if BUILD_CACAO |
7 | if !USE_SYSTEM_CACAO | 7 | if !USE_SYSTEM_CACAO |
8 | cd cacao/cacao && \ | 8 | cd cacao/cacao && \ |
9 | + patch -p1 -N < $(abs_top_srcdir)/patches/cacao-loadavg.patch && \ | 9 | + patch -p1 -N < $(abs_top_srcdir)/patches/cacao-loadavg.patch && \ |
10 | + patch -p1 -N < $(abs_top_srcdir)/patches/cacao-arm-ucontext.patch && \ | ||
10 | rm -f libtool && \ | 11 | rm -f libtool && \ |
11 | ./autogen.sh && \ | 12 | ./autogen.sh && \ |
12 | $(ARCH_PREFIX) ./configure \ | 13 | $(ARCH_PREFIX) ./configure \ |