summaryrefslogtreecommitdiffstats
path: root/recipes-core/javasqlite/javasqlite_20150419.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/javasqlite/javasqlite_20150419.bb')
-rw-r--r--recipes-core/javasqlite/javasqlite_20150419.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes-core/javasqlite/javasqlite_20150419.bb b/recipes-core/javasqlite/javasqlite_20150419.bb
new file mode 100644
index 0000000..d721d66
--- /dev/null
+++ b/recipes-core/javasqlite/javasqlite_20150419.bb
@@ -0,0 +1,42 @@
1SUMMARY = "a Java wrapper including a basic JDBC driver for SQLite"
2
3DESCRIPTION = "\
4This is a Java wrapper including a basic JDBC driver for the SQLite 2/3 \
5database engine. It is designed using JNI to interface to the SQLite API. \
6That API is wrapped by methods in the SQLite.Database class."
7
8LICENSE = "BSD"
9SECTION = "application"
10PR = "r0"
11SRC_URI = " \
12 http://www.ch-werner.de/javasqlite/${BPN}-${PV}.tar.gz \
13 file://0001-fix-errors-during-cross-compile.patch \
14 "
15
16LIC_FILES_CHKSUM = "file://license.terms;md5=3da0e50feac5f64f08184584a8cad58a"
17
18inherit autotools-brokensep
19
20DEPENDS += "sqlite3 sqlite3-native icedtea7-native"
21RDEPENDS_${PN} += "sqlite3"
22FILES_${PN} +="/usr/share"
23
24PARALLEL_MAKE = "-j 1"
25
26SRC_URI[md5sum] = "242e384c1cd863d6996a35cf8c1c1e97"
27SRC_URI[sha256sum] = "b6b26e2c1a2174f5525d904eb3ff698c3f7089f0d4b4c84cf6121da08c8d801f"
28
29EXTRA_OECONF = " \
30 --with-sqlite3=${STAGING_DIR_NATIVE}/usr \
31 --with-sqlite3-target=${STAGING_DIR_TARGET}/usr \
32 --with-jdk=${STAGING_DIR_NATIVE}/usr/lib/jvm/icedtea7-native/ \
33 "
34
35EXTRA_OEMAKE = "DESTDIR=${D}"
36
37# This dev package contains an '.so' file used for JNI development
38INSANE_SKIP_${PN}-dev = "dev-elf"
39
40do_configure_append (){
41 cp ${S}/*-libtool ${S}/libtool
42}