summaryrefslogtreecommitdiffstats
path: root/recipes-core/jakarta-libs/log4j1.2_1.2.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/jakarta-libs/log4j1.2_1.2.17.bb')
-rw-r--r--recipes-core/jakarta-libs/log4j1.2_1.2.17.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-core/jakarta-libs/log4j1.2_1.2.17.bb b/recipes-core/jakarta-libs/log4j1.2_1.2.17.bb
new file mode 100644
index 0000000..b37eb05
--- /dev/null
+++ b/recipes-core/jakarta-libs/log4j1.2_1.2.17.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "Java library to help the programmer output log statements to a variety of output targets"
2AUTHOR = "Apache Software Foundation"
3LICENSE = "AL2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=f4ce41a6d1028498fcacde12f589bce7"
5
6SRC_URI = "http://archive.apache.org/dist/logging/log4j/${PV}/log4j-${PV}.tar.gz"
7
8inherit java-library
9
10DEPENDS = "gnumail gnujaf"
11DEPENDS_virtclass-native = "gnumail-native gnujaf-native"
12
13S = "${WORKDIR}/apache-log4j-${PV}"
14
15JARFILENAME = "log4j-${PV}.jar"
16ALTJARFILENAMES = "log4j-1.2.jar log4j1.2.jar"
17
18do_compile() {
19 mkdir -p build
20
21 oe_makeclasspath cp -s activation gnumail
22
23 # Built everything but the JMS and JMX classes (like in Debian)
24 javac -sourcepath src/main/java -cp $cp -d build `find src/main/java -name "*.java" -and -not \( -iwholename "*jms*" -or -iwholename "*jmx*" \)`
25
26 cp -R src/main/resources/* build/
27
28 fastjar -C build -c -f ${JARFILENAME} .
29}
30
31SRC_URI[md5sum] = "8218714e41ee0c6509dcfeafa2e1f53f"
32SRC_URI[sha256sum] = "a528e3771ee6234661b5eb0fa02e14faee89dfec38de94088c163ddf2a0a8663"
33
34BBCLASSEXTEND = "native"
35