summaryrefslogtreecommitdiffstats
path: root/recipes-core/icedtea/openjdk-7-03b147/icedtea-hotspot-make-arch-sane-for-x86.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/icedtea/openjdk-7-03b147/icedtea-hotspot-make-arch-sane-for-x86.patch')
-rw-r--r--recipes-core/icedtea/openjdk-7-03b147/icedtea-hotspot-make-arch-sane-for-x86.patch622
1 files changed, 622 insertions, 0 deletions
diff --git a/recipes-core/icedtea/openjdk-7-03b147/icedtea-hotspot-make-arch-sane-for-x86.patch b/recipes-core/icedtea/openjdk-7-03b147/icedtea-hotspot-make-arch-sane-for-x86.patch
new file mode 100644
index 0000000..be4a7d0
--- /dev/null
+++ b/recipes-core/icedtea/openjdk-7-03b147/icedtea-hotspot-make-arch-sane-for-x86.patch
@@ -0,0 +1,622 @@
1From bd7c262396b7e21311c0ef983743672eb245fed7 Mon Sep 17 00:00:00 2001
2From: Henning Heinold <heinold@inf.fu-berlin.de>
3Date: Wed, 14 Mar 2012 22:15:47 +0100
4Subject: [PATCH] foo
5
6---
7 hotspot/agent/make/saenv.sh | 4 +-
8 hotspot/make/defs.make | 4 +-
9 hotspot/make/jprt.properties | 98 +++---
10 hotspot/make/linux/build.sh | 2 +-
11 hotspot/make/linux/makefiles/buildtree.make | 4 +-
12 hotspot/make/linux/makefiles/defs.make | 24 +-
13 hotspot/make/linux/makefiles/gcc.make | 2 +-
14 hotspot/make/linux/makefiles/i486.make | 34 --
15 hotspot/make/linux/makefiles/sparcWorks.make | 2 +-
16 hotspot/make/linux/makefiles/x86.make | 34 ++
17 hotspot/make/linux/platform_i486 | 15 -
18 hotspot/make/linux/platform_x86 | 15 +
19 hotspot/src/os/linux/vm/os_linux.cpp | 6 +-
20 hotspot/src/os/posix/launcher/java_md.c | 26 +-
21 hotspot/src/share/tools/hsdis/Makefile | 4 +-
22 hotspot/src/share/tools/hsdis/hsdis.c | 500 ++++++++++++++++++++++++++
23 16 files changed, 637 insertions(+), 137 deletions(-)
24 delete mode 100644 hotspot/make/linux/makefiles/i486.make
25 create mode 100644 hotspot/make/linux/makefiles/x86.make
26 delete mode 100644 hotspot/make/linux/platform_i486
27 create mode 100644 hotspot/make/linux/platform_x86
28
29diff --git openjdk/hotspot/agent/make/saenv.sh openjdk/hotspot/agent/make/saenv.sh
30index 81c2d15..4cc3a28 100644
31--- openjdk/hotspot/agent/make/saenv.sh
32+++ openjdk/hotspot/agent/make/saenv.sh
33@@ -43,9 +43,9 @@ if [ "$OS" = "Linux" ]; then
34 OPTIONS="-Dsa.library.path=$SA_LIBPATH"
35 CPU=amd64
36 else
37- SA_LIBPATH=$STARTDIR/../src/os/linux/i386:$STARTDIR/linux/i386
38+ SA_LIBPATH=$STARTDIR/../src/os/linux/x86:$STARTDIR/linux/x86
39 OPTIONS="-Dsa.library.path=$SA_LIBPATH"
40- CPU=i386
41+ CPU=x86
42 fi
43 else
44 # configure audit helper library if SA_ALTROOT is set
45diff --git openjdk/hotspot/make/defs.make openjdk/hotspot/make/defs.make
46index fe6c4a2..7ae5b1e 100644
47--- openjdk/hotspot/make/defs.make
48+++ openjdk/hotspot/make/defs.make
49@@ -216,7 +216,7 @@ ifneq ($(OSNAME),windows)
50 ifdef LP64
51 BUILDARCH = amd64
52 else
53- BUILDARCH = i486
54+ BUILDARCH = x86
55 endif
56 endif
57 ifeq ($(BUILDARCH), sparc)
58@@ -227,7 +227,7 @@ ifneq ($(OSNAME),windows)
59
60 # LIBARCH is 1:1 mapping from BUILDARCH
61 LIBARCH = $(LIBARCH/$(BUILDARCH))
62- LIBARCH/i486 = i386
63+ LIBARCH/x86 = x86
64 LIBARCH/amd64 = amd64
65 LIBARCH/sparc = sparc
66 LIBARCH/sparcv9 = sparcv9
67diff --git openjdk/hotspot/make/jprt.properties openjdk/hotspot/make/jprt.properties
68index 4c88ed0..e35cb84 100644
69--- openjdk/hotspot/make/jprt.properties
70+++ openjdk/hotspot/make/jprt.properties
71@@ -106,19 +106,19 @@ jprt.my.solaris.x64.ejdk7=${jprt.my.solaris.x64.jdk7}
72 jprt.my.solaris.x64.ejdk6=${jprt.my.solaris.x64.jdk6}
73 jprt.my.solaris.x64=${jprt.my.solaris.x64.${jprt.tools.default.release}}
74
75-jprt.my.linux.i586.jdk8=linux_i586_2.6
76-jprt.my.linux.i586.jdk7=linux_i586_2.6
77-jprt.my.linux.i586.jdk7b107=linux_i586_2.6
78-jprt.my.linux.i586.jdk7temp=linux_i586_2.6
79-jprt.my.linux.i586.jdk6=linux_i586_2.4
80-jprt.my.linux.i586.jdk6perf=linux_i586_2.4
81-jprt.my.linux.i586.jdk6u10=linux_i586_2.4
82-jprt.my.linux.i586.jdk6u14=linux_i586_2.4
83-jprt.my.linux.i586.jdk6u18=linux_i586_2.4
84-jprt.my.linux.i586.jdk6u20=linux_i586_2.4
85-jprt.my.linux.i586.ejdk7=linux_i586_2.6
86-jprt.my.linux.i586.ejdk6=linux_i586_2.6
87-jprt.my.linux.i586=${jprt.my.linux.i586.${jprt.tools.default.release}}
88+jprt.my.linux.x86.jdk8=linux_x86_2.6
89+jprt.my.linux.x86.jdk7=linux_x86_2.6
90+jprt.my.linux.x86.jdk7b107=linux_x86_2.6
91+jprt.my.linux.x86.jdk7temp=linux_x86_2.6
92+jprt.my.linux.x86.jdk6=linux_x86_2.4
93+jprt.my.linux.x86.jdk6perf=linux_x86_2.4
94+jprt.my.linux.x86.jdk6u10=linux_x86_2.4
95+jprt.my.linux.x86.jdk6u14=linux_x86_2.4
96+jprt.my.linux.x86.jdk6u18=linux_x86_2.4
97+jprt.my.linux.x86.jdk6u20=linux_x86_2.4
98+jprt.my.linux.x86.ejdk7=linux_x86_2.6
99+jprt.my.linux.x86.ejdk6=linux_x86_2.6
100+jprt.my.linux.x86=${jprt.my.linux.x86.${jprt.tools.default.release}}
101
102 jprt.my.linux.x64.jdk8=linux_x64_2.6
103 jprt.my.linux.x64.jdk7=linux_x64_2.6
104@@ -209,7 +209,7 @@ jprt.build.targets.standard= \
105 ${jprt.my.solaris.sparcv9}-{product|fastdebug|debug}, \
106 ${jprt.my.solaris.i586}-{product|fastdebug|debug}, \
107 ${jprt.my.solaris.x64}-{product|fastdebug|debug}, \
108- ${jprt.my.linux.i586}-{product|fastdebug|debug}, \
109+ ${jprt.my.linux.x86}-{product|fastdebug|debug}, \
110 ${jprt.my.linux.x64}-{product|fastdebug}, \
111 ${jprt.my.windows.i586}-{product|fastdebug|debug}, \
112 ${jprt.my.windows.x64}-{product|fastdebug|debug}
113@@ -220,7 +220,7 @@ jprt.build.targets.open= \
114 ${jprt.my.linux.x64}-{productOpen}
115
116 jprt.build.targets.embedded= \
117- ${jprt.my.linux.i586}-{productEmb|fastdebugEmb|debugEmb}, \
118+ ${jprt.my.linux.x86}-{productEmb|fastdebugEmb|debugEmb}, \
119 ${jprt.my.linux.ppc}-{productEmb|fastdebugEmb}, \
120 ${jprt.my.linux.ppcv2}-{productEmb|fastdebugEmb}, \
121 ${jprt.my.linux.ppcsflt}-{productEmb|fastdebugEmb}, \
122@@ -364,33 +364,33 @@ jprt.my.solaris.i586.test.targets= \
123 ${jprt.my.solaris.i586}-fastdebug-c2-jbb_G1, \
124 ${jprt.my.solaris.i586}-fastdebug-c2-jbb_ParOldGC
125
126-jprt.my.linux.i586.test.targets = \
127- ${jprt.my.linux.i586}-{product|fastdebug}-{c1|c2}-jvm98, \
128- ${jprt.my.linux.i586}-{product|fastdebug}-c2-jvm98_tiered, \
129- ${jprt.my.linux.i586}-{product|fastdebug}-{c1|c2}-scimark, \
130- ${jprt.my.linux.i586}-product-c1-runThese_Xcomp, \
131- ${jprt.my.linux.i586}-fastdebug-c1-runThese_Xshare, \
132- ${jprt.my.linux.i586}-fastdebug-c2-runThese_Xcomp, \
133- ${jprt.my.linux.i586}-{product|fastdebug}-{c1|c2}-GCBasher_default, \
134- ${jprt.my.linux.i586}-{product|fastdebug}-{c1|c2}-GCBasher_SerialGC, \
135- ${jprt.my.linux.i586}-{product|fastdebug}-{c1|c2}-GCBasher_ParallelGC, \
136- ${jprt.my.linux.i586}-{product|fastdebug}-{c1|c2}-GCBasher_ParNewGC, \
137- ${jprt.my.linux.i586}-{product|fastdebug}-{c1|c2}-GCBasher_CMS, \
138- ${jprt.my.linux.i586}-{product|fastdebug}-{c1|c2}-GCBasher_G1, \
139- ${jprt.my.linux.i586}-{product|fastdebug}-{c1|c2}-GCBasher_ParOldGC, \
140- ${jprt.my.linux.i586}-product-{c1|c2}-GCOld_default, \
141- ${jprt.my.linux.i586}-product-{c1|c2}-GCOld_SerialGC, \
142- ${jprt.my.linux.i586}-product-{c1|c2}-GCOld_ParallelGC, \
143- ${jprt.my.linux.i586}-product-{c1|c2}-GCOld_ParNewGC, \
144- ${jprt.my.linux.i586}-product-{c1|c2}-GCOld_CMS, \
145- ${jprt.my.linux.i586}-product-{c1|c2}-GCOld_G1, \
146- ${jprt.my.linux.i586}-product-{c1|c2}-GCOld_ParOldGC, \
147- ${jprt.my.linux.i586}-{product|fastdebug}-c1-jbb_default, \
148- ${jprt.my.linux.i586}-{product|fastdebug}-c2-jbb_default_tiered, \
149- ${jprt.my.linux.i586}-{product|fastdebug}-c1-jbb_ParallelGC, \
150- ${jprt.my.linux.i586}-{product|fastdebug}-c1-jbb_CMS, \
151- ${jprt.my.linux.i586}-{product|fastdebug}-c1-jbb_G1, \
152- ${jprt.my.linux.i586}-{product|fastdebug}-c1-jbb_ParOldGC
153+jprt.my.linux.x86.test.targets = \
154+ ${jprt.my.linux.x86}-{product|fastdebug}-{c1|c2}-jvm98, \
155+ ${jprt.my.linux.x86}-{product|fastdebug}-c2-jvm98_tiered, \
156+ ${jprt.my.linux.x86}-{product|fastdebug}-{c1|c2}-scimark, \
157+ ${jprt.my.linux.x86}-product-c1-runThese_Xcomp, \
158+ ${jprt.my.linux.x86}-fastdebug-c1-runThese_Xshare, \
159+ ${jprt.my.linux.x86}-fastdebug-c2-runThese_Xcomp, \
160+ ${jprt.my.linux.x86}-{product|fastdebug}-{c1|c2}-GCBasher_default, \
161+ ${jprt.my.linux.x86}-{product|fastdebug}-{c1|c2}-GCBasher_SerialGC, \
162+ ${jprt.my.linux.x86}-{product|fastdebug}-{c1|c2}-GCBasher_ParallelGC, \
163+ ${jprt.my.linux.x86}-{product|fastdebug}-{c1|c2}-GCBasher_ParNewGC, \
164+ ${jprt.my.linux.x86}-{product|fastdebug}-{c1|c2}-GCBasher_CMS, \
165+ ${jprt.my.linux.x86}-{product|fastdebug}-{c1|c2}-GCBasher_G1, \
166+ ${jprt.my.linux.x86}-{product|fastdebug}-{c1|c2}-GCBasher_ParOldGC, \
167+ ${jprt.my.linux.x86}-product-{c1|c2}-GCOld_default, \
168+ ${jprt.my.linux.x86}-product-{c1|c2}-GCOld_SerialGC, \
169+ ${jprt.my.linux.x86}-product-{c1|c2}-GCOld_ParallelGC, \
170+ ${jprt.my.linux.x86}-product-{c1|c2}-GCOld_ParNewGC, \
171+ ${jprt.my.linux.x86}-product-{c1|c2}-GCOld_CMS, \
172+ ${jprt.my.linux.x86}-product-{c1|c2}-GCOld_G1, \
173+ ${jprt.my.linux.x86}-product-{c1|c2}-GCOld_ParOldGC, \
174+ ${jprt.my.linux.x86}-{product|fastdebug}-c1-jbb_default, \
175+ ${jprt.my.linux.x86}-{product|fastdebug}-c2-jbb_default_tiered, \
176+ ${jprt.my.linux.x86}-{product|fastdebug}-c1-jbb_ParallelGC, \
177+ ${jprt.my.linux.x86}-{product|fastdebug}-c1-jbb_CMS, \
178+ ${jprt.my.linux.x86}-{product|fastdebug}-c1-jbb_G1, \
179+ ${jprt.my.linux.x86}-{product|fastdebug}-c1-jbb_ParOldGC
180
181 jprt.my.linux.x64.test.targets = \
182 ${jprt.my.linux.x64}-{product|fastdebug}-c2-jvm98, \
183@@ -478,26 +478,26 @@ jprt.test.targets.open = \
184 ${jprt.my.linux.x64}-{productOpen|fastdebugOpen}-c2-jvm98_tiered
185
186 # Testing for actual embedded builds is different to standard
187-jprt.my.linux.i586.test.targets.embedded = \
188- linux_i586_2.6-product-c1-scimark
189+jprt.my.linux.x86.test.targets.embedded = \
190+ linux_x86_2.6-product-c1-scimark
191
192 # The complete list of test targets for jprt
193 # Note: no PPC or ARM tests at this stage
194
195 jprt.test.targets.standard = \
196- ${jprt.my.linux.i586.test.targets.embedded}, \
197+ ${jprt.my.linux.x86.test.targets.embedded}, \
198 ${jprt.my.solaris.sparc.test.targets}, \
199 ${jprt.my.solaris.sparcv9.test.targets}, \
200 ${jprt.my.solaris.i586.test.targets}, \
201 ${jprt.my.solaris.x64.test.targets}, \
202- ${jprt.my.linux.i586.test.targets}, \
203+ ${jprt.my.linux.x86.test.targets}, \
204 ${jprt.my.linux.x64.test.targets}, \
205 ${jprt.my.windows.i586.test.targets}, \
206 ${jprt.my.windows.x64.test.targets}, \
207 ${jprt.test.targets.open}
208
209 jprt.test.targets.embedded= \
210- ${jprt.my.linux.i586.test.targets.embedded}, \
211+ ${jprt.my.linux.x86.test.targets.embedded}, \
212 ${jprt.my.solaris.sparc.test.targets}, \
213 ${jprt.my.solaris.sparcv9.test.targets}, \
214 ${jprt.my.solaris.i586.test.targets}, \
215@@ -528,7 +528,7 @@ jprt.test.targets=${jprt.test.targets.${jprt.tools.default.release}}
216 jprt.make.rule.test.targets.standard.client = \
217 ${jprt.my.solaris.sparc}-*-c1-clienttest, \
218 ${jprt.my.solaris.i586}-*-c1-clienttest, \
219- ${jprt.my.linux.i586}-*-c1-clienttest, \
220+ ${jprt.my.linux.x86}-*-c1-clienttest, \
221 ${jprt.my.windows.i586}-*-c1-clienttest
222
223 jprt.make.rule.test.targets.standard.server = \
224@@ -536,7 +536,7 @@ jprt.make.rule.test.targets.standard.server = \
225 ${jprt.my.solaris.sparcv9}-*-c2-servertest, \
226 ${jprt.my.solaris.i586}-*-c2-servertest, \
227 ${jprt.my.solaris.x64}-*-c2-servertest, \
228- ${jprt.my.linux.i586}-*-c2-servertest, \
229+ ${jprt.my.linux.x86}-*-c2-servertest, \
230 ${jprt.my.linux.x64}-*-c2-servertest, \
231 ${jprt.my.windows.i586}-*-c2-servertest, \
232 ${jprt.my.windows.x64}-*-c2-servertest
233diff --git openjdk/hotspot/make/linux/build.sh openjdk/hotspot/make/linux/build.sh
234index f46b8df..b06853f 100644
235--- openjdk/hotspot/make/linux/build.sh
236+++ openjdk/hotspot/make/linux/build.sh
237@@ -43,7 +43,7 @@ esac
238
239 case `uname -m` in
240 i386|i486|i586|i686)
241- mach=i386
242+ mach=x86
243 ;;
244 *)
245 echo "Unsupported machine: " `uname -m`
246diff --git openjdk/hotspot/make/linux/makefiles/buildtree.make openjdk/hotspot/make/linux/makefiles/buildtree.make
247index f8a1e88..ce7b575 100644
248--- openjdk/hotspot/make/linux/makefiles/buildtree.make
249+++ openjdk/hotspot/make/linux/makefiles/buildtree.make
250@@ -30,7 +30,7 @@
251 # The macros ARCH, GAMMADIR, OS_FAMILY and VARIANT must be defined in the
252 # environment or on the command-line:
253 #
254-# ARCH - sparc, i486, ... HotSpot cpu and os_cpu source directory
255+# ARCH - sparc, x86, ... HotSpot cpu and os_cpu source directory
256 # BUILDARCH - build directory
257 # LIBARCH - the corresponding directory in JDK/JRE
258 # GAMMADIR - top of workspace
259@@ -371,7 +371,7 @@ NO_JAVA_HOME_MSG = \
260 DATA_MODE = $(DATA_MODE/$(BUILDARCH))
261 JAVA_FLAG = $(JAVA_FLAG/$(DATA_MODE))
262
263-DATA_MODE/i486 = 32
264+DATA_MODE/x86 = 32
265 DATA_MODE/sparc = 32
266 DATA_MODE/sparcv9 = 64
267 DATA_MODE/amd64 = 64
268diff --git openjdk/hotspot/make/linux/makefiles/defs.make openjdk/hotspot/make/linux/makefiles/defs.make
269index c327974..757b333 100644
270--- openjdk/hotspot/make/linux/makefiles/defs.make
271+++ openjdk/hotspot/make/linux/makefiles/defs.make
272@@ -72,6 +72,16 @@ ifeq ($(ARCH), sparc64)
273 HS_ARCH = sparc
274 endif
275
276+# x86
277+ifeq ($(findstring 86,$(ARCH)), 86)
278+ ifneq ($(ARCH), x86_64)
279+ ARCH_DATA_MODEL = 32
280+ PLATFORM = linux-x86
281+ VM_PLATFORM = linux_x86
282+ HS_ARCH = x86
283+ endif
284+endif
285+
286 # x86_64
287 ifeq ($(ARCH), x86_64)
288 ifeq ($(ARCH_DATA_MODEL), 64)
289@@ -82,22 +92,12 @@ ifeq ($(ARCH), x86_64)
290 HS_ARCH = x86
291 else
292 ARCH_DATA_MODEL = 32
293- PLATFORM = linux-i586
294- VM_PLATFORM = linux_i486
295+ PLATFORM = linux-x86
296+ VM_PLATFORM = linux_x86
297 HS_ARCH = x86
298- # We have to reset ARCH to i686 since SRCARCH relies on it
299- ARCH = i686
300 endif
301 endif
302
303-# i686
304-ifeq ($(ARCH), i686)
305- ARCH_DATA_MODEL = 32
306- PLATFORM = linux-i586
307- VM_PLATFORM = linux_i486
308- HS_ARCH = x86
309-endif
310-
311 # ARM
312 ifeq ($(ARCH), arm)
313 ARCH_DATA_MODEL = 32
314diff --git openjdk/hotspot/make/linux/makefiles/gcc.make openjdk/hotspot/make/linux/makefiles/gcc.make
315index 05505d4..1979420 100644
316--- openjdk/hotspot/make/linux/makefiles/gcc.make
317+++ openjdk/hotspot/make/linux/makefiles/gcc.make
318@@ -105,7 +105,7 @@ CFLAGS += -fvisibility=hidden
319 endif
320
321 ARCHFLAG = $(ARCHFLAG/$(BUILDARCH))
322-ARCHFLAG/i486 = -m32 -march=i586
323+ARCHFLAG/x86 = -m32
324 ARCHFLAG/amd64 = -m64
325 ARCHFLAG/ia64 =
326 ARCHFLAG/sparc = -m32 -mcpu=v9
327diff --git openjdk/hotspot/make/linux/makefiles/i486.make openjdk/hotspot/make/linux/makefiles/i486.make
328deleted file mode 100644
329index 86e825d..0000000
330--- openjdk/hotspot/make/linux/makefiles/i486.make
331+++ /dev/null
332@@ -1,34 +0,0 @@
333-#
334-# Copyright (c) 1999, 2010, Oracle and/or its affiliates. All rights reserved.
335-# DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
336-#
337-# This code is free software; you can redistribute it and/or modify it
338-# under the terms of the GNU General Public License version 2 only, as
339-# published by the Free Software Foundation.
340-#
341-# This code is distributed in the hope that it will be useful, but WITHOUT
342-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
343-# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
344-# version 2 for more details (a copy is included in the LICENSE file that
345-# accompanied this code).
346-#
347-# You should have received a copy of the GNU General Public License version
348-# 2 along with this work; if not, write to the Free Software Foundation,
349-# Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA.
350-#
351-# Please contact Oracle, 500 Oracle Parkway, Redwood Shores, CA 94065 USA
352-# or visit www.oracle.com if you need additional information or have any
353-# questions.
354-#
355-#
356-
357-# TLS helper, assembled from .s file
358-
359-# The copied fdlibm routines in sharedRuntimeTrig.o must not be optimized
360-OPT_CFLAGS/sharedRuntimeTrig.o = $(OPT_CFLAGS/NOOPT)
361-# The copied fdlibm routines in sharedRuntimeTrans.o must not be optimized
362-OPT_CFLAGS/sharedRuntimeTrans.o = $(OPT_CFLAGS/NOOPT)
363-# Must also specify if CPU is little endian
364-CFLAGS += -DVM_LITTLE_ENDIAN
365-
366-OPT_CFLAGS/compactingPermGenGen.o = -O1
367diff --git openjdk/hotspot/make/linux/makefiles/sparcWorks.make openjdk/hotspot/make/linux/makefiles/sparcWorks.make
368index 6e6c841..78e5041 100644
369--- openjdk/hotspot/make/linux/makefiles/sparcWorks.make
370+++ openjdk/hotspot/make/linux/makefiles/sparcWorks.make
371@@ -33,7 +33,7 @@ HOSTCPP = $(CPP)
372 HOSTCC = $(CC)
373
374 ARCHFLAG = $(ARCHFLAG/$(BUILDARCH))
375-ARCHFLAG/i486 = -m32
376+ARCHFLAG/x86 = -m32
377 ARCHFLAG/amd64 = -m64
378
379 CFLAGS += $(ARCHFLAG)
380diff --git openjdk/hotspot/make/linux/makefiles/x86.make openjdk/hotspot/make/linux/makefiles/x86.make
381new file mode 100644
382index 0000000..86e825d
383--- /dev/null
384+++ openjdk/hotspot/make/linux/makefiles/x86.make
385@@ -0,0 +1,34 @@
386+#
387+# Copyright (c) 1999, 2010, Oracle and/or its affiliates. All rights reserved.
388+# DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
389+#
390+# This code is free software; you can redistribute it and/or modify it
391+# under the terms of the GNU General Public License version 2 only, as
392+# published by the Free Software Foundation.
393+#
394+# This code is distributed in the hope that it will be useful, but WITHOUT
395+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
396+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
397+# version 2 for more details (a copy is included in the LICENSE file that
398+# accompanied this code).
399+#
400+# You should have received a copy of the GNU General Public License version
401+# 2 along with this work; if not, write to the Free Software Foundation,
402+# Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA.
403+#
404+# Please contact Oracle, 500 Oracle Parkway, Redwood Shores, CA 94065 USA
405+# or visit www.oracle.com if you need additional information or have any
406+# questions.
407+#
408+#
409+
410+# TLS helper, assembled from .s file
411+
412+# The copied fdlibm routines in sharedRuntimeTrig.o must not be optimized
413+OPT_CFLAGS/sharedRuntimeTrig.o = $(OPT_CFLAGS/NOOPT)
414+# The copied fdlibm routines in sharedRuntimeTrans.o must not be optimized
415+OPT_CFLAGS/sharedRuntimeTrans.o = $(OPT_CFLAGS/NOOPT)
416+# Must also specify if CPU is little endian
417+CFLAGS += -DVM_LITTLE_ENDIAN
418+
419+OPT_CFLAGS/compactingPermGenGen.o = -O1
420diff --git openjdk/hotspot/make/linux/platform_i486 openjdk/hotspot/make/linux/platform_i486
421deleted file mode 100644
422index 610ac91..0000000
423--- openjdk/hotspot/make/linux/platform_i486
424+++ /dev/null
425@@ -1,15 +0,0 @@
426-os_family = linux
427-
428-arch = x86
429-
430-arch_model = x86_32
431-
432-os_arch = linux_x86
433-
434-os_arch_model = linux_x86_32
435-
436-lib_arch = i386
437-
438-compiler = gcc
439-
440-sysdefs = -DLINUX -D_GNU_SOURCE -DIA32
441diff --git openjdk/hotspot/make/linux/platform_x86 openjdk/hotspot/make/linux/platform_x86
442new file mode 100644
443index 0000000..5c613fe
444--- /dev/null
445+++ openjdk/hotspot/make/linux/platform_x86
446@@ -0,0 +1,15 @@
447+os_family = linux
448+
449+arch = x86
450+
451+arch_model = x86_32
452+
453+os_arch = linux_x86
454+
455+os_arch_model = linux_x86_32
456+
457+lib_arch = x86
458+
459+compiler = gcc
460+
461+sysdefs = -DLINUX -D_GNU_SOURCE -DIA32
462diff --git openjdk/hotspot/src/os/linux/vm/os_linux.cpp openjdk/hotspot/src/os/linux/vm/os_linux.cpp
463index dd75c42..dd91767 100644
464--- openjdk/hotspot/src/os/linux/vm/os_linux.cpp
465+++ openjdk/hotspot/src/os/linux/vm/os_linux.cpp
466@@ -261,10 +261,10 @@ bool os::have_special_privileges() {
467
468
469 #ifndef SYS_gettid
470-// i386: 224, ia64: 1105, amd64: 186, sparc 143
471+// x86: 224, ia64: 1105, amd64: 186, sparc 143
472 #ifdef __ia64__
473 #define SYS_gettid 1105
474-#elif __i386__
475+#elif __x86__
476 #define SYS_gettid 224
477 #elif __amd64__
478 #define SYS_gettid 186
479@@ -281,7 +281,7 @@ static char cpu_arch[] = ZERO_LIBARCH;
480 #elif defined(IA64)
481 static char cpu_arch[] = "ia64";
482 #elif defined(IA32)
483-static char cpu_arch[] = "i386";
484+static char cpu_arch[] = "x86";
485 #elif defined(AMD64)
486 static char cpu_arch[] = "amd64";
487 #elif defined(ARM)
488diff --git openjdk/hotspot/src/os/posix/launcher/java_md.c openjdk/hotspot/src/os/posix/launcher/java_md.c
489index 3ee0f20..29374ea 100644
490--- openjdk/hotspot/src/os/posix/launcher/java_md.c
491+++ openjdk/hotspot/src/os/posix/launcher/java_md.c
492@@ -57,8 +57,8 @@
493 * models is supported, then DUAL_MODE is defined. When DUAL_MODE is
494 * defined, the architecture names for the narrow and wide version of
495 * the architecture are defined in LIBARCH64NAME and LIBARCH32NAME. Currently
496- * only Solaris on sparc/sparcv9 and i586/amd64 is DUAL_MODE; linux
497- * i586/amd64 could be defined as DUAL_MODE but that is not the
498+ * only Solaris on sparc/sparcv9 and x86/amd64 is DUAL_MODE; linux
499+ * x86/amd64 could be defined as DUAL_MODE but that is not the
500 * current policy.
501 */
502
503@@ -1175,7 +1175,7 @@ get_cpuid(uint32_t arg,
504
505 #endif /* __sun && i586 */
506
507-#if defined(__linux__) && defined(i586)
508+#if defined(__linux__) && defined(x86)
509
510 /*
511 * A utility method for asking the CPU about itself.
512@@ -1240,11 +1240,11 @@ get_cpuid(uint32_t arg,
513 #endif
514 }
515
516-#endif /* __linux__ && i586 */
517+#endif /* __linux__ && x86 */
518
519-#ifdef i586
520+#if defined(i586) || defined(x86)
521 /*
522- * Routines shared by solaris-i586 and linux-i586.
523+ * Routines shared by solaris-i586 and linux-x86.
524 */
525
526 enum HyperThreadingSupport_enum {
527@@ -1384,7 +1384,7 @@ physical_processors(void) {
528 return result;
529 }
530
531-#endif /* i586 */
532+#endif /* i586 || x86 */
533
534 #if defined(__sun) && defined(i586)
535
536@@ -1419,11 +1419,11 @@ solaris_i586_ServerClassMachine(void) {
537
538 #endif /* __sun && i586 */
539
540-#if defined(__linux__) && defined(i586)
541+#if defined(__linux__) && defined(x86)
542
543-/* The definition of a server-class machine for linux-i586 */
544+/* The definition of a server-class machine for linux-x86 */
545 jboolean
546-linux_i586_ServerClassMachine(void) {
547+linux_x86_ServerClassMachine(void) {
548 jboolean result = JNI_FALSE;
549 /* How big is a server class machine? */
550 const unsigned long server_processors = 2UL;
551@@ -1450,7 +1450,7 @@ linux_i586_ServerClassMachine(void) {
552 return result;
553 }
554
555-#endif /* __linux__ && i586 */
556+#endif /* __linux__ && x86 */
557
558 /* Dispatch to the platform-specific definition of "server-class" */
559 jboolean
560@@ -1464,8 +1464,8 @@ ServerClassMachine(void) {
561 result = solaris_sparc_ServerClassMachine();
562 #elif defined(__sun) && defined(i586)
563 result = solaris_i586_ServerClassMachine();
564-#elif defined(__linux__) && defined(i586)
565- result = linux_i586_ServerClassMachine();
566+#elif defined(__linux__) && defined(x86)
567+ result = linux_x86_ServerClassMachine();
568 #else
569 if (_launcher_debug) {
570 printf("ServerClassMachine: returns default value of %s\n",
571diff --git openjdk/hotspot/src/share/tools/hsdis/Makefile openjdk/hotspot/src/share/tools/hsdis/Makefile
572index 19f9cdb..b2b9092 100644
573--- openjdk/hotspot/src/share/tools/hsdis/Makefile
574+++ openjdk/hotspot/src/share/tools/hsdis/Makefile
575@@ -25,7 +25,7 @@
576 # Single gnu makefile for solaris, linux and windows (windows requires cygwin and mingw)
577
578 # Default arch; it is changed below as needed.
579-ARCH = i386
580+ARCH = x86
581 OS = $(shell uname)
582
583 ## OS = SunOS ##
584@@ -40,7 +40,7 @@ ifdef LP64
585 ifeq ($(ARCH),sparc)
586 ARCH = sparcv9
587 endif
588-ifeq ($(ARCH),i386)
589+ifeq ($(ARCH),x86)
590 ARCH = amd64
591 endif
592 endif
593diff --git openjdk/hotspot/src/share/tools/hsdis/hsdis.c openjdk/hotspot/src/share/tools/hsdis/hsdis.c
594index daea404..2e49766 100644
595--- openjdk/hotspot/src/share/tools/hsdis/hsdis.c
596+++ openjdk/hotspot/src/share/tools/hsdis/hsdis.c
597@@ -384,8 +384,8 @@ static void print_help(struct hsdis_app_data* app_data,
598 else
599 disassembler_usage(stderr); /* better than nothing */
600 (*printf_callback)(printf_stream, " mach=<arch> select disassembly mode\n");
601-#if defined(LIBARCH_i386) || defined(LIBARCH_amd64)
602- (*printf_callback)(printf_stream, " mach=i386 select 32-bit mode\n");
603+#if defined(LIBARCH_x86) || defined(LIBARCH_amd64)
604+ (*printf_callback)(printf_stream, " mach=x86 select 32-bit mode\n");
605 (*printf_callback)(printf_stream, " mach=x86-64 select 64-bit mode\n");
606 (*printf_callback)(printf_stream, " suffix always print instruction suffix\n");
607 #endif
608@@ -406,11 +406,11 @@ static const bfd_arch_info_type* find_arch_info(const char* arch_name) {
609
610 static const char* native_arch_name() {
611 const char* res = NULL;
612-#ifdef LIBARCH_i386
613- res = "i386";
614+#ifdef LIBARCH_x86
615+ res = "x86";
616 #endif
617 #ifdef LIBARCH_amd64
618- res = "i386:x86-64";
619+ res = "x86-64";
620 #endif
621 #ifdef LIBARCH_sparc
622 res = "sparc:v8plusb";